An export already exists for the host string

Brief description of the problem

New to Rockstor, so I probably have bungled something somewhere. Additionally, while I have many years of linux experience, I’ve never quite gotten NFS right… so the likely hood of buglement there is quite high.

I created an NFS export, but then realized that I needed no_root_squash. At first I thought I needed to use advanced editing to get this, and it appeared that I could only do that while creating an export. So I deleted the export I had already made, and added one through advanced editing. But that didn’t show up under exports, which didn’t seem right, so I deleted that and went back to the regular creation screen. I then saw that the admin ip option sets no_root_squash, so I tried re-making the share with that… only to get the error in the screenshot.

Any suggestions would be appreciated. Thanks!

Detailed step by step instructions to reproduce the problem

I think these are the steps I took

  1. Create an NFS share using the normal screen
  2. Delete the share
  3. Create (or attempt to) the share via advanced editing
  4. Delete the share from the advanced editor
  5. Attempt to create the share using the “Add NFS Export” button
  6. Get the error message
  7. Delete all references to the IP using the system shell, directly editing /etc/exports
  8. Attempt to create the share using the “Add NFS Export” button
  9. Get the error message

Web-UI screenshot

Error Traceback provided on the Web-UI

NoneType: None (note, the whitespace and newlines was not a mistake; that was in the error message)
1 Like