Balance Error during Raid Conversion from Raid 1 to Raid5

Brief description of the problem


Yesterday I Hadded 2 Disk on my Raid 1 Pool and I started a RAID conversion (from Raid 1 to Raid 5).
After 7% the Balance crashed.
After a reboot my pool was unmounted and impossible to remount.
I made the new mistake of deleting my pool and try to reimport it. I Have the following Error (See Traceback)

Can you help me plz?


Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/storageadmin/views/", line 706, in _btrfs_disk_import mount_root(po) File "/opt/rockstor/src/rockstor/fs/", line 253, in mount_root run_command(mnt_cmd) File "/opt/rockstor/src/rockstor/system/", line 121, in run_command raise CommandException(cmd, out, err, rc) CommandException: Error running a command. cmd = /bin/mount /dev/disk/by-label/NetDrive2 /mnt2/NetDrive2. rc = 32. stdout = ['']. stderr = ['mount: wrong fs type, bad option, bad superblock on /dev/sdd,', ' missing codepage or helper program, or other error', '', ' In some cases useful info is found in syslog - try', ' dmesg | tail or so.', '']

@Croky Welcome to the Rockstor community.

It may have been possible to mount it degraded, or did you try that. Or to mount it read only (ro) and retrieve the data. But:


Oh dear. This is probably bad, but not necessarily (fingers crossed). Best to start with posting here what the command line thinks is going on re your systems btrfs state. If you post the output of the following command in this thread folks here may be able to assess if there is hope:

btrfs fi show

You could also attempt a read only mount to /mnt2/pool-name-here Rockstor may then be able to import it in it’s read only state, if your Rockstor is new enough. What version of Rockstor are you running:

yum info rockstor

should give this info.

Another thing to try is our Release candidate 5 of Rockstor 4, via a DIY build of the installer. That has a far newer kernel and btrfs which should be far better at mounting poorly pools, although you may still only be able to mount read only as that is a common limitation with poorly pools but at least allows back refreshes. Or possible degraded or ro,degraded.

Our DIY Rockstor 4 installer build instructions. Just make sure to detach your existing data disks before doing a re-install, just in case you accidentally select on as the system disk and end up wiping it.

Sometime mount my label, our first approach, can fail. A reboot / power cycle can fix this. See the “Only one disk of a multi-volume filesystem will mount” section here:

Then you need to ensure that you run a btrfs device scan first:

btrfs device scan

In later versions of Rockstor we do run this command more and have fixed some fail through to try and mount by each device in turn if mount my label fails.

Hope that helps.

1 Like

Thanks for the answer…
I tried all the command I found on the net…
Mount in read-only; mount in degraded mode; I found errors (in tree root?); I tried btrfs commands to repair it without any success…
As all my data where still on the disk I decide to parse my disk with a recovery tool… It will take a long time but I hope it will work…
And for the very important data (work, photo, …) I have other backup so it’s very unpleasant but after all it’s my fault…
And I’m using rockstor 3.9.1; the free version.
I things that I will reinstall all properly with the last version when my data will be restored… And only create Raid 1 pools… (more secure).

Thanks for the help