Cannot access web-ui [Fixed]

I literally just installed Rockstor and after the first boot-up I got to the expected login screen with a sentence telling me about the web ui. However, no matter what I do, I cannot access it?

I can ping and ssh the Rockstor server (, but I can’t get to the web ui using Google Chrome simply says “ERR_CONNECTION_REFUSED”.

Tried a few google searches, but came up empty. Has anyone else experienced this?

I found this thread in the “Suggested Topics” after I created my own thread. I wonder why that didn’t show on any of my forum searches… Anyway, looks like I have the same problem as he did with BTRFS not being chosen. Weird… Anyway, I will re-install!

This is my first time using RockStor. I installed Rockstor-3.8-7 from a CD onto a flash drive. If I encrypt the flash drive during the installation, I cannot connect to the web ui using the IP address that RockStor provides. I enter my passphrase during the startup and am able to login as root.

I tried the installation again, but did not encrypt the drive and I can connect to the web ui. Just to make sure it was encryption causing the problem, I reinstalled RockStor, encrypted the flash drive during the setup, and I cannot connect to the web ui.

I followed the instructions in New Install, WebUI Issues with my drive encrypted. I was able to connect using SSH. /opt/rockstor/.initrock did not exist
Below is the output when I ran /opt/rockstor/bin/initrock:

[root@Rockstor ~]# cd /opt/rockstor/bin
[root@Rockstor bin]# ./initrock
2015-09-27 01:13:00,686: Supported kernel(/boot/vmlinuz-4.1.0-1.el7.elrepo.x86_64) is already the default
2015-09-27 01:13:00,772: Checking for flash and Running flash optimizations if appropriate.
Traceback (most recent call last):
  File "./initrock", line 43, in <module>
  File "/opt/rockstor/src/rockstor/scripts/", line 194, in main
    run_command([FLASH_OPTIMIZE, '-x'])
  File "/opt/rockstor/src/rockstor/system/", line 85, in run_command
    raise CommandException(cmd, out, err, rc)
system.exceptions.CommandException: Error running a command. cmd = ['/opt/rockstor//bin/flash-optimize', '-x']. rc = 1. stdout = ['']. stderr = ['2015-09-27 01:13:01,218: Root drive is dm-', '2015-09-27 01:13:01,218: Checking for TRIM support on dm-', 'Traceback (most recent call last):', '  File "/opt/rockstor//bin/flash-optimize", line 43, in <module>', '    sys.exit(scripts.flash_optimize.main())', '  File "/opt/rockstor/src/rockstor/scripts/", line 166, in main', '    if (trim_support(rd) is True):', '  File "/opt/rockstor/src/rockstor/scripts/", line 79, in trim_support', "    o, e, rc = run_command(['hdparm', '-I', '/dev/%s' % disk])", '  File "/opt/rockstor/src/rockstor/system/", line 85, in run_command', '    raise CommandException(cmd, out, err, rc)', "system.exceptions.CommandException: Error running a command. cmd = ['hdparm', '-I', '/dev/dm-']. rc = 2. stdout = ['']. stderr = ['/dev/dm-: No such file or directory', '']", '']
[root@Rockstor bin]#

Please let me know what else I can do to help troubleshoot this. My workaround is to install onto another flash drive without using encryption, so I can continue to evaluate RockStor.

1 Like

Thanks for reporting this @jdiver919. Seems like a serious enough problem to fix sooner than later. Here’s the issue for it to keep track.

I had this problem too.
The new installation is not changed.
The problem is that automatic setup disk using LVM for root (/) file system.
RockStor required to run BTRFS.
Just when installing manually set the ROOT to BTRFS and everything works as it should.

(/boot needs to be set on EXT4).

Just want to circle back and update that the issue filed by me in response to the initrock failure/error is resolved and pushed as part of 3.8-8 update.

Currently having this issue, went to github site for the fix (“don’t bail fi flash_optimize fails”) but my newbie status don’t understand how to enable the fix. Any help would be appreciated, thanks in advance

@elvincent First off welcome to the Rockstor community.

The fix mentioned within this thread is already incorporated in current versions of Rockstor. You would be better off starting a new thread that explains as much as your can about your particular issue, including what steps you took to end up in the problem situation. Also make sure to include the version of Rockstor you are running.

Hope that helps.