Cannot upgrade to Testing or Stable?

Hi, I have Rocksto 4.1.00 and I tried to update through the Webui it would seemingly go through the upgrade. And then at the end nothing would have changed.

So I logged into SSH to upgrade via Yum Upgrade. This was to the testing channel and it said there was no way to upgrade from to (I cannot remember the exact error it gave).

I paid for a subscription to Rockstor to enable the stable channel thinking this would fix it. And still cannot upgrade.

When I put in Yum Upgrade it says

“Last metadata expiration check: 0:01:34 ago on Thu Dec 7 17:19:21 2023.
allow_vendor_change is disabled. This option is currently not supported for downgrade and distro-sync commands
Dependencies resolved.
Nothing to do.

It won’t let me upgrade via the Web UI it just says to press control shift and R to refresh but nothing changes.

Please, can someone help on how I fix this to upgrade to the latest stable version of Rockstor?

@AnthGood Hello again.

This may simply be down to us not publishing anything newer (in the Stable channel) than v4.1.0-0 for your base OS.

Take a look at the following summary for our next Milestone:

And more specifically in the 4.6.* forum changelog:

So it is likelyt that you are still on a Leap 15.3 base: where 4.1.0-0 was latest in stable channel. We now have a Web-UI indicator but you should be able to see with your older version by mouse-over on the Uses … bit in the top-right of the Web-UI. It should then indicate your openSUSE base OS. We then have the following HowTo’s to upgrade in place: depending on what the mouse-over indicator reads.
and / or only:

Let us know here what your mouse over states to be sure.

Hope that helps.

Incidentally, we only use yum/dnf to get changelogs. As you have likely already worked out, openSUSE uses zypper - as do we, for all actual update.


Edited from original reply.

I have went through this

and its now showing 15.4 and

Thanks for your help