Can't install newest Rockstor

I have a DELL R815 server with a raid.

When I try to install Rockstor, I put in my usb drive (and I have tired a CD as well), and after it loads up grub and asks me what I want to do, it starts the installer and the installer says “No device(s) for install found” and my only option is to quit.

@JustARockStorUser Hello again.

What raid hardware is this. Likely you have a controller that is either not exposing it’s drives in a way our installer can see or we are without the required driver. With details of the hardware it would be possible to track down the drive that may not be loaded by default. Or there may be a kernel option to specify a mode that it needs in order to be seen. I’ve seen something similar with some older raid controllers.

Another option, if the installer can’t see the intended system drive but the installed instance can (without doing a custom installer build of course) would be to attache a drive that can be seen. Just by way of a work around.

So as much hardware info as you can as that will help others here on the forum advise if they have familiarity.

Again as in you prior post, there is also the option to try retrofitting a Rockstor install on-top of a generic openSUSE Leap 15.2 or 15.3 install.

Also can you state, as request previously, if you tried both installers. There are options based on leap 15.2 or 15.3, with the latter preferred. But getting you off the ground is the main thing here.

Hope that helps.

Dell R815

256 gigs of ram

4 processors with 16 cores in each totaling 64 processors. (Opteron™)

PERC 700 (6g with 512MB battery-backed cache)

Not sure what else might be needed.

1 Like

And do you experience the same missing disks issue on our v4 installer one both the 15.2 and 15.3 variants. Definitely worth a try.

Hope that helps.

When I say I tried the installers, I only tried the newest, 15.3. I tried to install it via USB and CDROM (because the error provided isn’t super helpful … either it can’t find itself to install the stuff or it can’t find the drive it needs to install itself on). I did try doing

insmode=ide-generic in the build before I ran it, this didn’t help.

I did not try the 15.2 installer, at all.


More likely the latter I think.

Worth a try, just in case. Plus it should take that long to have a go. You can always “zypper dup” from a 15.2 to a 15.3 base if it comes to that.

Hope that helps.