Deleting Shares

At a loss here. Trying to delete a share.

        Traceback (most recent call last):

File “/opt/rockstor/eggs/gunicorn-19.7.1-py2.7.egg/gunicorn/workers/”, line 68, in run_for_one
File “/opt/rockstor/eggs/gunicorn-19.7.1-py2.7.egg/gunicorn/workers/”, line 27, in accept
client, addr = listener.accept()
File “/usr/lib64/python2.7/”, line 202, in accept
sock, addr = self._sock.accept()
error: [Errno 11] Resource temporarily unavailable

Seems multiple problems creping up.
Your guidance is always appreciated.
Rock On… hehe…

@dvanremortel Hello again.

This may be down to what has now, hopefully, been addressed in the stable channel as from 3.9.2-12 via:

What version of Rockstor are you seeing this on. I know you had both a stable and a testing install at one point?

If you follow the forum link in that issue it gives more info, and a work around, on what was found to occasionally block share (subvol) deletion. Linking to @Haioken and @Rene_Castberg 's thread here for convenience:

Hope that helps.

Hey, thank you for the reply.

I have the lastest version of Rockstor, I removed the non-production edition I had running.
Simply put, I had TWO shares. File and Media. I was able to successfully remove the Files share without issue, when I tried to remove the Media share it gave me the error I shared.

I then tried to remove the POOL and that removed the pool and the share. So not sure what the issue was.