Dev log for upcoming 3.8-13


(suman chakravartula) #1

Hello Everyone,

It’s great to see continued activity in the forum, though I have taken a short break after 3.8-12. I am catching up and would like to thank everyone that’s been providing feedback via forum and e-mails and of course! pull requests!

So let’s kick off 3.8-13 cycle with our first update: 3.8-12.02. Those of you on testing channel, please test away!

3.8-12.02 comes with two S.M.A.R.T related improvements, thanks to @phillxnet! and also the kernel is updated to 4.4.5. I’ve heard from a few users that ran into problems with 4.3 kernel, some with USB root drive and others with recovering Pools. I don’t know if 4.4.5 solves the USB issue completely, but let me know. @roweryan


(suman chakravartula) #2

(Karsten Vinding) #3

After updating to this version (and rebooting) the dashboard widgets do not seem to update.

Also the version number in the upper right hand corner does not appear.

Both errors are visible in the screenshot below

Otherwise everything seems to work, Samba is online, and so are Rockon’s.

According to DMESG kernel version is 4.4.5 and BTRFS is 4.4.1.


(Mirko Arena) #4

@suman as i told via private message got the same issue and found the problem:

Error from Chrome console:
Failed to load resource: the server responded with a status of 502 (Bad Gateway)

Rockstor web ui is not able to communicate with socket.io because of a 502 error
I’ve performed a check of nginx status and here it is what you get from /var/log/nginx/error.log

2016/03/16 10:32:26 [error] 3229#0: *33 upstream prematurely closed connection while reading response header from upstream, client: 192.168.11.10, server: ~^(?<myhost>.+)$, request: "GET /socket.io/1/?t=1458120750804 HTTP/1.1", upstream: "http://127.0.0.1:8001/socket.io/1/?t=1458120750804", host: "rockstone", referrer: "https://rockstone/home"

This is also the reason why you don’t get snapshots page updated


(Philip Guyton) #5

@KarstenV and @Flyer Thanks for your input and feedback on this. There is already an open issue “dashboard doesnt work after 3.8-12.02 upgrade” and I have linked back to this thread to tie the two together.


(Philip Guyton) #6

@suman @KarstenV and @Flyer Having had a quick look at the dashboard issue indicated it appears to be gevent version related. I’ve put my reasoning and testing in the issue. Just posting here as an update. There may already be a fix out in upstream gevent but I’m just not familiar enough to evaluate / deploy properly. I’ve indicated the suspected upstream (very recently closed) issue in our issue.


(Mirko Arena) #7

I was just looking your updates on github and i agree with you, saying issues are python side rather than socket.io js

Look at this:

[16/Mar/2016 15:41:02] ERROR [scripts.scheduled_tasks.snapshot:94] Failed to create snapshot at shares/Condivisione/snapshots/Cond_201603161541 [16/Mar/2016 15:41:02] ERROR [scripts.scheduled_tasks.snapshot:96] Error running a command. cmd = ['/sbin/btrfs', 'qgroup', 'assign', '0/911', '2015/1', '/mnt2//SIVAG']. rc = 1. stdout = ['']. stderr = ['WARNING: quotas may be inconsistent, rescan needed', ''] Traceback (most recent call last): File "/opt/rockstor/src/rockstor/scripts/scheduled_tasks/snapshot.py", line 90, in main aw.api_call(url, data=data, calltype='post', headers=headers, save_error=False) File "/opt/rockstor/src/rockstor/cli/api_wrapper.py", line 124, in api_call raise RockStorAPIException(detail=error_d['detail']) RockStorAPIException: Error running a command. cmd = ['/sbin/btrfs', 'qgroup', 'assign', '0/911', '2015/1', '/mnt2//SIVAG']. rc = 1. stdout = ['']. stderr = ['WARNING: quotas may be inconsistent, rescan needed', '']

I know about the quota warning, but now you get error also on snapshot creation (but every snapshots get created in the right way)

M.


(hms) #8

Installing transmission ROCKON doesn’t work, the gear icon just keeps rolling. Tried wit hremoving subvolumes while ROCKON stopped, but still no go.


(suman chakravartula) #9

New update: 3.8-12.03

Thanks for testing and reporting issues very clearly @Flyer @KarstenV and @phillxnet. The dashboard issue is fixed in this update.

This update is minor but important. Please update and make sure dashboard is working. On a related note, I am unable to reproduce the snapshot problem yet. Let me know if it still exists after the update.


(suman chakravartula) #10

(Karsten Vinding) #11

Dashboard, and version number showing is working here again on 3.8-12.03


(hms) #12

Transmission installed after update. +++


(suman chakravartula) #13

3.8-12.04 now available!

I’ve fixed a couple issues, 1) fixed the snapshot bug that @Flyer reported with extensive detail. Thanks!. I think the root cause is that a btrfs warning is being displayed to stderr, but it used to go to stdout prior to progs v4.4.1. I’ve made the code around it more robust as well. 2) Secondly, made a minor rock-ons improvement.

@phillxnet added a pretty cool feature where you can add custom S.M.A.R.T parameters. I know some of you discussed the matter in detail in other posts. Please give it a try and report back your findings. Many thanks Phil!


S.M.A.R.T. for USB drives
(suman chakravartula) #14

(Mirko Arena) #15

@suman check this https://github.com/rockstor/rockstor-core/issues/1223

I think we can avoid all those checks till btrfs-progs group don’t solve 4K chunk issue (you’ll always get a rescan request cos’ probably in any storage you’ll always find at least one file greater than 4K)

M.


(Karsten Vinding) #16

I’m sad to report that, on my system, the error with Samba and Rock-ons being stopped and not restarted during an update seems to have returned.

During the last 2 updates I have had to enable them manually after the update.


(suman chakravartula) #17

Happy saturday folks! 3.8-12.05 is now available.

This is a special one, we have a new contributor!!! Thanks @Flyer for your pull requests.

We closed 2 issues in this update. The first improved upon task scheduler by adding more frequency options to choose from. The second is a stability improvement in the scheduled snapshot logic. While we are at it, a couple of minor bugs were also fixed. Enjoy!


(suman chakravartula) #18

(Mirko Arena) #19

@suman Thanks for letting mentioned - Think i’ll go on helping for a long time, Rockstor rocks


(suman chakravartula) #20

3.8-12.06 is now available!

We fixed two issues. First is a UI/pagination issue preventing samba exports > 15 to be shown. Second is an enhancement to the pool mounting logic that helps with many things, particularly with rockstor-bootstrap. @phillxnet, there was a bug in pool mounting logic earlier that got triggered by your fake serial id changes. If you can, please test the latest against fake serial id scenario. Thanks!