Disks showing as detached after reboot?

Hi, can you please help with this issue. I had the same issue with OMV hence why I switched to Rockstor hoping it will fix it. But it has done the same here.

I have a x86 mini PC that I have a 10 port mains powered USB hub connected to it with a USB3 drive connected to each port of the hub. What happens is if I reboot the NAS. Some of those drives just show as detached on reboot.

With OMV it was a nightmare to get them to show again as attached so thought it was a limitation within OMV so switched to Rockstor and now this is doing the same.

The USB hub is definitely 100% not faulty as I had bought replacements and they have done the same thing. The same goes with the X86 mini PC is not faulty. As I had bought multiple of them too. It seems to be an issue with just generally using a USB hub to connect multiple hard drives to a NAS system. And seems to only present itself on rebooting the NAS. It is total random which drives will show as detached on a reboot.

Is there something in the settings I can do to fix this please?

@AnthGood, you might be suffering from something similar found here:

which could also have affected your original OMV build

but I think we need @phillxnet’s opinion on this.


I think it may be a delayed start up on the Hub so all 10 hard drives don’t power up at the exact same time to save on voltage/amp spikes or something like this, the Hub may do it in stages where 5 boot up, and 5 wait till the first 5 have booted before they start and in this time Rockstor (And OMV) has during its boot up process only seen 5 boot up and treat the other 5 as detached and then when the other 5 do then boot up its already decided they are detached and won’t change its mind on it.

This is just my total guess with nothing to back it up other than trying to hunt out this issue before giving up with OMV and switching to Rockstor. And just using commonsense that this may be a way a 10 port usb mains power hub deals with 10 devices being connected to it all trying to power up at the exact same time to be recognised by the NAS software.

But if that is the case, would delaying the boot of Rockstor [somehow] to give it enough time to allow all 10 drives to come online and be recognised by it before actually coming fully online be a fix for this?

Also this is not a cheap USB hub. It cost me £40 from Amazon. Just saying this incase anyone thinks this could be an issue.

But if anyone can think of a fix for this. It would be an absolute godsend for me. As this plagued me with OMV.

@AnthGood Hello again.

In short: yes.

If you disable all rockstor services and then let the system boot up and all the drives wake up. And then start the rockstor services by hand to test this hypothesis.

systemctl disable rockstor rockstor-pre rockstor-bootstrap

Then reboot. There will be no direct rockstor related service started automatically on the next boot.

You can then start the last of these service, by hand, once all the hardware has settled, and it will in-turn start each of the others as they for a dependant chain.

systemctl start rockstor-bootstrap

It in turn depends on the rockstor service which itself, in-turn, depends on the rocksor-pre service.

You will have to do this on each boot as you have now disabled the auto start of these services but it’s a way to check your timing hypothesis.

It could also be what @Hooverdan referenced. But we would need all drives attached to know and then there would be errors indicating fake serials on some or all of the devices.

Some system firmwares also have hdd spin-up delay settings. This may or may not help in this case also. I.e. older drives use to take a few seconds to get their act together so some manufacturers added this setting as a work around to improve system stability. This would be a proper fix. But it may happen before the USB bus is powered up, and in which case it would not help. Also check if there are any power settings or the like for the USB bus as this may also help. I.e. some USB bus hardware will wait for the OS to power it up. But if the bios can do this you may gain the extra time needed; if that’s all this is.

As always let us know how your experiments go on this one.

Hope that helps.

And to undo the disabling of the Rockstor related service you can simply run:

systemctl enable rockstor rockstor-pre rockstor-bootstrap

This wont start them as that would be ‘start’ but it will move them back to being started by default on the next and all subsequent boots with no related systemd changes.