Error Minimal BASH-like line editing is supported

Hi, I am newbie at rockstor, also at linux. A customer has installed Rockstor I don’t know which version is installed but when booting, stucks on GNU GRUB version 2.04, minimal BASH-like editing is supported error. I do not know what to do and my customer, needs to access their data

Any suggestions?

@eguerrac welcome to the Rockstor community. If your customer has an idea when they installed, that could give an indication of whether it’s likely to still be the now legacy 3.x version on CentOS or whether the newer 4.x version on the OpenSUSE platform.

Also, if a backup of the settings has been made and downloaded (either on the data disks of this server or someplace else), then it might just be easier to install Rockstor anew using the latest stable version from here: Downloads
and restore the settings from backup. If they only did a minimal configuration, then that could be set up manually again and it would ensure a clean installation.
After the installation, the existing pool(s) of data can be easily imported following the documentation. To ensure that the correct device is used for the install (and not accidentally overwriting the data disks), you could unplug the drives but the OS drive before reinstallation. Once installation is complete (based host name and root user and WebUI admin user is the most minimal requirement), shut down, reconnect drives, start up, log in and go to the disks page where you can then import the data pool(s) with one click. That should put you back in business to get to the data.

Also take a look at this:
specifically the data import and (if existing) the hints for restoring configuration. the first part of the reinstallation still applies, however the screenshots need to be updated to reflect our move to 4.x on OpenSUSE.

Before you do that, you could take a look at this (there are other tutorials out there as well, but this seems to be one quite a few people refer back to):

It might be safe for this approach to also physically disconnect the data disks. If the repair works, you can shut down again, reconnect and should be back in business.

Keep in mind that both the drive containing the Rockstor OS as well as the data drives are formatted in btrfs (the article mentions ext3, ext4, etc.).
If that works to get your client back to where they need to be, great, if not, it will still require the reinstallation.

Part of the design for the Rockstor appliance was to separate the OS and the Data pieces, so a reinstall will take minutes without impacting existing data.

If you go down the path of reinstallation, and your customer had an active stable subscription (which would then also lead me to believe that it is running version 4.x), the appliance ID might have changed that is tied to that subscription (likely it won’t, but if it does, it requires some action to restore that link between appliance ID and the subscription).

For that to be synced, one can log into:

and fix it yourself (or your customer can send a DM to @phillxnet and he can help to sort that out).

1 Like

Thanks Hooverdan, unfortunately is just one drive, I think the guy who installed it, made 2 partitions on the same disk. I want to backup data anyway. I don’t know if I can install a VM with centos or opensuse. I don’t know when it was installed also, I don’t know how to check on minimal bash which distro is. Also, when I type ls at bash, ppears all the partitions and also an error thatr says the following:
./…/grub-core/disk/i386/pc/biosdisk.c:546failure reading sector 0x0 from fd0’. Any suggestions?

Ouch, well all of that is not so good. Assuming, that either there is some hardware related disk sector failure (which could/would be the root cause for grub not working) or that area was compromised due to sudden power outage, etc.

Can you temporarily add another disk to this system and install Rockstor on it? That way it would likely allow you to import that data pool into the new Rockstor install (unless that partition is compromised as well), and then be able to pull the data off (e.g. creating a SMB share if you want to do it using a windows machine).

Or you attach the disk to another machine, create a Rockstor VM and mount the drive into that machine, but that could be more complicated (since you mentioned you’re a Rockstor/Linux newbie) or on that other machine install Rockstor (on a separate drive as well).

For either of these options, pick the stable OpenSUSE version, the pool doesn’t care whether the OS was CentOS or OpenSUSE, this was only relevant for trying to repair an installation. the btrfs file format/pool definition is not Linux distro dependent.

Hooverdan, I will install a Centos 9 VM to access data in the failed hard drive, then I will try to fix or be sure that is failed. After that, I will reinstall new opensuse distro and use at least 2 HDD. I think is the best for now

I believe CentOS9 does not have btrfs as a “thing” anymore (since Fedora deprecated it a while ago) but I might be wrong, otherwise you might need a custom built kernel for that. You could also just install a Leap OpenSUSE VM instead, where btrfs is the priority

Ok Thanks. I will install opensuse

1 Like

Hi Hooverdan, I tried to install OpenSuse on a VM and tried to connect the HDD on an IDE/Sata connector to a computer but Opensuse does not recognize the drive. Customer is really worried for data and needs to work with. We need to access that info. Any suggestions?

The issue can be that depending on how you’ve set up the VM (VirtualBox, KVM, VMWare, etc.) that it doesn’t pass through the drive info correctly for it to be recognized.
I assume, you used OpenSUSE with a Gnome or KDE desktop? Does it not recognize the drive at all, or is it like an “unknown device”?

If you have another physical box you can temporarily utilize, I would recommend to install the Rockstor stable version on a primary hard drive, then connect that data drive and see whether it is recognized that way, so you can access the data. Alternatively, you can try to install Rockstor on your VM instead and connect the HDD to it (like you did for OpenSUSE).


Dear friend, I already installed rockstor stable edition, as I am newbie on linux, I don’t know how to enable gui at opensuse and need some advices to attach the second drive that has the old rockstor partition and the data. Can you have any suggestion?

Ok, let me know if I understand you correctly:

  • you installed Rockstor stable edition on a VM and you can access the Rockstor WebUI using a browser?
  • the physical drive with the old rockstor is connected (i.e. plugged into a SATA port) to the system where you are hosting the VM?
  • the VM “knows” about the attached drive (in the VM settings, depending on which virtualization software you are using)?
  • the Rockstor WebUI does not display that attached old Rockstor drive, after you rebooted the VM and logged back into the Rockstor WebUI?

Or is the setup now different?

Well, customer, bought a new hard driver this morning, so I used that new drive to install rockstor

Well I already got into the rockstor new installation and I see the sdb4 (Old drive) that if were connected, how can I check if data is ok?

1 Like

That’s good news, if you can see sdb4, in the Rockstor WebUI you should be able to import the data pool that’s sitting on that device:

look at this section of the documentation:

Once that is complete, it should also show the available shares that were created (maybe it’s only one, may be it’s multiple) in the Shares section of the Rockstor WebUI.

Now you can create a SMB export (using the WebUI once again), and connect to it from, say, a Windows machine:

You should then be able to pull off the data from there

Finally, as usual (and that doesn’t go for a Rockstor setup exclusively, but should be part of any setup with a NAS) see whether you can set up a backup solution for your customer to ensure critical data is not lost through hardware or other failures.