Error resizing a share

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

I tried to resize a share to a smaller size and got an error.

Detailed step by step instructions to reproduce the problem

whole disk in a pool, split the pool between two shares, tried to resize either share to a smaller size. Capture

Web-UI screenshot

[Drag and drop the image here]

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/rest_framework_custom/generic_view.py", line 41, in _handle_exception yield File "/opt/rockstor/src/rockstor/storageadmin/views/share.py", line 247, in put share_pqgroup_assign(share.pqgroup, share) File "/opt/rockstor/src/rockstor/fs/btrfs.py", line 1240, in share_pqgroup_assign return qgroup_assign(share.qgroup, pqgroup, mnt_pt) File "/opt/rockstor/src/rockstor/fs/btrfs.py", line 1294, in qgroup_assign raise e CommandException: Error running a command. cmd = /usr/sbin/btrfs qgroup assign 0/258 2015/5 /mnt2//Pool2. rc = 1. stdout = ['']. stderr = ['ERROR: unable to assign quota group: File exists', '']

@Kerry_Penland Welcome the Rockstor community and thanks for the report.

You might find that disabling and then re-enabling quotas sorts this out. But keep in mind that the more data / snapshots / subvols / files you have on the pool the longer it will take for Rockstor to get it’s act together on the quota enable. Disable is pretty much instant however.

We do have a way to go yet on our quota support actually and there are some known limitations but unfortunately this area of the code has been a little neglected of late as we’ve concentrated on moving to an OS where btrfs is supported. I.e. our Rockstor 4 endeavour. What version of Rockstor are you experiencing this with. Note that only our Stable branch in the now legacy CentOS variant is able to handle quotas disabled.

yum info rockstor

run as the root user in a terminal on the Rockstor machine should give a definitive version output. Pasting that output here should help forum members help with working out if we have a reproducable bug here and if it’s in a relevant version of Rockstor.

Hope that helps and again thanks for the report.

1 Like