Error Scheduling Scrub

Brief description of the problem

I can’t schedule any scrubs. I am running 3.9.1-13

Detailed step by step instructions to reproduce the problem

Trying to schedule a scrub of any pool fails in the same way. Red is the name of the pool I tried to schedule for that error report.

Web-UI screenshot

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/rest_framework_custom/", line 41, in _handle_exception yield File "/opt/rockstor/src/rockstor/smart_manager/views/", line 151, in post crontab, crontabwindow, meta = self._validate_input(request) File "/opt/rockstor/src/rockstor/smart_manager/views/", line 47, in _validate_input if not Pool.objects.filter(id=meta['pool']).exists(): File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/", line 127, in manager_method return getattr(self.get_queryset(), name)(*args, **kwargs) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/", line 679, in filter return self._filter_or_exclude(False, *args, **kwargs) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/", line 697, in _filter_or_exclude clone.query.add_q(Q(*args, **kwargs)) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/sql/", line 1310, in add_q clause, require_inner = self._add_q(where_part, self.used_aliases) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/sql/", line 1338, in _add_q allow_joins=allow_joins, split_subq=split_subq, File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/sql/", line 1209, in build_filter condition = self.build_lookup(lookups, col, value) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/sql/", line 1102, in build_lookup return final_lookup(lhs, rhs) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/", line 105, in __init__ self.rhs = self.get_prep_lookup() File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/", line 143, in get_prep_lookup return self.lhs.output_field.get_prep_lookup(self.lookup_name, self.rhs) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/fields/", line 727, in get_prep_lookup return self.get_prep_value(value) File "/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/fields/", line 985, in get_prep_value return int(value) ValueError: invalid literal for int() with base 10: 'red'

@SuPeRMiNoR2 Welcome to the Rockstor community.
What you have reported looks to be the after affects of the following release:

and specifically:

It may be that you have yet to refresh your browser to pickup the new code after that update. Also note that all existing scheduled scrub tasks will have to be removed and re-done.

Let us know how that goes for you as pretty sure this is now fixed.

Clearing my browser cache and reloading fixed it. I guess I should have tried that first. Thanks!

@SuPeRMiNoR2 Glad it’s sorted for you and thanks for the update.

Trying to schedule a scrub via webui doesn’t respond when you click submit button. Clicking submit throws the following excception, home#add-scheduled-task: 1 Form submission failed, as the <SELECT> element named 'cron-time-min' was implicitly closed by reaching the end of the file. Please add an explicit end tag ('</SELECT>')

ROCKSTOR 3.9.2-5 - Stable
Linux: 4.12.4-1.el7.elrepo.x86_64