Error while processing remote metastore at Lower level exception: HTTPConnectionPool(host

Brief description of the problem

Can’t get list of Rockons.

Detailed step by step instructions to reproduce the problem

  1. Install Rockstor
  2. Go to Rockons tab
  3. Click on Update button.

I have no trouble retrieving the json file via the web browser.

Web-UI screenshot

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/rest_framework_custom/", line 41, in _handle_exception yield File "/opt/rockstor/src/rockstor/storageadmin/views/", line 395, in _get_available response = requests.get(remote_root, timeout=10) File "/opt/rockstor/eggs/requests-1.1.0-py2.7.egg/requests/", line 55, in get return request('get', url, **kwargs) File "/opt/rockstor/eggs/requests-1.1.0-py2.7.egg/requests/", line 44, in request return session.request(method=method, url=url, **kwargs) File "/opt/rockstor/eggs/requests-1.1.0-py2.7.egg/requests/", line 279, in request resp = self.send(prep, stream=stream, timeout=timeout, verify=verify, cert=cert, proxies=proxies) File "/opt/rockstor/eggs/requests-1.1.0-py2.7.egg/requests/", line 374, in send r = adapter.send(request, **kwargs) File "/opt/rockstor/eggs/requests-1.1.0-py2.7.egg/requests/", line 209, in send raise ConnectionError(e) ConnectionError: HTTPConnectionPool(host='', port=80): Max retries exceeded with url: /rockons/root.json (Caused by : [Errno 11] Resource temporarily unavailable)

Hello @isaac4,

It looks like the server you installed Rockstor on is unable to reach to get the list of rockons that are available.

Can you make sure it is able to access the internet.


Like I already said, I have no trouble retrieving the json file manually.


Hi @isaac4,

In @vesper1978’s defense, you did state “I have no trouble retrieving the json file via the web browser.”.
I personally read this to mean that you’d pulled the json file successfully from something like chrome on another machine, not wget from the local terminal.

Does your system perhaps have multiple NICs on difference networks? Perhaps the NIC rockstor is attempting to connect out with cannot reach

I can see no other reason as to why wget would be able to successfully retrieve the file while python cannot.
At least, not without screwing with security policies from the terminal, anyway.

I should have expressed myself more carefully. Sorry.

No, there’s only the one NIC on the this system. It’s just a used ASUS NUC I bought to use as a NAS. Is there really no other explanation than “no network connection”? You guys know more than me, but when I read the following, I see something other than a network issue.

Max retries exceeded with url: /rockons/root.json (Caused by <class ‘socket.error’>: [Errno 11] Resource temporarily unavailable)

Hi @isaac4,

I notice the GUI is showing Rockstor version 3.9.1-0 , and that the icons for both upgrading Rockstor and for applying CentOS updates are not showing. Had you installed all the updates? If you have, can you reboot the server, and try updating the Rockons list again?

OK, this is weird. I was going to follow your suggestion (when in doubt, reboot, should have thought of that myself) so I went to the console to do it, and just for the heck of it, gave that refresh button one last click. Worked!

So, problem solved, if not the mystery. Thanks, all.