Failed to import any pool on this device(4). Error: 'unicode' object has no attribute 'name'

Brief description of the problem

I want to Import my Raid1 Pool after I click at “Are you sure you want to automatically import pools, shares and snapshots that may be on the disk ?” at one Disk. I get the follwoing Error Message.

Houston, we’ve had a problem.
Failed to import any pool on this device(4). Error: ‘unicode’ object has no attribute ‘name’

Detailed step by step instructions to reproduce the problem

I had to reinstall Rockstor. After it, I tried to import my Pools. The Single Pools run without a problem. At the Raid1 Pool, I got this Error. What can I do to import my Raid1 Pool?

Web-UI screenshot

Error Traceback provided on the Web-UI

        Traceback (most recent call last):

File “/opt/rockstor/src/rockstor/storageadmin/views/”, line 705, in _btrfs_disk_import
import_shares(po, request)
File “/opt/rockstor/src/rockstor/storageadmin/views/”, line 110, in import_shares
File “/opt/rockstor/src/rockstor/fs/”, line 412, in shares_info
mnt_pt = mount_root(pool)
File “/opt/rockstor/src/rockstor/fs/”, line 229, in mount_root
root_pool_mnt = DEFAULT_MNT_DIR +
AttributeError: ‘unicode’ object has no attribute ‘name’

@Oconnor First off, welcome to the Rockstor community.

This is strange as the import code is essentially independent of raid level.

Did you perform a Rockstor update between the single and raid1 pool imports? If so then you could inadvertently be running part old and part new code that don’t get along: in which case a reboot and re-try on the import might help (worth a try anyway).

Also could you specify the exact Rockstor version you are running, and as we have a bug on version reporting when first moving from testing to stable channels could you confirm the version via the following command executed as root:

yum info rockstor

I’ve made some changes in this area myself recently (in stable channel) so it could be that I’ve messed up here: hence the query on updating between the two imports. Just in case I’ve successfully retested import from a single disk single raid pool and a 3 disk raid1 pool using the latest master branch code which is equivalent to Rockstor stable channel release version 3.9.2-27:

And you log line numbers would indicate a older version.

Let us know your current version and any progress after re-trying after a reboot and we can take it from there.

Also I take it the labels of the pools haven’t been removed in the mean time as that is where it taken from (earlier Rockstor versions couldn’t cope with ‘none’ label pool import).

Hope that helps.

Thanks for that fast support! I Updated to the latest Version. After it,it worked!