Failed weekly cron jop to update opensuse

Brief description of the problem

weekly cronjob script ( ) exited with returncode 4

Detailed step by step instructions to reproduce the problem

running weekly cronjob scripts

SCRIPT: exited with RETURNCODE = 4.
SCRIPT: output (stdout && stderr) follows

Problem: nichts stellt ‘postgresql = 16-150300.10.18.3’ bereit, das vom zu installierenden postgresql-llvmjit-devel-16-150300.10.18.3.noarch benötigt wird Lösung 1: Folgende Aktionen werden ausgeführt:
Deinstallation von postgresql-llvmjit-devel-15-150300.10.15.1.noarch
Deinstallation von postgresql13-llvmjit-devel-13.13-150200.5.50.1.x86_64
Lösung 2: patch:openSUSE-SLE-15.4-2023-4495-1.noarch nicht installieren Lösung 3: postgresql-llvmjit-devel-16-150300.10.18.3.noarch durch Ignorieren einiger Abhängigkeiten brechen

Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie (a)b [1/2/3/a/d/?] (a): a


update process recognizes that a new version postgresql-llvmjit-devel-16-150300.10.18.3.noarch is available and wants to deinstall the following packages first:

  1. postgresql-llvmjit-devel-15-150300.10.15.1.noarch
  2. postgresql13-llvmjit-devel-13.13-150200.5.50.1.x86_64.10.15.1.noarch
    The problem needs to be solved choosing an option:
  3. do not install openSUSE-SLE-15.4-2023-4495-1.noarch
  4. install postgresql-llvmjit-devel-16-150300.10.18.3.noarch and ignore dependencies

What is your recommendation to solve the issue?


@anborn, could you provide a few more details about your setup again? Are you on 4.6.1-0 (based on your post a few months ago)?
Is this is an installation of Rockstor on bare metal, or on top of a desktop Leap version?

The weekly cron job, you’re mentioning, could it be that the update options do not include the
--no-recommends option?

On my system (4.6.1-0) the llvmjit package is not even installed, irrespective of the postgresql version.

1 Like

Hi Dan,
it is running on bare metal (CentOS withstable updates) since 2018 now and was reinstalled by using Rockstor “Build on openSuSE” installer in 2019. Update to LEAP 15.3.was done end of 2021 and i’m running latest stable 4.6.1-0 of rockstor.
I remeber having some trouble upgrading to 4.6.1-0 on LEAP 15.3 with postgressql caused by poetry-install, but that was solved by the help of Flox.

1 Like

Yes, I am wondering whether some underlying issue continued …

Of course, now 15.3 is EOL, as is/will be 15.4 … so that’s not helping. Maybe @Flox has some suggestions.

I assume, you installed in the YAST2 context (or manually created?) the weekly online update cron job here?

/etc/cron.weekly/ -> /usr/lib/YaST2/bin/online_update

I also assume, that you then have a /etc/sysconfig/automatic_online_update file that contains the update flags?

If so, is the setting of the variable in that file like this?


which would represent the zypper command with the --no-recommends option to avoid “unnecessary” package installations/updates in the context of Rockstor (and any other manual installed programs one might have). Because, I think the llvmjit package is not really necessary for the functioning for the postgresql db and Rockstor overall … but I let @Flox or @phillxnet comment on that.


@anborn & @Hooverdan I’ve had the exact same automated update fail email report from a non Rockstor Leap 15.4 install:

running daily cronjob scripts

SCRIPT: exited with RETURNCODE = 4.
SCRIPT: output (stdout && stderr) follows

Problem: nothing provides 'postgresql = 16-150300.10.18.3' needed by the to be installed postgresql-llvmjit-devel-16-150300.10.18.3.noarch
 Solution 1: Following actions will be done:
  deinstallation of postgresql-llvmjit-devel-15-150300.10.15.1.noarch
  deinstallation of postgresql13-llvmjit-devel-13.13-150200.5.50.1.x86_64
 Solution 2: do not install patch:openSUSE-SLE-15.4-2023-4495-1.noarch
 Solution 3: break postgresql-llvmjit-devel-16-150300.10.18.3.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c/d/?] (c): c

This machine, has a zypper dup history, in that it used to be 15.3. So in short this is not Rockstor specific/related. So a wider search for this may help.

Would be good to check your actual OS install level via:

cat /etc/os-release 

As given the conflicting package version numbers match exactly I’m wondering if you are on 15.4 (raised from 15.3 via zypper dup).

Hope that helps.


Sorry for the confusion, I´m already on 15.4. of course.


The only mention of issues in this area is related to a security update that was released in November 2023:

but the version mentioned therein is even “higher” (I guess and update to 16.1 and then some stuff)

and on an earlier version where something similar was happening I saw this:

but not sure that this is the same problem just in a higher version …