HP DL380 G6 NetApp DS4243 PM8003 Installation

Hello guys,

first of all, I need to apologize for my bad english. Since I’m from Germany and my english is a bit rusty, I try my best.

I would like to share my experience with my Rockstor installation on an HP DL380 G6.
I had to install Rockstor allot of times. Since the installer is a bit buggy. But once I figured that out, the installation went good.

I’ve choosen to put 2 73GB 10K SAS drives in an Raid1 with the HP P410/512MB/BBW as a boot device. This works really good. BUT there were some problems with installation. The drives you put in, NEED to be empty.
The server has 16 bays. 14 are empty. But putting every drive (I tried all 16 drives) each in an Raid0 works fine. Rockstor is only missing the S.M.A.R.T data. I wouldn’t recomend this for an productive envirorment.

I put in my NetApp PM8003 Rev.5 HBA. I connected two NetApp DS4243 with 48 2TB SATA HDD’s. This was working fine. S.M.A.R.T is available and raid creation works fast and smooth. The only bottleneck is the 3GB/s connection between the DS4243 and the PM8003. SAS drives are also supported.

I confirm the hardware as working.


All standard funktions work without any problem.
But in the current state I would NOT reccomend Rockstor for an productive system.

-There are to many bugs with the RAM cache. The RAM is always full (144GB).
-CPU usage (2x QC with HT) is often nearly 100%. Might work better with two 6 core.
-Features like ISCSI are missing
-The system sometimes need to be hard reset, while it just hangs
-No German language pack
-Keyboard layout change does not work
-Bugged installer

What I love is the option to expand or change your raid AFTER you created it. I don’t know any other software raid that is caipable of that. Thats why I’m hopingfor the bugs/problems to be fixed. This could be the best NAS software ever.

Kind regards,

@ex3cution Welcome to the Rockstor community and glad you got things going in the end.

Thanks for the report: many good points and very detailed. Some nice pointers re your install finding also.

Thanks, and nice setup.

Smart data is often tricky through a raid controller but it may be possible with the use of custom smart options - explanations and references available via the pen icon next to the smart switch in the disks table. The following in our docs may be of use: “S.M.A.R.T through Hardware RAID Controllers”. Not a polished as I’d like yet but may allow for S.M.A.R.T via hw raid connected disks. All depends on the controller really. There is a canonical link in that doc section to the upstream smartmontools page for this config corner.

I would challenge this as we do nothing custom bar that which is in the main line kernel as per ElRepo’s kernel-ml. It may just be a difference of expectation vs reporting re memory use. Have a look at the following thread where this has come up before and was addressed by forum member @aditaa via a RedHat reference:

Yes, the check summing used by btrfs can be quite a hit. But 2 quad cores should be more than plenty. I know there are improvements going on all the time re efficiency in btrfs and we are inevitably to inherit those as time goes on. Definitely room for improvement and I would no recommend a single core for btrfs. And on the other hand there are times when it fails to distribute across cores the work that is needed. Of note here is that the parity raid levels of btrfs 5/6 are definitely a fair bit worse on this front and essentially impractical currently so as we indicate in the raid level selection tool-tip/hint and our docs - Redundancy profiles section, they are not recommended for production use just yet.

Yes, big one this and we have a rather popular issue open just for it:

Please feel free to contribute to that issue as per it’s intro text by project lead @suman

Very bad and no something we have heard or would expect. I’d look to logs for some clues as this is not normal or reported behaviour so definitely an issue / compatibility / hw conflict of some sort there. You could for instance try a different kernel as it may be down to driver versions or the like. Maybe start a new thread with specific details on this one as we are essentially a re-badged CentOS with a much newer kernel and btrfs-progs.

Yes, translation capability would be great and definitely under consideration, but we have only just started towards that end of things:

@Flyer has gotten as far as a proof of concept but I’m not up on exactly how currently (details in that issue, with pics):

And we have the following forum thread with some eager volunteers for the verbal leg work:

again please comment on that thread if you think it’s appropriate.

Bit of a low priority on a headless system but yes; see forum member @henfri’s issue on this:


Yes, we essentially inherit and only really re-badge the Anaconda installer and it is a little buggy. But there are ongoing plans to update our installer to get what improvements we can from upstream, which has only recently had a new 7.4 release tagged:

I know, it’s like magic. But funny thing is a new to raid tec user just expects to be able to do this so doesn’t even notice. But we do have some work to do on other expected behaviour such as changing names on shares etc. But there has been some recent and fairly hefty changes to accommodate such other reasonable expectations in the future.

Had to quote that bit as I feel similarly - but we have a ways to go just yet. However the efforts within Rockstor and the wider btrfs / CentOS / Linux community are perpetually ongoing so I look forward to our future where hopefully all of your concerns are, in time, addressed.

Thanks again for the generous and detailed write-up and hope you get that hard lock sorted as that is not a known issue.

Cheers; and I hope the above references re-assure you that we are ‘under way’ with the various points you raise.

1 Like

@phillxnet I have to admit, that this was the best reply I had ever on a forum.

I will be looking out for a newer version or Rockstor. In the meanwhile I’ll be experimenting with different servers like Dell R710, R720, HP ML350 G5, DL320 G6, DL180 G5, DL580 G7 (the big red machine :P) and so on. I have allot of servers here. If anyone needs some special hardware to be confirmed for working, I can do that.

I plan in using Rockstor for my company. I’m also thinking off recomending this to my costumers. But the points mentiont before need to be worked on. I may try another kernel. I need support for 10GB/s fibre channel. This seems not to be supported in the current state.

You can also contact me, if you need some help with the german translation. I would love to do that.

Kind regards,

1 Like