HP microserver 10

hello, when i try install rockstor i stuck after loader. Its there any fix for this problem?

The latest CentOS installer (Which Rockstor is built on) runs a Kernel that doesn’t support the HP microservers, or at least the older ones. I haven’t tested the 10 series, as I don’t have one…

Pull down Rockstor 3.8.16, install, then update to the latest version. This is how I got it installing on a Gen 7 N54L.

Thank You, but Its not working for me

Ok seems the Kernel doesnt support the SATA ports, so the system cant find the system root from DVD. Seem a HW compatibility problem. A more curreret Kernel on the install DVD should help here, but dont know if Rockstor uses the orig CentOS Kernel on install?! So this might be a bit of a problem…

You should this to install:

Put the HDD into a desktop PC (remove all other disks tha should NOT be deleted!) install Rockstor and put the disk back into the Microserver. With the current Kernel which gets bootet the HW should work. Network cards get deteced automaticly and get set to dhcp, so this should work out of the box.

thank you, for now i am happy with openmediavault.

But i will test it one day in far future.

Another hint: HP states on its support site “Unterstützt jetzt Red Hat Enterprise Linux Version 7.4”, which claims HW support for RHEL 7.4 and thus should be also CentOS 7.4 compatible when using the same Kernel?!

even Cent OS 7.3 works there was just some problem with gpu standby mode.

That’s odd, since I was able to use the installer to install on a Gen8. The only issue I had was using an SSD in the ODD bay and the HP not wanting to boot from that by default, but that’s not about Rockstor. I solved that by using the internal RAID controller to build a 1-disk RAID out of the SSD, which the HP does accept as a worthy boot drive.


My bad, the issue I mentioned applies specifically to the Gen 7. I hadn’t installed rockstor on the Gen 8 serues,

Also, (if you’re still using that Gen 8), I had an OMV install on one of those. Rather than using the on-board RAID card I added a flash drive to the internal connector for the boot loader, booting root off the SSD in the ODD bay.

Oh yes, I’m still using the Gen8, running Rockstor like a champ. I thought about going the USB or MicroSD route, but figured it was another moving part waiting to break on me. Also I didn’t have a spare card lying around that I trusted enough. :slight_smile:

Hi Rockstor community, is there any news on this topic? I would love to install Rockstor on my HPE gen10 microserver… I am getting the same issue as described above.
Thanks a lot in advance for your feedback.
(btw i am not very experienced when it comes to linux…just started :slight_smile:)

I just realised that HP released a Bios update 12 oct 2017, I will try if that fixes sth…

no, after bios update problem still remain.

Thanks frenky55 for your quick reply.

Has anybody tried the work around described above to mount the install hdd into another ps and do the installation there and then mount the drive back?

I installed rockstor on my gen 10 today. There were a few issues - the bios has to be in legacy mode, but once it was the install was fine. Installing in uefi mode got me the error above.

Once installed there are a few kernel flags to prevent warnings ( around iommu, even though it is off in the bios - https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00022034en_us Has the details) and for some reason I had to blacklist the i2c_designware_platform and i2c_designware_core kernel modules - in 4.12 they caused a kernel panic on startup, with 4.10 they just give a stacktrace on startup.

That sounds worse than it is though - the changes take 10 mins to make and the server now seems totally happy!


Great news Jfearon!

From what I understand you boot your gen 10 in legacy mode and iommu off.
Could you please explain a bit more in details how you fixed the kernel panic issues (I have very basic linux knowledge only).
Thanks a lot in advance,


Sorry for the massive delay - just create a file in /etc/modprobe.d called backlist.conf containing this:

blacklist i2c_designware_platform
blacklist i2c_designware_core