I screwed up network teaming

I tried to team my two NICs and screwed things up. I teamed the NICs and rebooted, when it booted up i had no network connectivity. From what I could tell, rockstor uses network manager, so I simply deleted the team0 with the following command:

nmcli con delete team0

My plan was to delete the team, then retry from the web gui again. so, after deleting the team from the CLI, I restarted and the machine got an address from DHCP and worked, but… I the web gui gets an error and I can no longer configure the network from the GUI.

The error states:
NetworkConnection matching query does not exist.If you need more help on this issue, email us at support@rockstor.com with the following information:

  • The error message: “NetworkConnection matching query does not exist.”
  • A step by step description of the actions leading up to the error.
  • Download the tarred and zipped server logs by clicking here, and attach it to the email.

I assume this is a simple fix, I’m just not sure what to do and don’t want to break anything. There is also a pending update from the auto updates and I’m scared to install, I don’t want it to fail and screw something up. Any help would be appreciated.

I have teaming enabled. Due to Rockstor’s missing support for VLANs i’m forced to have other types of network interfaces enabled as well to supress the webui complaining about missing stuff.

Here’s my current config, which may help you; of all these conns currently team0.enp8s0 and team0.enp9s0 are the ones connected, until i get to patch up two more conns to my switch.

team0 → teaming interface
enp8s0 (type: ethernet) → team0.enp8s0 (type: ethernet, team0 member) → team0
enp9s0 (type: ethernet) → team0.enp9s0 (type: ethernet team0 member) → team0
enp10s0 (type: ethernet) → team0.enp10s0 (type: ethernet team0 member) → team0
enp11s0 (type: ethernet) → team0.enp11s0 (type: ethernet team0 member) → team0

team0 → team0.30 (type: vlan) (and therefore not needed on your side)

Hint: use nmtui (ncurses version) instead of nmcli; may be easier to keep the overview…

Hi @abzstrak Daniel and welcome to Rockstor Community! :sunny:

I had a similar problem (and i kicked out my self from Rockstor webui too eheh) and here is my suggestion:

Go back and create a clone of your old connection (that should write required data to db tables), create a new simple ethernet connection - if you need one with a static ip -, than destroy teaming/bonding connection.

Let us know


Thanks guys. i’ve tried making a new one in the GUI, but it seemingly ignores me. I’ve done it a few times, it never actually makes anything.

Here is a screen shot:

I just finished shutting down my VMs, I’ll play with nmtui and see if I can get anywhere.

ok, nmtui is awesome. I just deleted the crap i tried to make after all this as well as the team slaves and left only my two nics… then saved it and everything is happy.

thanks guys!

1 Like

Good to know. Have fun with your renewed connectivity ,)