Install "unexpected error"

Hey there,
im looking to install Rockstor 3.9.1. I have a Xenon 1230 v3 and an ASUS H87i Plus Mainboard. I get some Error Massages while trying to install:
First there are coming these two errors at the beginning: - “Couldnt find an interrupt endpoint”
- “usb_submit_urb(ctrl) failed:-1”
I use a Corsair K55 as the Keyboard. I read that, that could be a problem?
And after that, i come to the GUI and there pops up a message saying “an unknown error has occurred” and i have to quit. The Log tells me something about “KeyError: rockstor server”.

Does anyone know what to do here?
Best regards

P.s: I tried same with the Rockstor 3.8.16.iso

Yes, Corsair’s mech keyboards are notorious for issues on Linux.
This may result in the keyboard being unusable on boot. If this is the case, use another keyboard to download and install the ckb-next userspace driver which will resolve that issue.
Unfortunately, this is unrelated to your later issues.

Unfortunately, this partial error is unlikely to lead to anything without more information.
This effectively is a python error stating that a key has been requested from a dict and the key does not exist.

To identify the issue, we need the whole error message including the traceback (which identifies where in the code the issue occurred).
An example for another (unrelated!) issue that also related in a key error is shown below:

ERROR [storageadmin.util:47] exception: Samba could not be configured. Try again. Exception: 'global_config'
Traceback (most recent call last): File "/opt/rockstor/src/rockstor/smart_manager/views/", line 61, in post
    gc_lines = config['global_config'].split('\n')
KeyError: 'global_config'
DEBUG [storageadmin.util:48] Current Rockstor version: 3.8.16-0
ERROR [storageadmin.views.config_backup:51] Exception occured while creating resource: 
https://localhost/api/sm/services/smb/config. payload: {'config': {u'workgroup': u'MYGROUP2'}}. 
exception: 500 Server Error: INTERNAL SERVER ERROR. Moving on.

Thank you for your answer so far!
Unfortunately its not a mechanical keyboard. Its “normal” ^^. But yes, i dont have another keyboard here right now but that shouldnt be a problem.
Yes i thought you would need the whole error massage. But im sorry, i rly dont know how to copy the error massage from my server to my PC. I tried to send the bug over the GUI but that failed. Any Suggestions?
I could write it off, but the whole text is huuuuge!
And again sorry, i just dont know how to quote here :confused:

I did a photo with my phone.

At the reason window there is the “KeyError: rockstor server” and the cmd line tells me “/user/bin/python” and “/sbin/anaconda”

My bad, I looked at the wrong model when stating that, but many of corsair’s gaming keyboards have this issue on Linux (The K55 rubber-dome included.)

Regarding the error shown - I’m sorry, this one is out of my league (experienced Rockstor user, not developer), as I’ve never investigated the install process.

It seems the error is appearing in Anaconda (the CentOS installer), from the submodule pyanaconda - probably in the software selection stage - based on this being in the ‘_allAddons’ subroutine, defined in later versions of pyanaconda in ‘’. I’m assuming this is in the array push to add ‘self.payload.environmentAddons[self.environmentid][1]’, however I’m unsure where this is sourced.

@phillxnet may want to weigh in here, as I think he has good working knowledge of the installer.

Is it possible to make any changes to BIOS settings or use another usb stick? (Getting another USB stick tomorrow…)
I currently have 2 HDD’s and 1 SSD connected. All with some (unnecessary) Data on it. Due to the problem i disconnected the 2 HDD’s and just let the SSD connected - to install rockstor here. Could that be a problem? Do i have to wipe out the data on the drives before installing rockstor?

@Alexander_Stork Welcome to the Rockstor community.

This is not normally required, however I have had the installer fail when I had prior FreeNAS (single swap partition with single ZFS partition) data disks attached. In that case I removed all partition info (and data consequently) via a 'wipefs -a ’ and then the installer proceeded as normal. Can’t remember what the error was in that case and given our installer is simply a re-branded CentOS Anaconda installer with a kickstart configuration you may get useful results searching for the observed error against CentOS or RedHat. But I’d try removing all unnecessary hardware that is attached and potentially also try the ‘wipefs -a’ command on the proposed system disk (you could use any linux live boot setup for this) and trying again. But do be careful with that command: it’s a sledge hammer with no safeguards. Once you have an install up and running you can shutdown, re-attache your proposed data disks and then boot up and configure them via Rockstor’s Web-UI.

Hope that helps.

Hi and thank you again for your help!
I just did a DBAN of my stick and my SSD where rockstor should be installed to (HDD’s still dismounted). And i did not get the error anymore. But the GUI-menue did not show up - instead it went directly to install and the “set root password”-screen. Means i couldn set time/timezone and Network settings etc. But i got it running :wink:
I just wiped my HDD’s and created a pool (Raid_1). I created a share (rock-on) at the rockstor_rockstor pool as it is recommended to have its own share for rock ons. But if i hit the update button after enabling the rock-on service i get an error.
Is it possible to change time/timezone? It shows up wrong time tho. And is it possible to connect a usb HDD and copy files from that drive to the rockstor server?

@Alexander_Stork Glad you got the install sorted.

Yes I get this some times. It’s a bug in our rebranded upstream anaconda installer / our kickstart config combination. When I encounter it and need the other installer options I simply do a re-install and it works as intended. See our Reinstalling Rockstor howto for a walk through of this procedure. Given you are using an SSD system it shouldn’t take much time.

We are hoping to provide an image based install option with our openSUSE move so things should be simpler moving forward.

See how you get on.

And the Rock-ons ‘Update’ can I suspect be just down to a timeout. See how your re-install goes and take it from there.

Only via the command line. No Web-UI capability there yet, but you could use the Rockstor interface to create the share where the data is to reside and then access it via it’s exclusive mount point inside:


using command line tools to mount your usb drive and copy into the freshly created share.

Hope that helps.

I reinstalled. Timezone works so far. Rock-ons still same problem. Did update the Kernel and the software.

ehm…im not quite familiar with linux. Under /mnt2 i see my shares. But i dont know how to mount/access my external drive over SSH/command line. Its listed in the “disks” section and marked as “usb”.

@Alexander_Stork Glad the re-install worked and you are up and running.

Hopefully others can chip in hear as this is not Rockstor specific but generic Linux help. Worst case, given you are not familiar with the command line in Linux, you can simply attach your usb drive to a client machine that you are familiar with and copy the data over to your Rockstor instance via the network. This is probably the easiest approach if you are not familiar with Linux anyway.

Sorry to be brief but working on Rockstor code currently.

Hope that helps.

No problem!

Yeah that would work. But then our network is slow and thats not that cool for my roommates.
I follwed these steps, found in community forum:

  1. yum install ntfs-3g
  2. mount -t ntfs /dev/sdd1 /media
  3. cp -r -v /media/movies /mnt2/multimedia

And now hes copying.
Still missin rock-on’s but then everything would be fine :slight_smile:
and btw in the WEB-GUI i get randomly this error. It appears, if it appears, 3-5 times in succession - then its fine …

@Alexander_Stork Thanks for the update and sharing your forum findings re the migration from an NTFS (MS Windows) USB disk. Those using this solution should make sure to get the correct “/dev/sdX#” bit as that will be different depending on hardware. Also more obviously the the mount point names of course.

We plan to have this ‘local copy’ facility in time but it’s not likely to appear soon unfortunately.

As for the datatables, yes this can happen sometimes. Try a Browser refresh when it happens as that sorts it for me the quickest. We do a lot in the browser and our tables get cached inappropriately sometimes. We have some measures in place to address this but not across the board by the looks of it. I only rarely get this nowadays though.

@Flox any idea what the rock-on update issue is for @Alexander_Stork as then we have a full house of solutions here. I can diagnose in time but not right now.

@Alexander_Stork Good luck on the remaining Rock-on issue. Always worth looking in your logs at around the time you last tried the ‘Update’ button to get a list of the available Rock-ons. Pasting what you find at the time you tried at button will help others help you with this issue hopefully.

My first thought was the same as yours: timeout.
@Alexander_Stork, I would second @phillxnet’s recommendation to look at the logs (rockstor.log, using the Log Manager from the webUI right after clicking the Rockon Update button) and see if you can get more details.
All this button does is fetching data from the following file:, which from my machine is working fine. If you do not get an error from pasting this URL in your web browser from a machine on the same network as your Rockstor’s machine, then, that would tend to indicate an issue with how your Rockstor machine is connecting to internet. It would thus also be informative to see how your Rockstor machine can access this file by doing:


That could be participating to explain why the Rockon update times out as well… (and maybe also explain the DataTable warnings you experienced as well).

Sorry for not being more helpful for now, but let us know how it goes.

Thank for your help here. Can i post the log file somewhere? otherwise i uploaded it here (if that was ok?): MEGA

i just copy/paste the link “” in my browser and hit enter. No error, it showed up like:

I did that. Appears just like the snapshot above.

Hi @Alexander_Stork,

Looking at the logs, just with regards to the Rock-Ons update, here’s where things are failing:

[15/Jan/2019 09:01:20] ERROR [storageadmin.util:40] Error while processing Rock-on profile at Lower level exception: HTTPConnectionPool(host=‘’, port=80): Max retries exceeded with url: /rockons/teamspeak3.json (Caused by <class ‘socket.error’>: [Errno 4] Interrupted system call)
[15/Jan/2019 09:01:20] ERROR [storageadmin.util:44] exception: HTTPConnectionPool(host=‘’, port=80): Max retries exceeded with url: /rockons/teamspeak3.json (Caused by <class ‘socket.error’>: [Errno 4] Interrupted system call)

Essentially, the download of teamspeak3.json is getting interrupted.

I do see other errors in your logs, but the following one is the most interesting to me:

[15/Jan/2019 09:01:09] ERROR [storageadmin.util:44] exception: Failed to reboot the system due to a low level error: Error running a command. cmd = /usr/sbin/shutdown -r now. rc = -15. stdout = [’’]. stderr = [’’]

Which to me looks like you tried a reboot through the GUI and it’s failed.

That error is before your attempt to Update the Rock-Ons list. There could be something from this causing an issue with your Update of the the Rock-Ons.

I’d like you to open a shell on your Rockstor server, and do the following to reboot.

sudo reboot

After your server boots back up, I want you to try Updating the Rock-Ons list and if it fails again provide a new copy of the rockstor.log.

1 Like

Hi! Yes thats right. Shutdown sometimes fails: Sometimes it shuts down und restarts, sometime nothing happens and sometimes it just shuts down.
On the other hand i think this is more interesting:

ERROR [] Unknown ctype: bridge config: {}

This is it what appears right after clicking update button!

I restarted my machine several times. unfortunately not with that command. I just hit the power button at the machine. But i just did it. Putty gives an error: “fatal error: connection lost to the network”. I think due to the reboot disconnect.
But the rock-on-update-error still appears.
Here is the actual log file: (im wondering that nothing was written in it on Jan 16/1/2019 about 11am… (where i tried to update last)!uQF1AIRR!Szj1MvAg22N9sQvN_NbKpdInoltOOhLoyzOMip_Qe_Y

Hi @Alexander_Stork,

The error:

ERROR [] Unknown ctype: bridge config: {}

is not being caused by you clicking the Update button. It’s just coincidental, but may help with identifying the issue further.

I suspect it’s something similar to:

1 Like

I’m short on time but wanted to quickly answer regarding the Unknown ctype... error message.
@vesper1978 is absolutely right about it as it is not caused by your issue, @Alexander_Stork. The Github issue linked is appropriate and it is actually a normal message to see in your logs as it simply results from Rockstor not being aware of connection of type bridge, which docker creates automatically (the connection named docker 0 that you see in System > Networks). Note that I’m currently working on this very aspect of Rockstor and it will be improved in a future Rockstor release.

Regarding your errors, I suspect you are simply seeing symptoms of slowness on your system or network, but I’ll have a better look at your logs and come back to you (if somebody else hasn’t helped you in the meantime).

Hope this helps,

1 Like

Hi again @Alexander_Stork,

I had a quick look at your log but cannot see anything wrong with it.
As explained in my post above, the Unknown ctype... message is unrelated and not a true error. Similarly, the shutdown error you see is an “expected” message as well (in some way) and not a sign of something wrong with your system. I do see it myself on Rockstor-3.9.1-16 after a successful shutdown from the webUI. As you can see, it returns an error code rc = -15, which is not worry-some–as far as I know, as least.

I would have a few suggestions and recommendations, however:

I would strongly advice against doing so unless your machine really is frozen and completely unresponsive. It seems something is slowing your machine down at times, and we need to make sure not to interrupt whatever is running.

Similarly, I would recommend to place this share on a pool separate from your system pool (the rockstor_rockstor pool).

I’m again sorry for not being able to give you a clear answer as to the errors you are seeing besides trying to give time to your system. After a clean restart, let it run for several minutes for it to settle down, especially if you were copying large amount of data. You can see on the dashboard widgets the CPU / network activity and make sure your machine is idle before proceeding further with Rock-ons configuration, for instance.

Let us know if you observe consistently high CPU usage, for instance, or general unresponsiveness, etc…

1 Like