Kernel Panic on boot

Can anyone tell my why my system has a kernel panic when booting rockstor, but any other distribution I install is fine? This is true even if they are running the same kernel. I even installed vanilla CentOS and it had no trouble booting.

I think it has something to do with Rockstor specifically because this has been happening since the upgrade from kernel 4.2.5 and every update since then.

here is my previous post with pictures of the panic. I welcome any ideas.


I seems to have a similar problem; in my case the kernel panic occurs on first install of version 3.8-14. It occurs during the post-installation setup during the installation (according to the install UI). Network connection verified

I have run memory checks that completed without errors, checked the installation media and I have installed Ubuntu 1604 (kernel 4.4) without problems on the same hardware


  • M4A78-AM motherboard
  • Athlon x2
  • 2x2GB DDR2-800
  • 60 GB SSD (I disconneted my two 4GB drives after a few install attempts)
  • Installing from USB pen drive

A few of the error message lines:

  • general protection fault: 0000 (#1) SMP
    Call trace:
    … ? generic_write_sync+0x60/0x60
    … sync_inodes_one_sb+0x19/0x20
    … iterates_supers+0xb2/0x110
    … sys_sync+0x44/0xb2

… sync_inodes_sb+0x127/0x1e0
Kernel panic - not syncing: Fatal exception

Any help welcome :slight_smile:

best regards

Hi again!

Followup: Since Rockstor seems to work with kernel 4.2.5 - could someone help with what version of Rockstor that corresponds to? It could be a good idea to verify that I can install that version without problems

Best Regards

One more addition: mounted the “half-installed” volume on another system and tried to check any logs in /var/log. However I found mostly empty files here except a 292 kb lastlog file :frowning:

@peter Welcome to the Rockstor community. I would say your issue is less related to the kernel issue that @sudowoodo references and more to some write / corruption issue; from the log snippets you posted. You could try installing to another device as it may just be that Rockstor’s install is triggering an issue there. The Rockstor installer actually uses a much older kernel than the system it installs (3.18 I think) so don’t think it’s the same issue here. Also always worth trying a different install key in case it’s corrupting the image. This to an extent can be checked by using the built in Media check as documented in the official docs in the Pre-Install Best Practice (PBP) and specifically the Checking the Install Media and Check Integrity of Downloaded ISO File sections. I know you mentioned checking the media but didn’t know if this was what you were referring to.

Hope that helps and maybe someone else can come up with more suggestions here.

@sudowoodo Rockstor is based on CentOS7 but uses the elrepo ml kernels so that might explain why your CentOS install was OK, although you don’t specify the verison. Many people reported issues with booting from USB devices on kernels newer than 4.2.5 but since we moved to 4.6.0-1.el7.elrepo.x86_64 that seems to have addressed things in that area at least. Have you tried updating to this, it is standard in Rockstor as of 3.8-14 and onwards.

As a way to rule out any Rockstor specific stuff you could try a CentOS 7 fully updated and with the the same elrepo 4.6.0-1.el7.elrepo.x86_64 kernel installed and see how you go. I suspect this is not related to Rockstor but down to this kernel and how it’s interoperating with your ChromeBox and it’s rather unusual coreboot variant bios.

Is there any reason why you started a new Forum thread? An update on the existing one would have helped to keep all the info in one place but well done on linking back. All new posts in the Forum are flagged similarly to those logged in.

Sorry I can’t offer more on this one but at least you have the CentOS7 + updates + elrepo ml kernel to try here in an effort to narrow this down. As we make no kernel level changes apart from simply installing by default a specific elrepo one.

Hope that helps.

@phillxnet Thanks for your suggestions. Before the latest kernel update in Rockstor, I installed CentOS7 and installed the latest elrepo ml kernel at the time. The system worked without a problem. It was a newer kernel than Rockstor was using, so I waited until Rockstor released with a new kernel hoping that it would be fixed. Sadly I still get kernel panic after this latest update.

I know my system is weird, but no other distro has ever given me kernel panics on boot like this. I made a new thread and labeled it “Bug” because I think that it is a bug with Rockstor. The thread I linked was labeled troubleshooting and I got no responses.

Hi Philip & thanks for the info!

I tested pretty much everything, including swapping network and sata cables… and of course after checking cpu, memory, disk, pen drive and MD5 of the .iso. The hardware still works with Ubuntu 1604 but not with Rockstor for some reason. In the end I pulled out an (even older) mainboard using the same disk, memory boards and pen drive. The install finished cleanly and I now have a barebone up and running. Still can’t prove it either way - bug or hardware problem - I can only say I didn’t find any obvious hardware issues. I guess a hardware problem should probably be more likely on old hardware

Again, thanks

Best regards

Hi again

Just want to confirm that this issue was hardware related. I replaced basically everything (mobo, cpu, memory) and after that install & setup worked like charm and it’s been running stable ever since sometime in august 2016

Thanks for a great storage solution!

Best Regards