Leap 15.3 Repo warning

Not sure if anyone else is also seeing this, but I have been getting out-of-date repository warnings for the past day or so:

Rockstor:~ # zypper up --no-recommends
Loading repository data…
Warning: Repository ‘Leap_15_3_Updates’ appears to be outdated. Consider using a different mirror or server.
Reading installed packages…

The following 3 package updates will NOT be installed:
dracut-kiwi-lib dracut-kiwi-oem-dump dracut-kiwi-oem-repart
Nothing to do.
Rockstor:~ #

I ran into the same. It looks a little bit like a previous issue:

But as far as I know, Rockstor isn’t that easily compatible with 15.4 at the moment, so i didn’t try to update it to 15.4.
I’m sure somebody with a better understanding of openSUSE update mechanism will correct me.

1 Like

Thanks @Mark93 yeah I came across that after I had posted - maybe I should have checked beforehand :slight_smile:

I wonder if its just a blip with some mirror(s) - I wasn’t aware that 15.3 was already EOL.

@Mark93 Hello there. Re:

It isn’t yet but it’s EOL is scheduled for the end of the year.

@Mark93 re:

Yes, 15.4 has no Python 2 by default which we still use. But once our testing branch Django update settles we can tackle that next (along with it’s brethren).

@GeoffA Before doing a zypper action, and especially if you get this message, try the following:

zypper refresh

It then updates the local ‘view’/cache of the repositories and your should be good.

Hope that helps.


Yes I always do a zypper refresh followed by the zypper up no recommends command

The warning remains each time.

1 Like

Thought I’d update fyi all seems good this morning. Must have just been a ‘blip’.


I saw the same thing for a while even with zypper refresh, but today is has also disappeared.

I did a test upgrade from 15.3 (with kernel backport installed) to 15.4 on a VM to see what would happen, and it seemed to have worked fine on the surface, but of course, since it was an upgrade the existing dependencies like Python 2 remained in place from the original install. Since I am not testing every single feature in that VM I won’t run the risk to do this to my “prod” instance, but I was just curious about it. I guess, if anything, it is somewhat of an indication that the “standard” component upgrades are possibly not impacting Rockstor, which could be a good sign, once we get closer to a newer Django version in the test channel.