Leaving rockstor

WHAT ??? so we don’t plan to get filthy rich on this project like apple does ? WTF ?! Have I missed a memo or something ?

2 Likes

Allthough I’m not a developer or power user or in any sort of way a heavy contributor to this project, I still find the original post a bit harsh.

For me the experience has been bumpy, and I have seen my share of issues.
But I have never lost one single bit of data, except in situations where I can only blame myself.

Rockstor is a ~ 1½ year old project. With , I’m guessing, a handfull of people developing it. Running a new file system that is still in heavy development (by other people). Of course there are going to be issues. Comparing this project with Apple is completely out of proportions.

But I have found it to reliable enough, if I just leave it to do its thing.

My setup is on rather old hardware.
I run a simple setup, SMB, NFS, and Plex.
Have also set up E-mail alerts.

And even though I do find the initial setup a little difficult (Plex is hard to get running properly), when the setup is done, Rockstor just does its thing.
I dont experience crashes, and during the summer period (where updates were few) I had uptimes at upto 2 months without reboot.

But there is still a lot of work to do. Rock-Ons need a lot of work IMHO. They are hard to setup, and every time I have set up more than one, it has given me problems. So there is room for improvement.

All I can do is report what I see and hope it gets fixed. And normally it does, or I get help to fix my problem.

Rockstor just needs time to mature, and all we can do is support the developers, and not discourage them, in doing the best they can. They are in a learning situation too.

I for one, is going to give it time. For now it does what I want it to well enough.

If one should say anything negative about the project, it could be that it is basically premature, as the base filesystem (BTRFS) is not ready enough.
Functions on which this project relies, does not work, or work unreliably. This is not the Rockstor developers fault though, and I hope that when BTRFS matures, so has Rockstor. And then it will be a very solid and flexible product.

2 Likes

@KarstenV thanks for your kind post,
I’m sure everyone (contributors, testers, etc) will appreciate it, both for your gentle words and suggestions (constructive “criticisms” are always good and welcome!)

@Tomasz_Kusmierz

No! Our big plan : have lot of testing and train a troop of fighting guinea piggies!!! :pig2:

1 Like

I’m not a professional developer but I do program, play with arduino and raspberries, and build my own systems. I’ve run Ubuntu, puppy Linux and various other distros, but usually stuck to the GUI with very little need to access the shell.

For Rockstor I chose an AMD Athlon 5350 running on an ASRock AM1H-ITX board. Runs around 25 watts without the HDs and is powerful enough for day-to-day. I probably couldn’t run Plex but that’s OK since I use Kodi running off an a 2nd gen Fire TV connected via ethernet. 1080p with no issues.

BTRFs support was the primary driver for me opting to use Rockstor. Cognizant of bit-rot, I used to perform a bit-level compare between my master copy, my onsite backup and my offsite backup. Now I preform either a bit-level or CRC compare and trust Rockstor to be my master of my family’s photos, videos, scans, personal audio recording, documents….

Thing is – there are times when I think I’ve made the wrong choice. Not because of anything inherently wrong with Rockstor or because you guys aren’t helpful, rather it’s because I don’t know Linux.

Most solutions I’ve had to look at here require you to get root access and execute commands which may result (at least in my case) with a series of posts where I feel bad for wasting people’s time. And then when I can’t get something working, I give up. Like for example, I haven‘t been able to get OwnCloud working because whenever I try to launch the GUI I’m told the server is refusing connection. This might have to do with my router, because of the port being used, or maybe a config option. I spent some time researching it, but then gave up. Then I see Synology supports BTRFS… at like 100x the price I paid for Rockstor.

But recently when my Rockstor build died and I wound up reinstalling it – which in itself took a lot of time because I was getting ‘root filesystem is not BTRFS” on a brand new SSD which lead me to several iterations of playing with the storage options under “Installation Destination,” only to finally create a bootable USB with gparted on it and wiping the partitions I must have created on the SSD during the installation process - I wonder, am I over my head? Am I risking my family’s archive? Why is it now that when I ask Rockstor to reboot, it hangs during the boot requiring a cold boot? I think it has something to do with an interrupt conflict with the MB but for now I’ll let it go. Have I been a penny wise and a pound foolish? Do I have to install a certificate on my desktop because every time I connect to Rockstor HTTPS doesn’t work? How do I know if BTRFS is actually working? When I run a SCRUB, was anything done? What’s the health of my drives? Will I be able to recover from a HD fail? Why can’t I have a USB drive attached to my NAS box and have Rockstor schedule a backup to it? How to I limit user rights so that my daughter doesn’t accidentally delete a file?

Some of these things such as HD health require me to go into the guts of the RockStor GUI, other things I’m sure I could figure out on my own. But that’s the thing – I’ll have to figure it out and hopefully not break something in the process.

None of this is a fault of Rockstor. It comes down to me being the wrong type of user at this stage of development.

I have no plans on leaving Rockstor but there are times when I have given it serious thought.

Hi @William212,
first point:

Wasting time: this is not wasting time ( my point of view: that’s a win-win game, you win, developers/other users win perhaps having a new how-to or new ideas about enhancements)
Wasting time: argue with my neighbour about not feeding pigeons + clean up pigeon feathers flying home :rage:

next point:

We have to work more on this, I agree!

Never ever give up: there’s a forum where you can ask and talk with other users and I’m pretty sure at least one will help you!

Moving to tech side of your post:

I’m quite sure we have a dozen posts about USB boot, root filesystem not being BTRFS (wiki/docu), etc, but asking @phillxnet help for refs.
@William212: feel free to have a new ad hoc forum post :slight_smile:

Yes, no, yes, no : you’re risking your family archive like you’d do on every HD (am I risking my data on my development environment used to code Rockstor? yep, sure but that’s a development environment with no data!)
No risks / less risks: 3-2-1 rule!
Our “fault”: usb backup not yet added, but you can accomplish that on your own via shell (back to point 2, we’ll solve it!)

Not your fault, not Rockstor fault: Rockstor certificate is self generated so not recognized by your browser (this is good and normal!). You can add a browser exception

Point 2 once again

Do you have SMART? (disks section)

Well, once again yes no yes no: RAID 1 disks ? quite sure about that. RAID 0 disks? NO

see previous answer :slight_smile:

Tie her to a chair! Ok, no, other “on the fly” solution:
have a samba share with an owner (you), create a new “readers” group, create a new user (your daughter), add your daughter user to “readers” group and add that group to your share only with read permissions :slight_smile:
M.

I get it that some things are out of Your control. Probably like the BTRFS quota issue. I’ll probably try Rockstor again in 6 months. I tried purging the rockstor package with yum and reinstalling it , and it failed to boot. I’ll try that again before summer and see how it works. It would be nice to not have to reinstall the whole system.

Thanks Tomasz and Suman

I’m not sure Synology is much better att supporting BTRFS given that BTRFS itself is fairly new. Not knowing Linux isn’t really a big problem. You learn things one at a time. Set up a virtual image of say Debian, create a partition you format with BTRFS and play with the tools. One of the keys is understanding most of the terms. Next is a couple of good links:

https://btrfs.wiki.kernel.org/index.php/Manpage/btrfs

Like this
root@NAS ~]# btrfs filesystem show
Label: ‘rockstor_rockstor’ uuid: 0f9e1be2-0601-4325-9c81-2525c175c4c9
Total devices 1 FS bytes used 4.79GiB
devid 1 size 208.00GiB used 8.06GiB path /dev/sda5

Label: 'storage'  uuid: fb47d047-55ba-4b1e-8187-215f5a04d134
	Total devices 2 FS bytes used 443.91GiB
	devid    1 size 2.73TiB used 455.03GiB path /dev/sdb
	devid    2 size 2.73TiB used 455.03GiB path /dev/sdc

or
btrfs filesystem usage /my_btrfs_mountpoint
btrfs balance start /my_btrfs_mountpoint
btrfs balance status /my_btrfs_mountpoint
btrfs scrub start /my_btrfs_mountpoint
btrfs scrub status /my_btrfs_mountpoint

also check out the wiki page for BTRFS with multiple devices. You can also try this with a virtual image. just create 3 partitions with 2GB each and play around with them.
https://btrfs.wiki.kernel.org/index.php/Using_Btrfs_with_Multiple_Devices - this page explains a lot of the terms used

btrfs filesystem balance start --full-balance /home/ &
btrfs filesystem balance status /home/

https://btrfs.wiki.kernel.org/index.php/Balance_Filters
you can convert a single fs to a raid by using the balance filters

[root@NAS ~]# btrfs fi balance status /media/
Balance on '/media/' is running
4 out of about 456 chunks balanced (5 considered),  99% left
[root@NAS ~]# btrfs fi show
Label: 'rockstor_rockstor'  uuid: 0f9e1be2-0601-4325-9c81-2525c175c4c9
	Total devices 1 FS bytes used 4.79GiB
	devid    1 size 208.00GiB used 6.06GiB path /dev/sda5

Label: 'storage'  uuid: fb47d047-55ba-4b1e-8187-215f5a04d134
	Total devices 2 FS bytes used 443.91GiB
	devid    1 size 2.73TiB used 456.03GiB path /dev/sdb
	devid    2 size 2.73TiB used 456.03GiB path /dev/sdc

[root@NAS ~]# btrfs fi df /media/
Data, RAID1: total=454.00GiB, used=443.27GiB
System, RAID1: total=32.00MiB, used=80.00KiB
Metadata, RAID1: total=2.00GiB, used=652.38MiB
GlobalReserve, single: total=224.00MiB, used=0.00B

And scrubbing :

So … it’s not that hard … when everything works … The thing is I was also reluctant to trust my family pictures and such to a bleeding edge filesystem, but decided to have two sets of backup, one on a raid 5 on my desktop, and one on a RAID1/BTRFS on the NAS. I’ve had some errors with BTRFS but after some googling it sorted itself out. As long as you run single drive or RAID0/1 it’s probably stable enough for you and me.

Fiddling around with Linux you’re always going to hit some speed bumps, with installation issues, booting, lost boot sectors, and so on. It’s called learning the hard way. It’s only when you’re over your head when you push the boundaries.

http://www.techrepublic.com/blog/linux-and-open-source/using-smartctl-to-get-smart-status-information-on-your-hard-drives/ - for working with smart. My first google result

You see, everything in Linux is more or less easiest done in the command line. Just get used to not being afraid of being root and executing commands. Also make sure you understand what the command does, and maybe play with it in the virtual machine before trying it live. In VMware for instance , you can take snapshots of your VM so that if you break something it takes 5 minutes to roll back.

Good luck !

1 Like

I left Rockstor some time ago as well. I like Rockstor, but btrfs I just can’t trust Rockstor. I now have 22TB on Windows Server Storage Spaces, but I continuously track the progress of btrfs so I can come back to Rockstor.

1 Like

I agree with most of the responses to the original poster. Especially that things like bittorrent & plex should remain off by default. But there are a couple of valid points around fixes \ functionality needed:

  1. “btrfs quota issues”. Many have reported them. Despite this, it is still necessary to manually type btrfs quota disable <pool> in order to avoid consuming 100% cpu and prevent the entire NAS freezing. BTRFS quotas have been broken for a long time now and Rockstor services should not be dependent upon them. Shouldn’t have to type btrfs quota enable <pool> to start samba (and then disable again to prevent lock-up).

  2. Scrub feedback. “Error” isn’t very descriptive.

problem is that they don’t checksum you data, if something corrupts it … you will no know, and mirrors will not help you because you will not know which one is right. Also “Windows Server Storage Spaces” is not cost efficient for some.

preaching to the converted … it’s not that simple to switch it of but we have some discussion going that way. We ARE severely underpowered - if you want to get this thing solved, code it your self and we will test it to death and get it mainstream !!! Seriously if anybody has some coding skils -> github -> help out !!

1 Like

Well, I am off as well,

BTRFS is the main reason for my exit.
And also the hassle with Rock-ons, It works,but to write new Rockons one need a bit of bug-testing. Thus my suggestion for new docker interface so that powerusers can use docker to its fullest, while the regular homeuser can use finished rock-ons.

I love the idea of Rockstor, but at the moment i cant trust my data with BTRFS so I have converted to Openmediavault with ZFS. Im back to Rockstor the moment at least BTRFS if fixed.

See you back in 3045 :slight_smile: (yes, sometimes I’m loosing hope as well, but I’m a optimistic pessimist :laughing: )

1 Like

I have my concerns.

I’ve started trying/using RockStor for a couple of weeks now and I found this post after I started using it but thought, hey it was 2016 and it’s now 2020 perhaps some things will not ring true anymore.

My Experience so far;
I started with recycled free hardware (HP xw4600 Quad core & 6x 3TB Enterprise drives).
I had troubble getting my on-baord 1Gbit NIC working with the installer image, however I experimeted with a USB 10/100 NIC and with an online update the onboard NIC worked.
I have installed RockStor to a new 16GB USB Drive to keep the OS and Data Storage Seperate.

I’m using Version 3.9.1-16, which is indicated as the latest version. System Shell Link has never worked for me. Prompts with “502 Bad Gateway”. I’m not sure what it is but I’ve had a good experience with xTerm.

I have noticed that after 2-3 days, I need to reboot Rockstor as I loose the Web interface.
The Web loads with a Title bar and Page not found errors.
Rock-ons that I was using looked like they were working, etc.
The last reboot, I was unable to get to the Web Interface at all.
I found a post about initrock and django upgrade. However I found that there was a problem writing to the disk. I deleted a log file /opt/rockstor/var/log/rockstor.log.3 and tried running the command again, perhaps with a reboot and was able to restore oprations to my Rockstor.

Looking in the logs, there is a flood about S.M.A.R.T. Errors regarding the USB Drive but the Drive page indicates “Not Supported”. How do I disable this checking as the Off switch is removed because it is “Not Supported”. I’m tring to specify the type as “-d test” to see if it is way of skipping the log.
The USB Drive indicates my 16GB Drive as 12.7GB, ideally the installer would have made use of the whole drive instead of a bit over 3/4.
The Pool indicates 1GB of Free Space, The root Share indicates 2.4GB used with 10GB of Free Space. Hence I’m unsure of the issue I appeared to have resolved by deleting a log file.

There is no classic FTP option.

There is no option to Share a drive as is. If I want to connect a USB hard drive with existing Data, I can’t just add a CIFS map to it.

Now for Rock-ons; (I know you don’t control all of these but it would be good to have a stable / experimental / Community channel options to choose from, perhaps with community upvote option to move an experimental version into a stable channel, etc.)
Rock-ons appears to be a whole lot of trial and error. I followed the instructions and created Shares for each Rock-on as requested. Some should indicate that the “Downloads” Share should be common to that of the Torrent Rock-on Download Share. There should be a Quick-option link to creating a Share with pre-configured options. i.e. the share name of a rock-on, permissions for the Rock-on to use the share, etc.

I installed uTorrent, it appeared to load, etc however it was unable to download anything. I tried changing Share permissions but for all I could tell perhaps the shares were not mapped correctly in the rock-on, hence no matter the changes I made I could not get it to work.

I installed PiHole, it works but RockStor indicates that it is not working?

I tried Sonarr and Radarr, they worked, however I wanted to scan a Network location that I have media stored on and I’m unable to add this simply. RockStor has no GUI to Map CIFS/SAMBA locations into RoclStor.

nginx - Indicates for Advanced users only, I followed the instructions and I was unable to get this working.

SmokePing - Works but has no documention on how to configure it. I mapped it’s configuration share, changed the permissions and was able to make my own entries and restart it. However the permissions get changed back so I need to repeat the process for any more updates.

I tried OwnCloud but it fails to load anything and hence I’m unable to proceed with it or the other linked rock-ons.
I tried Handbrake but the GUI fails to load and hence I’m unable to proceed.

There should be a xTerm option for Advanced users to get into a Rock-on directly and configure things for it. Hence it would be good to be able to create your own Rock-on from the GUI and make it avaliable, etc.

Overall, I like the potential however I’m concerned about progress and if the system can look afer it’s self.

Regards,

B

I have worked out How I ran out of space.
the CIFS/SAMBA Share automatically Maps a share the logged in user Home Directory as avaliable but this happens to be the part of the ROOT storage device and in my case that was the USB Drive.

Hi,
Here a new Rockstor user too …

Due to corona I was looking to ressurect my old FreeNAS server. Couldn’t update to the most recent version due to the fact that my mobo only has 2gb onboard.

I found Rockstor in a Best Top 10 NAS webpage. Plus the fact that it uses CentOS.
I decided to install it. At first there were some hassles but it didn’t stop me yet.

Finally I have it up 'n running. I’m running 3.9.1-0. The most recent ISO I could find and it’s a bit old.

Could activate the features I needed. NFS/SAMBA/SFTP.
Rock-on is a bit strange. I’m using pi-hole (says it’s OFF) but it’s fully functionally.
Plex, Sabnzb and Watchtower were a breeze to install. No problems with that.

However OpenVPN, Crashplan didn’t succeeded. And although I cleaned all unused containers/settings I still can’t get these rock-ons working.

I want to install a docker not on the list. But the documention isn’t clear enuff for me. But I will dig into it later.

I have installed my own vpn (PureVPN) so all traffic outside is encrypted. The NAS self isn’t remote available (yet).

The NAS is performing well on a GigaByte GA-D510UD (rev 1.0) with 2gb RAM and 4x Samsung HD753LJ disks.

Oh yes system shell doesn’t work!! But ssh is fine with me.

Still in doubt to activate stable updates.

Is there any development with Rockstor? This forum seems to be a bit outdated.

Cheers.

@b8two Welcome to the Rockstor community and thanks for the feedback.

Re:

This use to be the case and is again in our openSUSE channels (early releases as yet) but we stopped releasing rpms in the testing channel for our soon to be legacy CentOS base around Nov 2017:

which is equivalent to the last testing channel release on CentOS of 3.9.1-16.

The original post in our Stable Channel updates thread explains this:

So in the interim there have been many releases and improvements both on our side and in upstream.

However we have now re-activated the testing channel but only for our new ‘Built on openSUSE’ base, see the following forum thread for this:

Our Update Channels doc section alludes to this plan but as this is currently pretty early days in our transition, at least on the public release side, I haven’t yet updated the docs. But soon hopefully.

And we are currently releasing in unison to both channels but as follows:

  • Stable Channel: Our based on CentOS offering.
  • Testing Chennel: Our ‘Built on openSUSE’ offering.

Where they are build from the exact same source code although due to ditro differences, which we are currently working on fixing, there are often different ‘paths’ within that same code.

The caveat is that currently we have no publicly released installer for our ‘Built on openSUSE’ variant so one has to start with a Leap15.1 or Leap15.2 beta install and make the minor modifications listed in the thread above.

I’m actually currently working on cleaning up/improving the automation element of creating Leap15.1, Leap15.2beta, and Tumbleweed based installers. And we have current testing channel rpms available now for all of these. The installer build system I’m working on currently pre-installs these testing channel rpms but once we have feature parity with our CentOS based offering we will reverting to installing a Stable channel rpm into these installers. As per our prior release strategy for our installers.

Yes the erros in the log are what inform the “Not Supported” condition with the Web-UI. We essentially try to enable smart and if there is an error we say it’s not supported. Sometimes there is a work around via custom smart options detailed in our S.M.A.R.T doc entry, specifically the “Disk Custom S.M.A.R.T Options” subsection which uses this common smart error log as an example. Many USB devices just dont’ support smart but some do with a custom switch.

Some of the dive is swap and boot, the rest btrfs; hence not all available.

No, but pull requests are welcome. But we have had near zero requests for this. Rockstor is not aiming to be all things to all folks, but to do the most used things well: and there is much for us to still do in this regard of course :slight_smile: .

No, and this is unlikely to be added. We are specifically btrfs and the additional complexities in supporting this are better addressed by systems that aim to be everything and the kitchen sink. But you could create a new pool with an external btrfs whole disk and share that out via it’s subvolumes.

Yes this is an excellent idea. Thanks. It has been considered but of course we always seem to have more pressing stuff on. Especially during our multi year transition to the ‘Built on openSUSE’ re-launch. Would you care to create a GitHub issue for this. As it will require quite a few changes in the core code it would best be placed in the rockstor-core repo:

there will also have to be additional maintenance / voting / feedback to maintain these and changes in the back-end support infrastructure that uploads these and some kind of transition over to this system that doesn’t break every existing install so it’s definitely no trivial but there is merit in the idea and we can gather ideas around it’s implementation under the suggested issue.

Yes agreed. But as usual that is easier said than done. We do have existing issue open of such an enhancement here:

But we have some improvements that need to be in place within the Rock-on definition first before we can viably implement this kind of one click install and the like. But it’s definitely a goal.

That strange as I tested that one myself recently prior to merging it. I know that our now over 2 year old CentOS testing release still uses the older docker where as Stable release and testing channel for openSUSE have long since moved to docker-ce. See the following proof of function prior to merge:

Take a look there and see if you find any clues as to why it’s not working for yourself.

You are more than welcome to contribute some and put in reproducible methods for your issues on all of these Rock-on issues in our Rock-ons page. Some docker images may just have fallen into disrepair and we are happy to delete them if that is the case. And have recently removed some for similar reasons or through being replaced by better options. Please keep in mind, as you state, that we depend upon the community to help with this project of ours. And your points failure each need to have exact reproducers detailed in individual GitHub issues located in the correct repository so that other’s might pick them off if they fancy stepping up to the task.

Again this is one I proved working myself and @Flox also tested it as working, although we likely used more recent versions of Rockstor as that makes more sense moving forward. And we usually pove the function of each rock-on in both our CentOS and Leap variants. Though both use docker-ce.

So this may be further evidence of an issue with your particular setup. I’d suggest using a more recent Rockstor version for your trials. Especially since have have had so many issue that have not otherwise been reported by others.

Yes, another nice idea. This could be another button, against each rock-on, that is only shown when an advance option is ticked within the rock-on web-ui. Please consider making this an issue in the core repo as that is where the code would have to be:

And inviting some discussion on how best to implement this both in the back-end as well as within the Web-UI here on the forum, in a fresh post, would be good.

I’d like to invite you to try a more recent rockstor version as many issue you have reported don’t have confrontational reports. Also note that your follow up post:

Could account for any number of issues. Linux systems with no root space are typically a house of cards as they need working root to function.

Thanks for putting so much effort into this report, I’m not convinced that your root full issue didn’t spill over to many of your other issues however and would be interested to see if you can reproduce especially your issues with the Rock-ons I mentioned with a more recent version of Rockstor. In this light I will contact you via PM about this. Also note that regular USB key drives just don’t work with rockstor. We are not a cut down linux my any means so absolutely require fast USB key not regular ones, although ssd or hdd is far preferred. See our Minimum system requirements on this.

  • 8GB drive for Rockstor; if USB key use only fast variants (16GB+ SSD recommended).

And this recommendation is likely to double for our imminent ‘Built on openSUSE’ variant.

So thanks again for the feedback and I look forward to potential follow-ups regarding more recent versions of our offerings. Either via the Stable Chanel or our current ‘Built on openSUSE’ testing channel. I’ll contact you via PM for options there.

Hope that helps, even if it is only to clarify our current development.

1 Like

@dont Welcome to the Rockstor community.

Yes 2 GB is really a very bare minimum these days and is our minimum Ram specification as it goes. But as long as you don’t run a large pool and don’t run many Rock-ons you should be OK. Also don’t use the btrfs parity raid levels of 5/6 as they are less well able to cope with lower memory conditions and are younger implementations as well.

As posted previously in this thread our new Testing Channel is actually openSUSE Leap 15.1+ only and upon reaching Stable status we will be moving over, in time, to only releasing openSUSE rpms but for both Channels.

Yes our ISO is now 2.5 years old. But our new one will be openSUSE based and we have to get our openSUSE based offering into shape before we release that one. But it’s in private alpha test currently.

There may be hints in my last post on this as our ISO release (essentially 3.9.1 and our testing channel, 3.9.1-16 (a few months newer) both still use older docker and we have moved to docker-ce in our testing channel for openSUSE. Or you could try a stable subscription to get the latest, I see you have contributed a rock-on json in another post so lets circle back around to a stable subscription in that thread :slight_smile: .

Try changing it’s mode, we had an early bug on this, see the spanner icon next to it’s name in the System - Services. That should fix that one hopefully. But works more reliable in our newer offerings. Again lets circle back around to that one in your other thread:

Our last stable release was 3rd April (11 days ago) and they are Announced / documented in the following thread currently for the 3.9.2-* releases:

Also see our rejuvenated “Built on openSUSE” Testing Channel effort:

But as yet no installer for that one.

We also have a Rock-ons Announcements (form tag) thread here:

last updated 18 days ago as of writing.

I’ll continue this discussion on your newly submitted Rock-on post referenced earlier.

Thanks for the feed back, much appreciated.

Hi there,

I’ve had an experiment going with Rockstor for a couple of months now.
For a BTRFS based NAS project, there are slim pickings.

I’ve made an installation that was indicated as will work however is not recommended. (USB system pen Drive)

From what I can tell is that BTRFS was started with support by RedHat, CentOS and SUSE linux but CentOS have fallen behind in supporting the latest and greatest of BTRFS and that is where Rockstor need to be, hence there has been major effort porting across. This is the backgrond to the no Public releases.

As for the target market of the project, I’m not clear who that is.
It somewhat suits be Me clearly, however there are things that I’d prefer was done differently. e.g. Appliance type deployment.
There are Rockons that the target market is home users but also some that could be more, however I have been unable to get them working. (Web based office suite).

Once I have time to change my “USB system pen Drive” configuration, perhaps I’ll have a less tainted example of how it is performing.

I’ve been using RockStor for almost 3 years now. I use an SSD as my main system drive and a quartet of hard disks in a RAID-1 pool. Using BTRFS means I can easily upgrade disk sizes as needed, which is not as simple a task on a ZFS filesystem.

The CentOS 7 version of RockStor is now very old, the distribution’s stock kernel does not work with a lot of new hardware, most obviously some of the AMD Ryzen motherboards. There has been a long journey to port functionality over to the OpenSUSE, thanks to a handful of handful of supporting developers. When the OpenSUSE build is ready (in the coming weeks by the sound of it), it will be a much more up to date and well supported target compared with CentOS going forward.

OpenSUSE places BTRFS front and centre - it’s stock installer defaults to using BTRFS for the root file system, whereas on CentOS’s stock installer it was an optional, rather than recommended, approach. RedHat (the upstream origin of CentOS) have made it clear they do not recommend use of BTRFS.

I think RockStor is a similar target market to other bring your own hardware and tinker storage solutions (e.g. FreeNAS and the like). I find the NAS in a box solutions like Synology compromised (i.e. low powered processors, or limits on what the OS can do), so while I may recommend them for friends and family, I want more. I enjoy building new or re-purposing old hardware to fit my data hoarding needs. I don’t want our private household data obtainable from the latest cloud service breach, nor do I want a delay when want to open one of my 25MB raw photographs for editing.

RockOns are quite useful to me, I’ve run a few of them untouched and also a handful of custom ones which expand on the ones in the repository (e.g. an Emby one where I can plug in my individual shares at creation rather than adding the extra shares several times). Building or expanding them is quite easy, but it does require use of a text editor and a name that does not conflict with the repository.

The handy thing with having a solid Linux distribution is that we have access to all it can do, so I also use KVM on my server to run an always on desktop which I occasionally connect to when in a hotel over a VPN connection to access documents on my Rockstor box.

I have some much newer hardware I plan to deploy when the OpenSUSE image is available for use. I am looking forward to moving across my existing arrays for a quick replacement of my now 6-8 year old hardware depending on which bit you look at. The biggest bonus to me being a more up to date KVM build, where USB forwarding might actually work and working on Ryzen processors without fiddling with custom kernels.

1 Like

My 2 cents …euro for me :slight_smile:

I stumbled accross Rockstor in an older review (top 10 best NAS software).
The description, the looks …it felt good. At first I had troubles installing Rockstor on my older, self-build system. But after a few tries I got the system working.

The rock-on system had my special interest, not the btfrs part. I managed very quickly to install pi-hole and some other rock-ons. Since I’m a huge fan of domotica I wanted to run Node-Red on my Rockstor system. I managed easily to get Node-Red running. Then @phillxnet asked me to make a pull-request.

My first encounter with GitHub. Oh boy I had some troubles to understand the system but along the way I really got the learn GitHub and the way Rockstor is working. So at the end I was really happy with Rockstor.

My pros:

  • running on older hardware (> 8 years)
  • runs smoothly with just 2gb RAM. I have 4 rock-ons (pi-hole, node-red, sabnzb, watchtower).
  • runs CentOS (we’re running Rhel at work)
  • Stable subscription (easy updates)
  • Rock-ons
  • Can use some other third-party software (purevpn, portainer). Yes it survives reboots :slight_smile:

My Cons:

  • The move to OpenSuse …some sort! Have to learn OpenSuse :wink:

Next step will be configuring a new system and install the new Rockstor/OpenSuse build.

Cheers,

J.

1 Like