Many errors... Corrupt HDD? New To Rockstor, I need help!

Problem(s) at hand

So, I’ve got many issues, all of which seem to be relating to my “corrupted” HDD. So I’ve 2 hard-drives. 1 of which Rockstor is installed (with its normal shares such as home and root). Then I have my second drive which is partitioned with a few gigabytes set aside for rockons (mainly plex at the moment) and the rest is where my media files are stored.

I came to the conclusion the 1st hard-drive (with Rockstor installed on it) was a corrupted HDD after reading a forum somewhere. I then tried to do the checks on the hdd (using fsck & btrfs etc) but, its impossible to do a check on the mounted HDD (that Rockstor is installed on) without a lot of faffing around (with, what I read, a memory stick or something like that or perhaps it was another computer - too much work really for what I need to do)

Here’s some images of my problems (it may help the devs)
disk error log - p1&p2

CLI errors

Some more problems I’m having, I can’t seem to access sudo, or yum or anything like that (must be because of those faulty drive sectors). Rockstor CLI on the server lets me just sign in but then after a while it starts showing those errors above (or even if i dont sign in - it’ll still show the errors after a while of me using the server). Also after a while of being on the Web-UI also shows this

                                                       502 Bad Gateway
                                                     ---------------------------
                                                          nginx/1.10.2

I assume it can not access nginx consistently. Also after I reboot the server the web-ui will work for a short while again before showing that error again.

ALSO It may be weird (might not) but I am able to access PLEX & my files on the second hdd (through the PLEX rockon) without any trouble (even when these errors are happening). For example 192.168.1.78 doesn’t take me to the Web-UI (it shows the 502 error) but 192.168.1.78:32400 takes me to PLEX and I can play my media. Probably because most of the things plex needs are on the second hdd (but surely the second hdd would access plex via the rockstor hdd - but maybe thats a good sector anyway I digress).

ALSO another issue was ata3.00: status {DRDY}
AND
ata3:SRST failed (errno=-16)

I also can’t even map a network drive in Windows because of this apparently faulty drive.

My Questions

Can I get confirmation that the Rockstor boot drive is the cause of the problems, please?
Also, how would I go about fixing this? Would I be able to remove this drive then install Rockstor on another drive and still be able to access the files on my 2nd drive? Or will the files on the second drive be lost?

I would really appreciate some help on this please.
BTW I’m not a newbie when it comes to computing (in higher education for computing) but I am a newbie to Linux/Unix. So if there is any other way of solving this, I’d appreciate some clear (perhaps in-depth) instructions.

Thanks, in advance.

Hi @Mark_Jackson,

Welcome to the community! I’m sorry it’s under such circumstances…

I’m not a drive expert at all, so I’ll let others with proper knowledge answer, but I wanted to rule out something simple first.

Indeed, after some quick Googling for both the SRST failed error and the ERROR: ICRC reported by S.M.A.R.T., I found a lot of references to a loose or bad cable. Therefore, have you tried unplugging the data cable to this drive (on both ends) and replugging it to make sure it’s in properly?

I know it can sound too simple, but I’d rather rule out something that simple first before diving deep into drive troubleshooting etc…

Let us know how it goes.

1 Like

Hi @Flox

Although I’m ashamed to admit it, doing what you suggested solved the problem.
I saw that solution too when hunting down possible solutions but I assumed it to be not worthy
of trying because Rockstor had installed without problems mere hours before and the issues came out of nowhere.

I’m facepalming hard right now, I feel like an idiot. It’s too easy to overthink things.
They do say that most problems are one layer 1. I just wish I checked that supposed solution at the time rather than making a forum post about what seems to be a simple issue.
Still, maybe some other people can get help from this.

So now, I’ve done a little bit of testing on it and everything seems fine.

sudo works.
yum works.
Mapping the drive in Windows works.

It’s been running for longer than it would have been when there were errors (might need to test further) so fingers crossed it doesn’t happen again. Btw, even with the errors, I was still enjoying Rockstor & now even more because it seems to have a nice helpful community.

Anyway, thanks for the help. Very much appreciated.

2 Likes

Glad it only was something easy, and I hope you’ll be able to fully enjoy it!

Cheers,

Hey @Flox,

I may have been a bit too confident in that fix. Everything seems to have reverted back to the way it was. I haven’t shutdown the server since the fix was attempted.
I don’t have the monitor always on for this server, so I only noticed the errors again when I tried to access the mapped drive in Windows. I then tried the Web-UI and the “502 error” was there & in the Rockstor CLI sudo and yum (just tested to see if I had access to the files) do not work (blk_update_request: I/O error, dev sda, sector 9285344 etc)

IMG_20200602_190701

Anymore thoughts?

I’m going to swap the SATA cable to see if that’ll fix it.

Thanks.

[UPDATE] After swapping the SATA cable to the Rockstor boot drive there no longer appears to be any errors. It’s remained stable after an upload of around 25GB.