No GUI on HP Microserver N40L after install

Having managed to overcome the initial boot issue on previous post here. I’m having some other issues in getting access to the web GUI. This appears to be related to disk format issues somehow but being new here I’m a little bit lost and would appreciate some guidance please where to check services etc.

Quick overview of my setup, so I have N40L with 5 disks (removed CDROM, HDD installed), BIOS mod to allow compatibility xpenology and also open access to full speed SATA for port 5 (CDROM port), I boot from the internal USB2 port and have a 80GB 2.5HDD in a caddy which runs from here.

I’ve been running FreeNAS and more lately TrueNAS for a little over 2 years without issue, I wanted to move as I now have to rebuild the array due to disk changes and lack of flexibility with ZFS to achive this. I don’t want to get locked back in again once doing this.

I tried installing to a USB flashdrive but gave up after 24 hours and it was still running. Anyhow, installation completed, reboot and I get to the login prompt and get these errors that come into the console


The installation has been using auto settings so nothing funny going on here from my side.

Aside from the issue, there are a couple of questions, if this boot drive fails is recovery as simple as rebuild and re-attach the array after, much like TrueNAS ? Or is there a more robust way to deal with this installing Rockstor on all 5 disks using a smaller partition and RAID across all the disks which is similar to xpenology only using the USB drive to boot and then hand off to the disks.

Appreciate any assistance that can be offered with the immediate boot issue, the questions are secondary really.

Thanks in advance and thanks for this wonderful forum!

Hmm, seems like this was a hardware issue. Replaced the hard disk (2.5" IDE in USB2 caddy) for a new 2.5" SATA that’s connected over USB 3 into an internal USB2 server port.

The old disk doesn’t show any errors through testing though so unsure if this is interface related or not, all worked fine on TrueNAS, either way I’m now up and running and off to the races.


From what I can see in that dmesg log on your login screen, it does seem like that HD is indeed broken (Buffer I/O error on dev sdf1,... ). If you want to make sure, I suggest to run a SMART test on the HD (instructions for that are very easily google to find). A short one might even be enough (long ones take +4h)


Thanks Marenz, SMART is not so easy to run through USB as this doesn’t identify the drive as SMART enabled and its an older 2.5 IDE interface. Yes quite so possibly due for a change now.

Ah shame. I have an SATA -> USB adpater and SMART does work on that one. Seems your’s doesn’t support that