Installation stuck on HP Microserver N40L

Hi I am trying to install the latest rockstor on my standard build HP Microserver Proliant N40L and I get the boot screen to select Install Rockstor and goes on however it stops at the last line and not progressing anymore. I have waited for 10minutes or so.

I am installing using USB stick created via DD on linux mint machine

[20.168790] [] ? rest_init+0x80/0x80

When I use the previous build Rockstor-3.8.15.iso it goes on successfully.

@kwetiaw Welcome to the Rockstor community forum.

Thanks for the feedback; the installer was updated on the release of the 3.8.16 iso which generally helped in it’s stability but it looks like in your case there was a regression. All I can suggest for now is the work around of installing 3.8.15, then pick an update channel as prompted then update to a 3.8.16 release (latest). You should end up with the same thing, just remember to reboot after each update as we still have Rock-on issues directly after each update until after a reboot is performed. Plus if there are any kernel updates these will need to be put into effect in that reboot.

It may be that others have a more elegant fix / workaround but for now that’s all I can suggest.

We do have an open issue to upgrade the installer again so hopefully this will help in your case. But there is no firm schedule on this:

Hope that helps.

hi @phillxnet thanks for your prompt reply
I have since then used the previous version to install and then update. all seems to be in order now.

I’m using an Hp proliant microserver N40l like you. It happened to me too. I downloaded the previous version, and installed

1 Like

thats great news. i think the issue is specific with N40L :slight_smile:

Hi. I had the same issue with an N40L.

For anyone else doing the same thing now, there is an issue when updating from 3.8.15 to 3.8.16-13/14.

After upgrading, you will need to downgrade rockstor to 3.8.16-12 and then upgrade to the current version again.

More detail in this post

Just to remember this issue again.
This problem exists also up to Rockstor 3.9.1

I have a N54l. Same Issue.

I can use the workaround with installing 3.8.15. But this gets more and more outdated.

The problem looks to me like a kernel panic. The system stops. No backward scroll available. Just the screen above in the screenshot.

I tried several things like removing all disks except the one I want to install to. But nothing helps.

Are there any plans to fix this?
I am willing to investigate this, if you point me in an direction.

@Schrauber Hello again.

This issue here relates, as you state, to the kernel used by the installer and as we are essentially using an un-modified upstream CentOS installer kernel the only fix / work around is to use a different version of the installer/kernel (hence the reverting to an older version) or finding kernel boot parameters that address the specific difficulty the installer kernel has with this hardware. There are however plans to update the installer again to be based on hopefully CentOS 7.4 in the already linked:

That issue has an existing note to update this forum thread with any progress and I have updated it to reflect the pending CentOS 7.4 release along with it’s ETA:

Lets hope that helps and anything you can do to prove the upstream installer works would also benefit, but it has of course first to be released; unless you fancy trialling any beta releases of the CentOS 7.4 iso’s as they become available.

Otherwise it’s just down to finding a workaround via kernel command line options passed via the initial installer screen.

Thanks for offering to help and hope this has suggested a useful direction.

On which CentOS version is the installer based?

I tried CentOS 7.3. The installer works fine. No hang on boot.
The kernel line is:
vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=CentOS\x207\x20x86:64 quiet

So it seems there are no special options.

I changed the kernel in the ISO to one from a running rockstor installation via UltraISO. This leads a booting system without kernel panic. I end up on the kernel command line. I think this is because I can not write the ISO in DD mode. UltraISO gives me an ISO which must be written in ISO mode.

But to me it seems to be related to the kernel itself, not to the used options.

Can I somehow build an correct image by myself with a switched kernel?


As per the previously referenced issue it’s based on 1511 (7.2) as the 7.3 came out just after the new 7.2 based Rockstor iso had been prepared.

Yes that was also the finding of others, hence the push at the time for a 7.3 based installer; but the timing just wan’t right unfortunately. In the issue @tazzydemon 's explorations were referenced, re-referenced here for ease:

My kernel boot options suggestion was as an option to pursue with the existing installer kernel to avoid its kernel’s issues seen my some.

I haven’t tended to this myself as yet but hopefully all that you need should be in the rockstor-iso repository:

If you find anything a-miss there please open an issue / pull request as all assistance is welcome.

Hope that helps.

Hi, pretty new here and wanted to get a Rockstor up and running. I too have the same problem in this thread. So what’s the current best fix, updating the ISO with a newer Kernel (will need to dust off my linux skills for this) or find an older version to install with and upgrade. Anyone know where I can get previous versions?

I am still having this issue. Had to turn back to OMV, since I cant install Rockstor after hardware failure forces me to re-install it…

This is an old post, but is there a current resolution?
I’m installing on an old Gateway DX4320-01e w/ AMD945 and getting this problem.

I am trying to install Rockstor on my HP Proliant N54L704941-421 with AMD Turion II Neo N54L Dual Core CPU and 8 GB RAM.
I am currently trying to install Rockstor 3.9.1 from USB key on a local USB key inserted in the HP Proliant motherboard.
I have tried disabling ACPI and using “Install Rockstor 3.0 in basic graphics mode” under Troubleshooting but nothing changes. I always end up with the same error that is posted at the beginning of this post.
Can someone help me with this issue ? I have read various other posts but nothing seems to work.
Thanks in advance for your help.

Hey guys,
looks like I solved the problem by myself.
I added « nosmp » on the kernel command line and canceled quiet… now Rockstor 3.9.1 is installing on my HP Proliant N54L.
Hope this will help someone else that is having my issue.

1 Like

@carlasella Welcome to the Rockstor community and nice find there.

Thanks for the update and for sharing your findings. Remember to select an update channel when prompted as you will then be offered much newer Rockstor code (and a slightly newer kernel) than comes with the iso. Also stable, as a value add for subscribers, is now much newer than testing (we had to refocus more recently). But last released testing channel is still fairly usable.

Hopefully you won’t need this kernel option as once installed Rockstor changes over to a much newer kernel than is default in our current CentOS base.

Which generation is your HP Proliant N54L?

Let us know how you get on.

@phillxnet Thanks.
Thanks for your suggestions they are valuable.
My HP Proliant N54L is a 7th generation server.
It worked ! I’ve got Rockstor up an running :smile:.

@carlasella Thanks for the info, these look like nice little devices. I think I remember project lead @suman having an older generation of these. They look to be very tidy.

That’s great news. Did you select an update channel and then install the consequent updates.? By default when using the System - Software Update page you also get all the upstream updates. And given the iso is geetting a little old there are quite a few of them. You can also update all but the rockstor package via the flashing (wifi) icon next to the kernel version.

Give all updates a while to apply though as we have had breakages when people reboot during an update.

Keep us posted.

YW. I did not yet select an update channel as I am still in the testing phase, I am new to Rockstor. If I succeed in what I am planning to do I will certainly select the update channel and apply updates. Thanks for all your suggestions, they are valuable if I succeed to put up a fileserver as I planed I will do as you say.


OK, that makes sense. But there have been quite a few fixes released since the iso was released under the testing channel. So you could select that one first and get at least some improvements, plus the slightly newer kernel of course (which is important). You can always then switch to the value add stable (which is now the much newer of the two) later down the line and in doing so help to support development financially if that works for you.

A known chicken and egg bug when changing from testing to stable however:
Make sure to confirm you actually have installed what the Web-UI interface states. This can be done via a terminal as root user:

yum info rockstor

We had a bug when switching from testing to stable where the Web-UI would show available version not installed. That was really irritating but never mind. It is now fixed and so once we get another iso out we can forget it. But of course if you don’t know of it then you thing you are on a newer version and it doesn’t ever offer to updates via the Web-UI. Details in case you are interested:

Essential the Rockstor code age is as follows:

  • iso 3.9.1-0 (July 2017)
  • testing channel (Gratis) 3.9.1-16 (same as 3.9.2-0 stable at the time (November 2017)
  • stable channel (Paid subscription to help with the projects development) 3 days ago.

You can see the details for the fixes introduced in each release on the GitHub Releases page:

All code in all versions is GPL v2 or later bar the js libraries which are all at least open source. So you might as well try the testing code for your testing and either stick with it or get the newer stable code. In time we will release a new iso and so all new installs will again be bang up to date (at least for a while). But that’s not the case right now.

Hope that helps and thanks again for sharing your fix / workaround for getting this hardware working on our now rather old installer (we are working on that). Much appreciated.