Phantom Errors?

I noticed that if I access my big storage Raid 10 setup while a SCRUB is taking place that I get ERRORS. Not sure what is causing it, but I clear the errors and repeat without accessing the RAID 10 setup then no errors happen. I’ve repeated this several times and it always has errors.

Generally when this happens, I am deleting and moving things around on the share.

Any idea’s on this?



PS: still healing from my second kidney surgery…

@Tex1954 glad to see you around, and hope the healing progresses nicely.

Can you refresh my memory on what version you are currently running? Stable 4.1. or one of the release candidates from the testing channel?
When clicking on the hyperlink to view scrub details does it show specific errors?


Yuppers! Running stable 4.1 and no other problems really noted these last few months.

Errors are always READ errors on random drives and all drives show ZERO S.M.A.R.T. errors.

Wild guess is I happen to delete or move a file while that file is in the middle of a scrub or something like that… It’s very repeatable.

These are the errors:



I think I read somewhere at some point that looking at dmesg can give you more details on what files the errors occur with.

I think with something like this you might be able to filter out whether these files are indeed the ones you’re moving during the scrub …

Ah, here is some reference that I think I had looked up in the past:

dmesg| grep -e "BTRFS warning.*path:" | sed -e 's/^.*path\: //'

or you can do something similar using journalctl:

journalctl --dmesg --grep='checksum error'

If it’s indeed your files that you had been moving, then it proves your point …


I tried that and there are no messages left in the buffer; presumably because I cleared them and ran 2 more scrubs without accessing the share to triple check things.

Soon, I will try the same test again and try to show the same error type again, but I am in the middle of some other things ( including adding 2 more HD’s to the the RAID 10 setup).

I’ll let you know…