Pi-Hole rockon not working

Brief description of the problem

after installing Pi-Hole Rockon the web interface doesn’t come up

Detailed step by step instructions to reproduce the problem

Install the pi-hole rock on and click the pi-hole UI button. A page opens but fails to connect

Web-UI screenshot

image

image

One thing I have noticed is that the json at https://github.com/rockstor/rockon-registry/blob/master/pi-hole.json seems to be missing some of the ports on https://hub.docker.com/r/pihole/pihole. When I tried to copy the json add the ports and load it manually with those ports it failed to install.

It worked a few months back but nothing is working now.

1 Like

Thanks for the report, @Bee_rii.

It seems we need to update the json definition, indeed. I don’t have access to my test machine at the moment but I should be able to try later today.

Did you change the name of this new customized rock-on in the JSON file before clicking the “Update” button in the UI? I’m hoping the issue you encountered results from something simple like that, otherwise we’ll probably need further troubleshooting.

Thanks again for bringing this to light!

1 Like

Hello again @Bee_rii,

I just tried to run the Pi-hole rock-on on my test machine and it all seems to work as intended. I thus looked further at your screenshot and noticed something odd that I believe might be the reason you’re seeing this error while to access the webUI. Indeed, could you try using the non-HTTPS url for it? Pi-hole’s webUI should be accessed on non HTTPS port (as you’re specifying port 86). It should thus be:
http://<server.IP>:86/admin
Now, the rock-on JSON is configured so that the “Pi-Hole UI” button already points to that URL without httpS so I’m confused as to why your screenshot does seem to indicate the use of an httpS URL.
Could you verify that when you click on the “Pi-Hole UI” button in the rock-on page, you actually are redirected to the http address and not the httpS? Also, could you try manually entering the http://serverIP:86/admin URL and see if you can indeed access the webUI?

Thanks!

1 Like

When we say pihole isn’t working is the docker container running at all and what do the docker logs say?
on the bash prompt can you check the following

We should update the ports but 67 is for DHCP and 443 could be added but this should still work.
Often pihole doesn’t start up all the way and hangs (in my experience).

(replace pihole with the name of the container but mine is defaulted to pihole)

docker ps -a | grep pihole
docker logs pihole

try to restart pihole and check logs again if you don’t see anything

docker restart pihole
docker logs -f pihole

hit ctrl-c to stop logs when you’re ready. Is there any information or does docker refuse to run the container at all?

1 Like

@Flox Re:

Might this be a browser plugin trying to enforce https where it is not wanted ?

I.e. something like: https://www.eff.org/https-everywhere

@Bee_rii Could you confirm if you are using such a plugin or not?

Normally great but in this case an exception may need to be added for this particular URL.

Hope that helps.

1 Like

Hi,

I typed the HTTPS manually just in case but it doesn’t work without it either.

docker ps -a | grep pihole
returns

a06bc4ab9ac5 pihole/pihole:latest "/s6-init" 2 days ago Restarting (1) 11 seconds ago pi-hole

docker logs -f pi-hole returns

 Error: inet prefix is expected rather than "bhartman".
 ERROR: ServerIP Environment variable (bhartman) doesn't appear to be a valid IPv4 address

I deleted the service, deleted the shares and even deleted the rockon share and tried reinstalling the rockon but it seems to keep my config save. Where do the configs get saved? I can try deleting the config and starting from fresh.

1 Like

Thanks to @magicalyak, I think you found the culprit:

I believe you thus need to reinstall the rock-on and enter the IP address of your Rockstor machine (likely 192.168.x.x) rather than the hostname.

1 Like

yeah that’s sorted it thanks.

1 Like