Problem restoring config file


I have been testing Rockstor for a little while now, and decided to move my instance from VMware to KVM. I did a backup of the old system, on 3.9.0 using the config tool. I created a new instance and tried to restore the config file on a 3.9.1 system. This is the error I get when trying to import the config:

["isdir() takes exactly 1 argument (0 given)","Traceback (most recent call last):\n File \"/opt/rockstor/src/rockstor/rest_framework_custom/\", line 41, in _handle_exception\n yield\n File \"/opt/rockstor/src/rockstor/storageadmin/views/\", line 255, in post\n if (not os.path.isdir()):\nTypeError: isdir() takes exactly 1 argument (0 given)\n"]

The system had updates and I applied them, but I’m still getting the same error.

Thanks in advance,

@jorgy Hello again and apologies for the slow response.

This looks very much like:

which was originally reported by forum member @Flox in the following thread:

and their consequent issue:

and fixed in testing channel release as of:

via the following pull request:

These changes are due for inclusion in the next stable release.

The config backup file is human readable (just about once unzipped) but if you are careful (especially with indentation) you may find a work around by looking to the single one line change that ended up being the fix in the above referenced pr. You may have to restart your Rockstor service for the edit to take effect however.

Hope that helps.


Thank you for the comprehensive reply! I’m sorry I missed the issue brought up by @Flox. I’ve been doing a lot of testing of Rockstor in different configurations, and practicing restores for DR reasons. Glad to have this fixed, though I ended up re-building the server it was on.