[RESOLVED] Error expanding share

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Can’t resize share. The data has outgrown the share so I tried to increase it.

Detailed step by step instructions to reproduce the problem

Click on share, click resize, pick a new value, click save.

Web-UI screenshot

image

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/src/rockstor/rest_framework_custom/generic_view.py", line 41, in _handle_exception yield File "/opt/rockstor/src/rockstor/storageadmin/views/share.py", line 247, in put share_pqgroup_assign(share.pqgroup, share) File "/opt/rockstor/src/rockstor/fs/btrfs.py", line 1240, in share_pqgroup_assign return qgroup_assign(share.qgroup, pqgroup, mnt_pt) File "/opt/rockstor/src/rockstor/fs/btrfs.py", line 1294, in qgroup_assign raise e CommandException: Error running a command. cmd = /usr/sbin/btrfs qgroup assign 0/259 2015/13 /mnt2//Main_Pool. rc = 1. stdout = ['']. stderr = ['ERROR: unable to assign quota group: File exists', '']

I had tried rebooting before I raised the call without success. But then I saw there were updates outstanding. I applied them and then I was able to resize the partition. Not sure if it was an update or another reboot but all good now.

2 Likes