Rock-on repository / Zoneminder upgrade to 1.30 (from 1.29)


is there anyone possibly working or looking into getting the existing Rock-on repository upgraded to Zoneminder 1.30?
Any problems that may hinder to do so?

If not, has anyone tried to give the following official package (RedHat/CentOS) a try to install via the terminal and still all works out the same from Rockstor Rock-on UI afterwards? :slight_smile:


I’ll take a look. I haven’t found a good 1.30 Docker container out there. It’s really strange but it’s as if something broke Docker with 1.30.



I’m using zoneminder in production with multiple cameras recording actually critical data, and yes I would like to update as well … but you know old saying “if it ain’t broke - don’t fix it”

I’m not trying to put you off, but zone minder is a bit critical toy to play with so I would like it to run right than cutting edge.

@Tomasz_Kusmierz you are right, that could be an argument, but I personally like to have the latest releases.

Just an idea, I’m not sure if feasible or if it makes sense at all…

Maybe for the overall Rock-ons and the programs we could think of implementing a drop down menu for each entry; during the installation procedure you can select different versions like for Zoneminder v1.29 and v1.30, so everyone can decide on his own being an early bird or stick to an older version.

I’m not sure whom to include here to judge or to make a note for the ideabank?
@suman @Flyer


This all makes sense, I need to find a stable 1.30 docker container that works well. The ones out there have either been failing or so poorly constructed that I wouldn’t let others use it without big flashing red letters in CAPS. I’ll take another look this week to see if I can find one that works. Eventually I’ll make one myself but I’m wondering if there is some change that breaks compatibility? I’ll also see if I can make the option to specify the version or not. Ideally, a stable maintainer can be found and would always use the latest version. Thanks for the patience.

Working on a new one will post on status

I have 1.30 running but need some testers

You can drop the zoneminder-1.30.json into /opt/rockstor/rockons-metastore/ (create this directory if it’s not there)
You can grab zoneminder-1.30.json here

Make a zm-config and zm-mysql (name whatever you what) share
hit update, select the zoneminder-1.30 rock-on and select the two shares you created for the config and db
It should install and work. Let me know how it compares to 1.29 (you should be able to run them side by side)


@magicalyak thx
do you know where the ZM config file is located?
I was wondering if I simply copy / paste the config file from v1.29 into v1.30 would work without problems and not setting up everything again :grinning:

I wouldn’t do that but you could copy the shares. Make 2 new ones (maybe same name with -1.30 on end) and let’s assume the names are zmconfig and zmdata (and new ones zmconfig-1.30 and zmdata-1.30)

You can make a writeable snapshot of zmconfig (call it zmconfig-test perhaps?) and then select the clone button to make a new share from that snapshot (call that zmconfig-1.30)
do the same for zmdata
use those new shares for the new zone minder and see if it works (it might? it might not). If it fails, try to clone only the config directory and create fresh new database share and see what settings persist (probably none since they are stored in the database).

OR on the command line do this (after creating the shares in the GUI)

if you have rsync installed (if not just use cp example below)
rsync -av --progress /mnt2/zmconfig /mnt2/zmconfig-1.30
rsync -av --progress /mnt2/zmdata /mnt2/zmdata-1.30

or cp
cp -avr /mnt2/zmconfig /mnt2/zmconfig-1.30
cp -avr /mnt2/zmdata /mnt2/zmdata-1.30

Also just make a new file in the directory /opt/rockstor/rockons-metastore/ and call it something different (I suggest zoneminder-1.30.json ). Go to rockons tab and hit update, scroll and find the rockon once it finishes and install it. (it make take a bit to install)

Good luck!

Hi again,
I’ve tried today to install ZM 1.30 from the Rockons repository beside my existing installation of ZM 1.29 (which works well).
I’ve created new shares and perfromed a fresh installation, opened the options windows and made sure that all options/paths/variables are set equal (1.29 vs. 1.30), but there is no live stream available…broken stream (see below)

I’m using FFMPEG as before with the following input options -r 30 -vcodec libx264 -threads 2 -b 2000k -minrate 800k -maxrate 5000k and formats mpg mpeg wmv asf avi mov swf 3gp** mp4*, could it be that there is any modification needed for ZM 1.30?

EDIT: works now, I forgot one “/” within the link to stream server “/zm/cgi-bin/nph-zms” :joy:


Even if ZM 1.30 seems to work fine NOW comparing to ZM 1.29, I’ve observed that ZmView can’t connect anymore to the server. I’ve used this App on my mobile and tablet so far.

Anyone facing the same problem?

EDIT: ZM v1.30 allocated another port 8094 - SOLVED :joy:


Thanks for the feedback. Those of us who tested this didn’t have cameras and couldn’t test all functions. It may be this isn’t fully baked (thanks for trying a separate share). Can you walk me through how you set this up and if you know of a way for me to test without a camera? If not I may need to work with you to test out patches to fix this. We asked for feedback but didn’t hear any and pushed forward with the rockon assuming these functions worked. I apologize if they aren’t working correctly.
I also want to open an issue on the GitHub (unless you can) for the issue(s). If you know how to, please do. Otherwise I’ll do it for you using the info here.

These are the simple steps I performed…

  • I’ve created new shares e.g. “zm13_data” and “zm13_mysql”

  • Pressed “install” and linked the shares by selecting the drop down-menu

  • V1.29 and v1.30 were running in parallel, so I was able to open up and access the “option window” from each version

  • comparing / mirroring all settings from v1.29 to v1.30

  • same copy/paste of all settings for the camara and zone settings I had set-up

One “problem” I still face…the recorded events are not stored within the “zm13_data” share nor in any other folder - I’m not able to find those recordings. The recorded events are being displayed on the ZM GUI and can be re-played, but I don’t know where they are stored.

Could there be a bug with storing events?
Looks like the “zm13_data” share is not set fully for storing events. I don’t want to run into troubles with space or so…

V1.29 created a folder “/data/events/” that contained all recordings.

Regarding your question - test ZM without a camara - I’m not sure if there is a way.


Hi, sorry for reaching out again to you regarding the event storage with the new ZM v1.30 Rock-ons as described above.
Do you think there could be a bug, that the recorded events are not linked and stored correct to the newly set up “zm13_data” share as it was with the previous v1.29?

Thank again for your support

That could be the issue. I am sorry I haven’t run through this recently but hope to this week. I’m hoping it’s simple to fix. 1.30 had been out for a while and I did not see many docker containers that worked (lots for 1.29). again, hope to get this fixed soon.

1 Like

Thanks! I think it is not a difficult bug (if it is at all), but we should know where the events are stored and if there is enough space for them…but fixing it would be nice :smiley:

I think they are in /var/cache/zoneminder/events we can add that as another location rather easily. Does that solve the issue? How is that different than 1.29?

1 Like

Thanks for getting back to me.
With ZM v1.29 all events have been stored to a specific share “zm_data” that was required to be set up during installation, which makes sense to me. I would prefer to change this for v1.30 (like in v1.29) if possible…a dedicated share (and storage size) for ZM.

Do you see any chance to update this within the rock-ons docker image? or which config file should I change on my end to correct it?

I’m just not understanding perhaps. In the 1.29 (older one) there is this section for volumes, it’s the same in the new one. Are you saying you see a folder in the config directory that is saving this information or you want a third directory (config, mysql and data).

            "volumes": {
                "/config": {
                    "description": "Choose a Share for the data and configuration data. (you can add seperate shares for events later by attaching a volume to /config/data/events)",
                    "label": "Config Storage",
                    "min_size": "1073741824"
                "/config/mysql": {
                    "description": "Choose a Share for the database.",
                    "label": "MySQL Storage",
                    "min_size": "1073741824"