Rockstor 4.0.4 install on VM trouble getting connected [SOLVED]

Further to:

Hi, I should be doing other things, but I’ve tried the installer in both VirtualBox and Virt-Manager,
and I can’t connect to the Web-ui on the address reported ( I can’t ping into the VM, either… both time out.

ps shows nginx and gunicorn are running.

I can ping out, both to machines on my lan, and to the intenet, and zypper refresh connects to repos on both.

I’ve tried changing the NIC from virtio to e1000e, to no avail.

Any ideas?
I had an easier time with 3.9.2, but that was on my old PC… I’m suspecting my VM support rather than the install itself. I might try the old PC next.

Cheers, H.

Well, I got there in the end. VM troubles. I managed to get it to install on the old PC, and on the new, I had to run virt-manager as root, which is weird.

But the upshot is both instances are running fine,
and my troubles were nothing to do with Rockstor :smiley:


My VM troubles could also explain the vagrant connection timeout too

@HarryHUK Hello again.

Yes me too. if you can ping out from the VM’s and zypper is happy then all looks good. It’s very likely that you have a NAT arrangement in you host machine, the machine that is running the VM’s. That is usual at least with KVM/Virt-Manager. But I had thought that VirtualBox defaulted to a bridge arrangement which would allow other network machines to get access. But in the NAT arrangement only the host machine can access the Web-UI as only it has routing info to get to it’s own VMs.

Let us know how it goes.

1 Like

My experience of Virtualbox is that it defaults to NAT for new VM creation. And nearly every time I forget to change it to Bridge. Ahem :slight_smile:


@GeoffA Thanks for the correction. I’ve barely used Virtual box as it goes so probably spoke out of turn.

Thanks for covering/correcting my back/mistakes.


I do/did have NAT enabled, (on both VMM and VirtualBox) but I was only trying to ping in from the host machine, so it’s still a bit odd. I hadn’t tried to access a VM from another machine in the network since I first tried out rockstor and wanted to see if my sonos could play music stored on it. Now I know why that didn’t work, thanks :slight_smile: