Rockstor-bootstrap.service is missing

While having Problems with some Rock-Ons, I tried to delete the Rock-On Share via ssh. After a while I got this solved via the Web-UI. but after a restart of the Server, the Web-UI did not open anymore and if I try to start the bootstrap service, I get the Error:
Failed to start rockstor-bootstrap.service: Unit rockstor-bootstrap.service not found.

Is there a way to restore this? Or do I have to do a new install of Rockstor?

@Felix welcome to the Rockstor community. Which version of Rockstor are you working with where you are running into that problem?

Note: In case a restore is required, make sure you take a configuration backup (if you have configured other things on Rockstor) so you can reimport your settings quickly.


I’m using

I also just found the issue. I have accidentally deleted the nginx folder in /opt/rockstor.
After reinstalling the rockstor package it is running again.

After a few hours, somehow it suddenly worked again.
Topic solved
I still have an issue that may is corresponding with that. No Rock-On can be opened in the browser (the web-ui). I am really new to the system and don’t know if the two things have to do with each other

1 Like

@Felix, Hello there, and glad you got over the first hurdle you encountered.

If you are sure to select the exact same configuration, i.e. shares ports etc, there is no harm in re-installing a Rock-on: note that you may have to uninstall it first. Do be sure that you have followed the guidelines here:

regarding dedicated shares etc. And of course the Rock-ons-root share.

Hope that helps.

1 Like