Rockstor on VMWare with multiple disks

Hey, 


The software is only detecting one disk - sdc.

If I do fdisk -l on the centos box it recognises and sees all disk, they all appear the same as sdc but for some reason the system only sees the one. 

I have done a rescan and rebooted the box etc… 

Any ideas? 

Welcome to Rockstor community. I am happy to help, but need more information.

Are you saying that all of your disks show up with the same name(sdc) in the output of fdisk -l?

Can you show us the output of fdisk -l and even better, the following command:

/usr/bin/lsblk -P -o NAME,MODEL,SERIAL,SIZE,TRAN,VENDOR,HCTL,TYPE,FSTYPE,LABEL,UUID

Hey, 


Sorry for my lack of information. to clarify fdisk -l is showing the following: 

Disk /dev/sda: 10.7 GB, 10737418240 bytes, 20971520 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x000b9b40

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 1026047 512000 83 Linux
/dev/sda2 1026048 3123199 1048576 82 Linux swap / Solaris
/dev/sda3 3123200 20971519 8924160 83 Linux

Disk /dev/sdb: 1099.5 GB, 1099511627776 bytes, 2147483648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sdc: 1099.5 GB, 1099511627776 bytes, 2147483648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes



The command you asked me to run shows: 

NAME=“sda” MODEL=“Virtual disk " SERIAL=”" SIZE=“10G” TRAN=“spi” VENDOR=“VMware " HCTL=“2:0:0:0” TYPE=“disk” FSTYPE=”" LABEL="" UUID="“
NAME=“sda1” MODEL=”" SERIAL="" SIZE=“500M” TRAN="" VENDOR="" HCTL="" TYPE=“part” FSTYPE=“ext4” LABEL="" UUID=“086d6a03-8b54-4ceb-b5dc-e9569063bd83"
NAME=“sda2” MODEL=”" SERIAL="" SIZE=“1G” TRAN="" VENDOR="" HCTL="" TYPE=“part” FSTYPE=“swap” LABEL="" UUID=“1a0957a1-e122-40a8-a851-32382b0e0d26"
NAME=“sda3” MODEL=”" SERIAL="" SIZE=“8.5G” TRAN="" VENDOR="" HCTL="" TYPE=“part” FSTYPE=“btrfs” LABEL=“rockstor_rockstor” UUID=“ece5ed17-0da7-44b9-a8ca-1666da5b4555"
NAME=“sdb” MODEL=“Virtual disk " SERIAL=”” SIZE=“1T” TRAN=“spi” VENDOR=“VMware " HCTL=“2:0:1:0” TYPE=“disk” FSTYPE=”" LABEL="" UUID="“
NAME=“sdc” MODEL=“Virtual disk " SERIAL=”” SIZE=“1T” TRAN=“spi” VENDOR=“VMware " HCTL=“2:0:2:0” TYPE=“disk” FSTYPE=”" LABEL="" UUID="“
NAME=“sr0” MODEL=“VMware IDE CDR10” SERIAL=“10000000000000000001” SIZE=“1024M” TRAN=“ata” VENDOR=“NECVMWar” HCTL=“1:0:0:0” TYPE=“rom” FSTYPE=”" LABEL="" UUID=""


The only disk that is showing up on the web console for RockStor is sdc… 


Thank you so much for that information. One clear problem I see is that there are no serial numbers for drives while the current code expects a unique one for each drive. If they were physical drives or from virtualbox, you would not have this problem. But this is legit usecase to support, perhaps a lot of users like to use Rockstor on VMWare.

We’ll fix this bug in the next release update (sometime within a week). Here’s the issue for this bug:

https://github.com/rockstor/rockstor-core/issues/545

I’ll update this discussion once the issue is resolved, but feel free to interact on github also.

Sorry that you are unable to use Rockstor until it’s fixed.

Thanks for the fast response. 


If the next release with this bug fix is going to be available within the next week that’s awesome… 

Thanks again 

Rob 

Hey, 


Just and FYI… I have a workaround for this. If you edit the VMX file of the RockStore VM and add the following line: 

disk.EnableUUID="true"

This adds a serial number to each drive and they all appear in the webinterface. 

Thanks :) 
3 Likes

Thanks for the workaround. It will be helpful to others. IMO, it’s actually the right solution and a must for seriously using Rockstor. When disk drives go bad, renamed and/or are replaced, serial numbers(unique and externally provided) are essential to properly restoring the state.

Rockstor can provide an internal UUID, but it would be bad design and doesn’t fully solve the problem, I think. What we’ll probably end up doing as a fix is (a) assign internal/fake serial numbers making all disks visible (b) provide a clear message to the user that they are internally given serial numbers and that it can cause problems.

Another user ran into this scenario, so I’ve edited the title appropriately to point other Rockstor+VMware users to this link easily.

We’ve updated the code to give a clear warning if disks don’t have uuid/serial numbers. But editing the vmx file as suggested by Robsi seems to be the preferred solution for this problem.

I ran into the same issue. Have you thought about creating a preconfigured VM of rockstor, with the fix implemented. I tried the fix, but it didn’t work for me.

We can potentially do that. Feel free to open a issue on github.


I am not a vmware user, but can you share more details about your vmware settings and how exactly is it not working? There are other vmware Rockstor users here and they could try to help you.

@MarshallCS there is a recently opened and closed github issue https://github.com/rockstor/rockstor-core/issues/666 where @suman referenced this thread. The original poster oliver68 had a similar problem of vmware drive serial numbers still not showing up in Rockstor; even after the disk.EnableUUID=“true” VMX file addition (thanks @Robsi) . In that case the contributor tracked their problem down to a bug in vsphere client (thanks oliver68). Their fix involved forcing a reload of their VMX file; it is worth anyone having a similar problem reviewing that thread where oliver68 explains in detail what they found.

Hiya,

I know it is a while ago since last reply, but I would like to contribute my installation story in short.
VMware ESXi 5.5, 2 disks, one for system 1 for data, after rebooting I had the messages about the disks UUID. Please leave that message there as it will remind the VMware users that they have forgotten to add the parameter to the VM. The only appropiate way to do so is when you create the VM and answer that you want to edit before starting or after the VM is created but still down. If you forget then the warning message will remind you :wink:

How? Select the VM when down, edit settings, TAB Options, General, click on the Configurations Parameters button, Click Add Row button, in First column: Disk.EnableUUID, second Column TRUE, ok, done.

Install the Open-vm-tools:
Rockstore uses epel repo so it is pretty easy to install: on your console login as root:

yum install open-vm-tools
service vmtoolsd start

Done, happy Rocking!

2 Likes

@TheRavenKing Welcome and thanks for detailing your install procedure. The Serial number / UUID check warning is rather crucial for how the disks are differentiated… I’m not familiar with ESXi so curious as to the purpose of open-vm-tools in the context of Rockstor? What do they help with and are they strictly necessary?

Thanks again for detailing this as it’s bound to help others doing the same.

@phillxnet Hi Philip,
Yes I would recommend to do so as it has many benefits: VMware Tools is a suite of utilities that enhances the performance of the virtual machine’s guest operating system and improves management of the virtual machine. For example: if for whatever reason the VM hangs you can shut it down or reboot in your vSphere client without being to much afraid things get damaged.

See VMware website.

Maybe good to note for those who are going to use it for NFS or other shares, make sure your VM is marked as first to start in the autostart feature of the ESXi server, make also sure there is enough delay before the other VMs start to make sure all shares are available before the other VMs start. This might avoid a lot of trouble.

You might want to find out how the resources assigned are doing, all will be available in your vSphere client, you can use Veeam One [free version] to get even more information.

The open-vm-tools are also less work then the official VMware tools, when there is an update for ESXi server or you update the kernel, you don’t have to re-install the open-vm-tools, they just work, the bug in VMware is still not solved and the cd keeps still mounted, not handy when you want to move the VM. I prefer the open-vm-tools. Wow, that was a lot of waffling on…

Hope this helps, happy Rocking.

@TheRavenKing Well that was more than I expected. All a little out of my area but some great pointers. I’m more of a kvm person myself, though only for rockstor testing really, and have had zero to do with ESXi except where we had the missing serial numbers affect kvm virtio drives similarly to ESXi as you detailed in you first post.
Cheers for info and link.

@phillxnet Your very welcome, any questions let me know and I am happy to look into it.

Anyone found an equivalent solution (add disk serial number) in XenServer? Many thanks.