Samba doesn’t REstart

Hi,
I have a problem with samba.
It don’t start on a reboot.
My versions are :

  • Kernel 4.12.4-1.el7.elrepo.x86_64
  • Rockstor 3.9.2-57

I read some topics like Samba doesn't start ; Samba service doesn't start automatically after reboot .
Theses are really similar but …
Some “log” :

[Admin-RS@hpg10 ~]$ systemctl status smb.service
● smb.service - Samba SMB Daemon
Loaded: loaded (/etc/systemd/system/smb.service; enabled; vendor preset: disabled)
Active: failed (Result: protocol) since dim. 2020-11-08 10:39:28 CET; 7min ago
Process: 3158 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=0/SUCCESS)
Main PID: 3158 (code=exited, status=0/SUCCESS)

[Admin-RS@hpg10 ~]$ journalctl -xn
Hint: You are currently not seeing messages from other users and the system.
Users in the ‘systemd-journal’ group can see all messages. Pass -q to
turn off this notice.
No journal files were opened due to insufficient permissions.

[Admin-RS@hpg10 ~]$ systemctl status smb -l
● smb.service - Samba SMB Daemon
Loaded: loaded (/etc/systemd/system/smb.service; enabled; vendor preset: disabled)
Active: failed (Result: protocol) since dim. 2020-11-08 10:39:28 CET; 18min ago
Process: 3158 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=0/SUCCESS)
Main PID: 3158 (code=exited, status=0/SUCCESS)

[Admin-RS@hpg10 ~]$ systemctl status rockstor-bootstrap -l
● rockstor-bootstrap.service - Rockstor bootstrapping tasks
Loaded: loaded (/etc/systemd/system/rockstor-bootstrap.service; enabled; vendor preset: disabled)
Active: active (exited) since dim. 2020-11-08 10:39:28 CET; 19min ago
Process: 2854 ExecStart=/opt/rockstor/bin/bootstrap (code=exited, status=0/SUCCESS)
Main PID: 2854 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/rockstor-bootstrap.service

And on reboot Samba service is OFF.
Capture%20d%E2%80%99%C3%A9cran%20de%202020-11-08%2011-13-45

I change the status from OFF to ON and share become enable on my “working station”.
The problem is back on reboot.

I got 2 time this windows :
Capture%20d%E2%80%99%C3%A9cran%20de%202020-11-08%2011-13-20
I check the link … Which I don’t understand what I have to do :anguished:

A detail … maybe…
I wrote reboot, this reboot is a power OFF then ON !

Could you give me advices ?
Freed

Hi @Freederic,

We’ve actually seen that one a short while ago while we were updating our Samba implementation to our new openSUSE base. I can’t remember exactly when that was, so the specifics as to whether or not the fixes were included in Rockstor-3.9.2-57. My current guess is, I would suspect you turned ON the Samba service before configuring it. I would thus be curious to know if you could try the following and see if it works for you:

  1. Go to System > Services, and click on the little wrench icon next to the “Samba” service name.
  2. Configure it as you desire and click submit.
  3. Then, try to toggle the service ON from this page. It should hopefully work this time.

For details, I would point you towards the following discussion thread where this shortcoming was reported:

… and @phillxnet’s post providing more information:

Regarding the error in the screenshot you shared, it is unfortunately unrelated. It actually relates to the javascript part of our code and is purely cosmetic (still annoying, though). We have big changes and improvements planned on that part once we have tackled bigger and more pressing improvements, so it will improve in time.

I hope this will help you move forward,

PS: contrairement a ce que tu mentionnes dans ton autre post, je ne vois pas de probleme avec ton anglais, mais n’hesite pas a me contacter en francais si tu preferes ; je ne pratique plus trop ces derniers temps, mais c’est ma langue natale :wink: . Bien sur, l’anglais est prefere car plus de monde peut le comprendre, mais ca n’empeche pas d’utiliser quelque chose d’autre si necessaire.

2 Likes