Samba error when attempt to activate

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Cannot open Samba due to system error

Detailed step by step instructions to reproduce the problem

Opened Samba, set at condition off, turned to condition on and error message appeared.

Web-UI screenshot

[Drag and drop the image here]

Error Traceback provided on the Web-UI


[paste here]
Traceback (most recent call last):
File “/opt/rockstor/src/rockstor/smart_manager/views/”, line 113, in post
systemctl(‘nmb’, command)
File “/opt/rockstor/src/rockstor/system/”, line 64, in systemctl
return run_command([SYSTEMCTL_BIN, switch, service_name])
File “/opt/rockstor/src/rockstor/system/”, line 115, in run_command
raise CommandException(cmd, out, err, rc)
CommandException: Error running a command. cmd = /usr/bin/systemctl start nmb. rc = 1. stdout = [‘’]. stderr = [‘Job for nmb.service failed because the control process exited with error code. See “systemctl status nmb.service” and “journalctl -xe” for details.’, ‘’]

Hi @Gerard_Crutch,

It appears that nmbd has failed to start.
Could you please open a terminal and provide output for the following commands

systemctl status nmb.service
journalctl -u nmbd


EDIT: I have since found other threads with the same issue and have managed to fix the issue. Sorry I didn’t see them first! You can now disregard my post and would recommend following the other threads if you are having the same issue.

Original post:

Hello, I’m having the exact same problem as the original post.
I have been running Rockstor for almost a year on a two bay Shuttle and it has been running fine, but I got a four bay enclosure from my brother last week so I could use more drives and now I am having the same issue when I try and start samba.
I installed Rockstor 3.9.1 fresh from the ISO and it hasn’t worked at all since the install. I’ve tried updating with no luck, and even turning on testing updates to see if any of them would help, and still no luck. Same issue every time.

Running systemctl status nmb.service gets me:

● nmb.service - Samba NMB Daemon
   Loaded: loaded (/usr/lib/systemd/system/nmb.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2017-10-17 23:00:41 PDT; 57s ago
  Process: 6727 ExecStart=/usr/sbin/nmbd $NMBDOPTIONS (code=exited, status=1/FAILURE)
 Main PID: 6727 (code=exited, status=1/FAILURE)

Oct 17 23:00:41 pedra systemd[1]: Starting Samba NMB Daemon...
Oct 17 23:00:41 pedra nmbd[6727]: /usr/sbin/nmbd: /usr/lib64/samba/ version `SAMBA_4.4.4' not found (required by /lib64/
Oct 17 23:00:41 pedra nmbd[6727]: /usr/sbin/nmbd: /usr/lib64/samba/ version `SAMBA_4.4.4' not found (required by /lib64/
Oct 17 23:00:41 pedra systemd[1]: nmb.service: main process exited, code=exited, status=1/FAILURE
Oct 17 23:00:41 pedra systemd[1]: Failed to start Samba NMB Daemon.
Oct 17 23:00:41 pedra systemd[1]: Unit nmb.service entered failed state.
Oct 17 23:00:41 pedra systemd[1]: nmb.service failed.

And running journalctl -u nmbd just says -- No entries --

@rtharston Welcome to the Rockstor community and thanks for the update / edit here.

I’ll just link to your referenced post to ease following/finding this in the future.

Glad you got it sorted in the end and well done for persevering.