[Solved ]Failed to mount sysroot - Fresh install latest Rockstor iso 3.8.15

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Hi guys, went to check my NAS today and it was offline, I had to do a graceful reboot and it never came back up. I got this error open_ctree failed, had to to type “journalctl” to view the logs

Detailed step by step instructions to reproduce the problem

[I didn’t do anything the problem just occurred :slight_smile: ]

This is the logs I have got on my NAS

Ok, I ended up reinstalling Rockstor on different USB drive, booted up and updated to the latest kernel “Linux: 4.8.7-1.el7.elrepo.x86_64” and Rockstor 3.8.15-14. Activated the testing updates, but didn’t get the latest update the 3.8.16!!, any ideas what is going on?

Also after importing the pool I wasn’t able add samba shares :frowning:

Here is some logs

Houston, we’ve had a problem.

relation “storageadmin_pincard” does not exist LINE 1: SELECT COUNT(*) AS “__count” FROM “storageadmin_pincard” WHE… ^

        Traceback (most recent call last):

File “/opt/rockstor/src/rockstor/rest_framework_custom/generic_view.py”, line 40, in _handle_exception
File “/opt/rockstor/src/rockstor/storageadmin/views/user.py”, line 105, in get_queryset
return combined_users()
File “/opt/rockstor/src/rockstor/storageadmin/views/ug_helpers.py”, line 69, in combined_users
temp_uo.pincard_allowed, temp_uo.has_pincard = pincard_states(temp_uo)
File “/opt/rockstor/src/rockstor/system/pinmanager.py”, line 136, in pincard_states
pincard_present = has_pincard(user)
File “/opt/rockstor/src/rockstor/system/pinmanager.py”, line 121, in has_pincard
pins = Pincard.objects.filter(user=int(uid_field)).count()
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/query.py”, line 318, in count
return self.query.get_count(using=self.db)
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/sql/query.py”, line 466, in get_count
number = obj.get_aggregation(using, [’__count’])[’__count’]
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/sql/query.py”, line 447, in get_aggregation
result = compiler.execute_sql(SINGLE)
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/models/sql/compiler.py”, line 840, in execute_sql
cursor.execute(sql, params)
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/backends/utils.py”, line 64, in execute
return self.cursor.execute(sql, params)
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/utils.py”, line 98, in exit
six.reraise(dj_exc_type, dj_exc_value, traceback)
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/db/backends/utils.py”, line 64, in execute
return self.cursor.execute(sql, params)
ProgrammingError: relation “storageadmin_pincard” does not exist
LINE 1: SELECT COUNT(*) AS “__count” FROM “storageadmin_pincard” WHE…

@Mahmoud87 Hello again; well done on getting your Rock-on in to rockon-repo by the way, it normally does take quite that long but it seems like you submitted it right at the beginning of a quite time.

Anyway on to your questions:

That’s an easy one as it’s not out yet. The latest Rockstor release in testing channel updates is 3.8.15-14 which is the version you indicate getting so no problem on that one.

The problem you indicate re the database missing an entry looks like the one reported in the following thread:
Boot and Upgrade Error. 3.8.12 > - #2 by suman Although in that case it was the missing networkdevice entry.
There as you see @suman states that due to the recent fairly large db related changes there are issues with updating from earlier releases. You didn’t state what version of the Rockstor iso you used to re-install with but it seems like the way to go now is to use the latest 3.8.15 iso for any re-installs.

The samba shares issue is also most likely due to the database being out of kilter due to this recent change re upgrades. Bit of a pain but this needed to be done sooner rather than later it seems as I suspect we here heading to greater problems as the db update method was put off. Quite a few regressions (one of which you have reported yourself of course) but we should all be in a better position once we are over the hill as it were.

Hope that helps.

Oh and sometime (often) a reboot is required after a Rockstor update. Just a though but I’m assuming you tired this.

@Mahmoud87 Please don’t get this a wrong way (at I think documentation should be changed to discourage this) but installing any operating system to USB for constant use is VERY UNSAFE.

Let’s concentrate on few characteristics of USB drives:

  • are meant to be cheap, there fore those are not designed with reliability in mind
  • are not meant to have any specific “up time” so those drives tend to overheat / self rest / plain switch of / have lurking bugs that only running long exposes
  • are not meant with data integrity in mind ! Those re designed to put pictures of cats on it - take it some where and that’s it … using those for having a system that relies on integrity of it’s data will result in problems !
  • have issues with syncing data to “long term storage” - let’s say that you system performed some amount of updates (a lot of writes and changes in files) and performed a reboot -> your usb drive may opose a reboot because it’s still trying to write data down … but operating system goes “oh well, you should have a journal like anybody else does, so live long and suck it”

I know that people will start screaming about the costs, but you can get a sandisk 32GB SSD for 20$ … maybe not a speed demon but very reliable and way better than spinning rust.

Thanks @phillxnet I am so pumped to see it in the official rockon registry, really many thanks to you in the first place you helped alot.

I have looked in this post and totally ignored the fact that my iso was the 3.8.14, but what makes me wonder I got every single update till the last one that upgraded the kernel then Rockstor was down and got the error “BTRFS: open_ctree failed”. I still has this USB and tried to boot in it again but same problem still there. I don’t know if it’s something worth looking into or just enjoy the new setup :smiley: .

You were right once installed the new iso 3.8.15 and updated to 3.8.15-14 I was able to add samba shares, but I keep getting this error messages
I just hit ok about 3 times and it disappear but every now and then it pops up, tried to go to the url it displayed but to be honest didn’t get much :slight_smile: .

I couldn’t agree more with ya mate, this is why am gonna get a normal 120gb hdd or an SSD cause I can really tell how slow it is off the USB :smiley: ,beside all risks you stated above. Do you guys think it’s gonna make a big difference running Rockstor on HDD compared to SSD? I know it’s going to be faster but is it a noticeable speed difference?

1 Like

Honestly I would say that it will make no difference because once rockstor is running all operating system stuff is already in ram so there is no need to load anything from disk. Also please remember that it’s a good practice to leave system filesystem alone, not to put any shares there (like rockon share) … it’s not smart to do it and a lot of people pay the price for it (or they will but now they don’t know about it yet.

Of course when you need to make any operating system related stuff like big update or

Why I’m suggesting a sandisk ssd is that sandisk is a well established company that produces moderately reliable equipment and their 32GB SSD for around 20$ is cheaper than any brand new HDD you can buy with same reliability level.

Thanks mate for the recommendation, definitely $20 is so cheap for an SSD. [quote=“Tomasz_Kusmierz, post:6, topic:2453”]
Also please remember that it’s a good practice to leave system filesystem alone, not to put any shares there (like rockon share) … it’s not smart to do it and a lot of people pay the price for it (or they will but now they don’t know about it yet.

Yeah man I have separate drive for the file system since day 1 :slight_smile: can’t afford losing everything with the system when it goes down.

I’m honestly starting to get more and more confused … now I can’t mount root fs on one server because btrfs decided to corrupt it’s checksum tree (similar to yours) … other (as you seen) spontaneously forgot it’s settings …

I will mark this as solved. I did fresh installation using the 3.8.15 iso, all was fixed. The “Data Tables” wasn’t the original problem, but we can follow the “Data Tables” issue in this post, please @phillxnet when you get sometime can you have a look at this post :slight_smile: .


Funny enough, I’ve did a fresh install in vmware to test my theory about compressed pool not being able to mount … like a magic I’ve got that:

And this is while I’m in users and can’t create any pincard :confused: installing fresh from .14 iso → finish install → upgrade to -14 → import pool → make it compressed → go to samba config (to be able to quickly upload some data) → TADA a nice error …

(update this was a .14 iso install, my bad)

Third reporting this, it seems Django initial migration partially fails


@Flyer I seriously think that something more went wrong than just django …

This is a straight .14 iso install … note the lack of user in admin table …

so I think this is where problem started to creep in on people …

Maybe I’m wrong, move to page 2,3,4, etc : on 3.8.14-0 admin user got listed on alphabetical order by all users (ex. your rockstor admin is “Test”, you’ll se it on page with T users), that was fixed later

Pls confirm this


my admin user was tom … no such user … even thou I could log on normally …