[Solved] I am trying to figure out the what and why of several things

HELP PLZ!

  1. What is this:
Jan 10 07:25:24 RockNAS kernel: perf: interrupt took too long (2506 > 2500), lowering kernel.perf_event_max_sample_rate to 79750
Jan 10 07:57:46 RockNAS kernel: perf: interrupt took too long (3155 > 3132), lowering kernel.perf_event_max_sample_rate to 63250
Jan 10 08:52:41 RockNAS kernel: perf: interrupt took too long (3976 > 3943), lowering kernel.perf_event_max_sample_rate to 50250
Jan 10 12:57:00 RockNAS kernel: perf: interrupt took too long (5005 > 4970), lowering kernel.perf_event_max_sample_rate to 39750
  1. Can I turn off most/all logging for test purposes?

  2. So far, Write performance on ANY (2,3, or 4) Raid-0 SSD setup is LESS than that of a single SSD! I am looking at the SAS card I am using etc. to nail this down. This problem happens when I test transfer 16x 9GB video files from a client to Rockstor via 10Gbs LAN.

Sometime after the 32GB ECC memory shows full, Rockstor shows the last installed SSD (no matter how many) goes 100% “Writing” for extended periods of time, and writes to the other SSD’s blip now and then.

If I pause the transfer and wait MINUTES, the same behavior happens again. Deleting the files and starting over gives the same result.

READ/WRITE performance of the 6 HDD Raid-10 is as anticipated and fine! Also, READ performance of the 4 SSD Raid-10 is fine. It’s only the SSD Write performance that suffers.

  1. Anyone know where the smb.conf is located?

  2. Anyone know of any system tweaks to modify SSD Write behavior?

  3. There are 6 4TB HDDS (all the same) in a raid-10 setup and when I am doing the below large 3.9TB transfer to another setup, Rockstor seems to be reading from ALL of them at the same time. Is this normal or am I seeing rockstor use them in a sort of raid zero way for multiple files?


Any help with this is much appreciated.

Note: Testing being done on migrated hardware in new box that can accommodate the number of HDD’s I ended up needing. Still have a lot more to do to clean it up and install different (better) fans etc. Upgraded the CPU to E3-1245V2 so I could eliminate the cheapo graphics card.

Still running 4.0.9-0 with all updates and works well enough so far… a LOT (tons!) better than older version.

Cheers Everyone and Happy New Year!

:sunglasses:

(Open Images in new tab to see full size)

[3.9TB xfer to backup machine 3HDD Raid-0 setup]

NAS-to-Win-3HDD-Raid-Backup

Nas-to-Win-3HDD-BU

1 Like

ad 4) should be located here: /etc/samba/smb.conf

1 Like