(Solved) PuTTY stopped working after 5.0.9 then 5.0.10 installed (operator glitch probably...)

Okay, weird woopsy here…

Upgraded both NAS setups to 5.0.10 without a hitch, then today tried to PuTTY into them on port 22 and using either root or admin login, it won’t connect.


Both setups perform perfectly and the Rockstor web GUI works fine on both.


(I’m old and ignorant I know…)


interesting. I upgraded from 4.x to 5.0.9-0 to 5.0.10-0 and it continued to work for me (tried with the root user).

I assume PuTTY didn’t give you a warning message about changed certificates and whether you want to trust the new one?

Can you use the WebUI system Shell access and successfully login (as the admin user, not root)?

If so, then I assume the sshd server for the remote access is running …

systemctl status sshd

1 Like

PuTTY gave me a warning on one setup but not the other. Both setups I did a clean install on… upgraded both from 5.0.9 at same time.

BOTH setups run the Web GUI with admin logon fine.

I’m thinking some weird something might have happened on my end… maybe need to clear something locally?



Putty works on one setup after reboot now… but still does not work on other after reboot…


YIKES! Figured it out!

When I installed 5.0.9 and then updated to 5.0.10 on the setup, I also changed the password so it would match the new password of my .108 setup.

So, on the .104 setup, it uses the NEW password on the Web GUI, but weirdly uses the OLD password using PuTTY!!!

GO figure… I will try a new reinstall of 5.0.9 then upgrade it unless there is a way to fix the weird root password thing…


PS: Both setups used to have different PW’s, but I wanted them the same this time around… is it stored somewhere on the disk images or something?

1 Like

I’m guessing I made a booboo because I reinstalled 5.0.9 then upgraded to 5.0.10 and PuTTY works now…

Soory for any hoopla…