[SOLVED] Samba does not start

        Traceback (most recent call last):

File “/opt/rockstor/src/rockstor/smart_manager/views/samba_service.py”, line 109, in post
systemctl(‘nmb’, command)
File “/opt/rockstor/src/rockstor/system/services.py”, line 64, in systemctl
return run_command([SYSTEMCTL_BIN, switch, service_name])
File “/opt/rockstor/src/rockstor/system/osi.py”, line 109, in run_command
raise CommandException(cmd, out, err, rc)
CommandException: Error running a command. cmd = [’/usr/bin/systemctl’, ‘start’, ‘nmb’]. rc = 1. stdout = [’’]. stderr = [’’]

this is what the UI trows at me, any clues? i am at version 3.8.16-8

Hi @agamennon and welcome to Rockstor :sparkles:

Can you please check this forum thread?

Recently other users experienced same isssue


Selinux is disabled. (as per the config) should i turn it on?

Good morning @agamennon ,
we don’t need* SELinux to solve this, let’s check Rockstor logs:

Try to turn on Samba service via Rockstor WebUI then collect this logs

journalctl -xe nmbd
systemctl status -l nmbd
tail -n 100 /opt/rockstor/var/log/rockstor
tail -n 100 /var/log/samba/log.nmbd
tail -n 100 /var/log/samba/log.smbd

(*) We don’t need SELinux: Rockstor usually with SELinux disabled, but you can search our forum and find how to turn it on with permissive mode


Before i took any more of your time i tried reinstalling SAMBA and libwbclient, rebooted and now it works.

yum reinstall samba
yum reinstall libwbclient


1 Like

We all are here to help, so don’t worry about that :wink:

Marking this solved


thanks mate was almost going to trash Rockstor for Freenas .


Don’t do that, we’re much cooler.
Oh, and features and stuff. Yeah.

1 Like