[Solved] Share(LNP-Multimedia) cannot be deleted as it is shared via Samba. Unshare and try again

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Unable to delete a share. I created a share. I copied some files into it. Then I moved all files to another share and I try to delete the first share but I got an error.

Detailed step by step instructions to reproduce the problem

  1. Create a share
  2. Copy some files into the share
  3. Move the share into another share
  4. Try to delete the share

Got the error

Web-UI screenshot

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/eggs/gunicorn-0.16.1-py2.7.egg/gunicorn/workers/sync.py", line 34, in run client, addr = self.socket.accept() File "/usr/lib64/python2.7/socket.py", line 202, in accept sock, addr = self._sock.accept() error: [Errno 11] Resource temporarily unavailable

@ideawebi Welcome to the Rockstor community.

Your initial post in this thread appears to have been unlisted yet it has important context, how you arrived at this difficulty: ie “3. Move the share into another share”. Consider correcting the visibility of this first share as it looks like a mistake was made in unsharing that post or something. As is, it is not I think visible to those browsing the forum.

Hope that helps and be aware that Rockstor does not a share within a share, which you may have inadvertently created with that move. You could try moving just the share’s (btrfs subvolume content) directory contents rather than the directory (subvolume) itself. If one moves a subvol’s directory you are moving the subvol itself, you probably wanted just to move it’s contents.

Just a though and hope that helps.

Hi Philip,

You’re right, I wrote wrong:

I move all the content files from the first share to another one…

However, I just solved my problem, I understand that I couldn’t delete a share if I don’t delete before all the services attached on it. ( I hope I use the correct terms )

My problem was initially that I created 2 shares using all the space available on my hdds, then I decided to create another share but the resize didn’t work ( Now I think for the same problem: before to resize or delete a share I must delete all the services attached on the share).

You can mark my issue as solved. Thank you for your fast and kindly reply!



Also note that Rockstor version 3.9.0 (directly after latest iso install) is now pretty old. You could consider subscribing to either of the update channels as you would then get quit a few fixes / updates. With the stable channel now being quite a way ahead of the testing (we have reversed the update frequency between them at least more recently).

Well done on sorting out your issue.

Hi Philip,

I’m having a lot of problems using rockstor, I’m not a sysAdmin, but not newbie linux user.

Can I ask you some info?

Is it normal that I can’t use any command in ssh? (ls, mkdir, su, ect…) do not work.

I have no access to my WebUI, there are some errors, the admin’s pw is not accepted, and using another user I receive some errors…

Are those my errors about the release is not the latest one?

My release is 3.9.1-0, you said that it is pretty old. Are all the update channel’s to be paid?


This sounds like you are not using the root user. In which case that user can end up in a chroot environment. We have ssh setup that way ‘from memory’.

Yes only the admin use can login or other users who have been crated that way from within the Web-UI.

3.9.1-0 was pretty functional but yes many fixes / improvements were made in the latest testing 3.9.1-16 (which was also released as stable version) and there have been many more fixes / improvements since then that have been released on the stable channel which is now up to 3.9.2-40.

The stable channel subscription is to help Rockstor achieve sustainability, hence the move to serving it more regularly than the free to subscribe testing channel, at least of late. See my following post on this:

Essentially we trying to use the convenience of an rpm release as a value add for helping to support the project via a stable subscription. It turned out that releasing regular testing channel updates, with only occasional (and actually quite infrequent) stable channel updates wan’t serving all parties as well as we had hoped. We currently seem to have a fairly healthy engagement with both channels but yes there is always more that can be done but we are trying to build thing as good as we can and that takes sustained effort which in turn requires a sustainable arrangement. The stable channel update subscription forms part of that sustainable model. But remember we are GPL licenced (rockstor-core) open source so the very latest code is always available in the GitHub repos. And our Developer docs explains how to build a Rockstor instance but there are obviously compromises taking that route.

You don’t mention if you have tried a reboot, we did have a bug, and still do but less so recently, where if a brower was left open on the Rockstor Web-UI it would become unresponsive. Easiest, now you are more familiar with Rockstor, is to take a look at the Reinstalling Rockstor and once you have the 3.9.1-0 in pick an update channel and apply them. There are literally tons of upstream (CentOS currently) and Rockstor updates so give it quite a bit of time to get them all down and installed. The Web-UI will disapear during these as they take ages to apply. But once they are all in you will be in a much better position that 3.9.1-0 with no updates left you in.

Let us know how you get on. And remember that if you do have any data on your data disks, assuming you put no data on the system disk, then you can always import the pools / shares you created into the new install. But if those pools / shares are your only copy then take care during the re-install and best really to disconnect your data drives until you are fully up and running and fully updated.

Hope that helps and in case you are interested in tracking down your current issue your system logs:


and Rockstor’s own logs and specifically:


should be of help. Otherwise there is very info here to help you with. Also remember that starting a fresh thread for each issue you encounter is probably best for a more focused discussion on each is then easier. But assisting with 3.9.1-0 is not something many are likely to put time into given it’s age and the many updates that are now available in both channels. Plus the massive number of upstream updates that have come out since then also.