[Solved]Somewhere in trying different backup methods,this happened

I have two Rockstor appliances up and running, one is going to be a backup to the main NAS appliance. I’ve been testing various methods to backup, replication, RockOn stuff etc.

So far, Replication works, but I don’t like the way it stores the backup as a snapshot. I would rather just a simple Share or Pool copy, clean and neat.

[ I’m trying to avoid reinstalling Rockstor (again!) ]

Here is my problem now. Somewhere along the line, something stored some weird /nobody directory in /mnt3! It’s taking up a ton of space and I can’t delete it. No snapshots show up anywhere in the system I can find because I deleted them all.

Any ideas on how it got there?

THANKS in advance!

:sunglasses:

@Tex1954 Hello again.
Re:

After 5 replication events you will end up with a regular share with 3 snapshots on each end. The btrfs send receive mechanism requires a read only snapshot be used as the source and we, in turn, turn this into a regular share in-time at the receiving end. But each has 3 snapshots once it’s settled down. Not everyone cup of tea agreed. I’ll get to doing proper docs for this hopefully in the not too distant future. We have a long standing doc issue open on this front.

And of course it’s only a share. Entire pool copy is not it’s bag.

Directories are created by Rockstor in /mnt2 not /mnt3. And these are then used as mount points only. There should be no space used by these. And if space was used by them it would be taken from the ROOT/system pool. Where is the space being occupied. That would be a start in tracking down what/where this is.

Also take a look at:

btrfs fi usage /mnt-point

Hope that helps.

1 Like

I think it is from one of my test backup rockons… like Duplicata or something…

I tried the BTRFS command on mnt2 & mnt3 and got this:

btrfs1 btrfs2

Here is what it looks like:

btrfs3

I’m just going to reinstall as before (how many times? LOL) and redo the setup; takes less time than trying to figure out what I did wrong.

Thanks for the help!

:sunglasses:

3 Likes

Hi @Tex1954,

I too am unfortunately very short on time, but the /mnt3 point is created, from memory, when one uses the SFTP service. Would you have configured and activated an SFTP export, by any chance?

2 Likes

Actually, I did try that also at some point and didn’t like it for some reason.

:sunglasses:

1 Like