[Solved] Unable to update plex

Until now the update of my Plex rock-on by stop/start the docker on the Web UI always worked like a charm.

But today I receive this message in the log file:
Mar 19 18:16:13 nas journal: https://downloads.plex.tv/plex-media-server/
Mar 19 18:16:13 nas journal: 2019-03-19 18:16:13 ERROR 404: Not Found.

Upgrade attempt failed, this could be because either #
Mar 19 18:16:13 nas journal: # plex update site is down, local network issues, or #
Mar 19 18:16:13 nas journal: # you were trying to get a version that simply doesn’t #
Mar 19 18:16:13 nas journal: exist, check over the VERSION variable thoroughly & #
Mar 19 18:16:13 nas journal: correct it or try again later. #
Mar 19 18:16:13 nas journal: ###################################

I can download the file manually, so it does exist and the site is not down. Something ist blocking the NAS, i don’t know. I’m running a central ad blocker, which I disabled, but still no luck. Is there a way to workaround this problem?

I’m not a Plex user myself, but my initial thought was related to a recent notice of a problem upon Plex update by @Hooverdan:

Could this be what you experience?

Thank your for your response.
No, but I’m not sure. I found th following issue:

In my log file docker attempted to upgrade by the following line:


This file indeed cannot be find on plex (Error 404).
But if you use the download provided by the plex UI it says:


How can I change this URL?

It looks like a parameter set in the docker container image itself, so my first guess would be to uninstall / re-install the Plex rockon, which should thus pull the newest image that hopefully corrects this download link.
As I mentioned above, I’m not a Plex user myself so I’m unfamiliar with how this image is structured, so somebody else’s input may be preferred (@Hooverdan?). Note that if you choose to go the uninstall, re-install route, you shouldn’t loose any data if you reuse the same rockstor shares during install.

I’m sorry I can’t be of any more precise help, but hopefully someone else more familiar with Plex will know.

Thank you again.
I started reading @Hooverdan solution concerning the plex issue. It sounds like this is the problem I’m facing now.

Perhaps he can give me assistance, because I’m not very familiar with all that stuff.

your issue definitely sounds similar to mine. I can try to provide some assistance with what I’ve done. Where do you need clarification?

Youre help is very appreciated.
So, in short:
What are the main steps? And can I do this all by the rockstor UI?

Didn’t work so far:

  • stopped Plex (OK)
  • Uninstall Plex (OK)
  • docker image -f rm linuxserver/plex (had to force, was that wrong?)
  • install Plex
    failed to install in the previous attempt. Here’s how you can proceed.

Check logs in /opt/rockstor/var/log for clues.
Install again.
If the problem persists, post on the Forum or email support@rockstor.com

I don’t find any logs regarding the installation

docker images says now:
linuxserver/plex latest 2442c43f1f56 4 days ago 383MB

I tried this twice. At the the second try, docker images could be removed without -f.
Installation still failed

Log files says:

The container name "/plex-linuxserver.io" is already in use by container "5c473b7bd514b241d748045a3baede014811851170140b301aac173c19bbd961". You have to remove (or rename) that container to be able to reuse that name.', "See '/usr/bin/docker run --help'.", '']

How can I remove this container?

Ulrich - no the forceful removal of the image was ok. I think you also have to throw away the actual container - you already removed the image of which the container is created.
You should be able to remove the actual container with (you can use the force parameter, or try without first):

docker rm --f 5c473b7bd514b241d748045a3baede014811851170140b301aac173c19bbd961

If you just want to see the various existing containers you can use: docker ps -a -q

I don’t remember (brain like a sieve) but you might have to run the commands with sudo …

Doesn’t work:
Yesterday I accidentally deleted some snapshots. So when I try to remove the container it results in:

docker rm 5c473b7bd514
Error response from daemon: driver “btrfs” failed to remove root filesystem for 5c473b7bd514b241d748045a3baede014811851170140b301aac173c19bbd961: Failed to destroy btrfs snapshot /mnt2/rock-ons-root/btrfs/subvolumes for 80f8217c59a1b3e42f174504dbc57728e6532b21d9b280c302abf0be853d970b: invalid argument

I have a backup of all data (and snapshots) but I’m not able to restore these data correctly. How can I proceedd? Any help would be great. Thanks

As @phillxnet mentioned in a recent post (in a different thread, see below), this unfortunately is a problem that has already been identified and planned on being addressed as soon as possible:

In this situation, the current solution I know is to turn-off your Rock-on service, and then remove your rockons_root share (the share you used to configure to Rock-on service), before reconfiguring it as it was before. The main drawback is that you would have to re-install the rock-on(s) you had installed before, but no data should be lost if you re-use the same shares as before for each rock-on.

Sorry for the short answer; I’m unfortunately quite short on time :slightly_frowning_face:

Hope this helps,

Thanks @Flox a lot. This helped me out.

After recreating my “rock-ons-root” share as described, I was able to install Plex again without any data loss. The snapshots are created as well.

You saved my live :smiley: