[SOLVED] Unknown internal error doing a POST to /api/shares/[share]/aci after fresh install

Hi again.

Since my update to 3.8.16 failed the other day

I did a fresh install of rockstor 3.8.16-0 as suggested, and then an update through the UI to 3.8.16-1.

The install was painful, eventually having to disconnect all my storage drives to get it to work.

Importing the pool through the UI was uneventful and now, going back through everything, setting up users, and reconnecting shares in >storage>shares>access contol; I’m getting an error.

The shares have all come up with root being the owner and the group. I’m trying to change this.

Unknown internal error doing POST to /api/shares/[share]/acl

No further information is being given.

Ok, a couple of reboots and a pool scrub and that bit works.

My shares are showing usage of about double what they should be, and the usage is showing at 104% (on the graphs on the dashboard.

Now, when I try to access my shares over samba from a W10 PC I can’t get into one of them and the other I get a .ssh hidden folder, a .bash_logout hidden file, a .bash_profile hidden file and a .bashrc hidden file.

WTF is up with this. I’m spending more time trying to troubleshoot this damn thing than I am being able to use it.

Hah. Never mind. I forgot to setup the Samba Shares.

Hi @Maddan,
can we mark this as solved?

Yes, that would be great thankyou.

1 Like