Unsupported kernel (4.6.0-1.el7.elrepo.x86_64 after update to 3.8.16-0

Hi Guys.

I updated to 3.8.16 today. The update through the UI kept failing so I thought I’d be clever with

yum update rockstor-3.8.16’

That worked but now is showing unsupported kernel.

I’ve tried rebooting a few times and it continues to load 4.6.0-1…

I’ve tried

‘yum update’

but it’s returning
Transaction check error:
file /usr/lib64/libkadm5clnt_mit.so.8.0 from install of libkadm5-1.14.1-27.el7_3.x86_64 conflicts with file from package krb5-libs-1.13.2-12.el7_2.x86_64

I’ve had the same result after trying

‘yum clean packages’


‘yum upgrade’

I don’t want to keep randomly trying stuff because I am a little out of my depth here.

Any ideas?

I’ve now gone back to 3.8.15

‘yum downgrade rockstor-3.8.15’

Running ‘yum update’ returns the same transaction check error as before.

And it still won’t update through the GUI. IT does the countdown but then loads back to the ‘update is available’ page.

Hi @Maddan. I see on one of my test systems here that krb5-libs also has an update available(1.14.1-27). So not sure why it’s complaining about 1.13.2. Do you have any custom yum repos enabled?

update from the UI fails because it’s also running yum update behind the scenes and fails.

Have you considered just downloading 3.8.16 ISO, do a fresh install and import your data back? I know this is not ideal, but is a simpler option compared to troubleshooting and cleaning up yum if you are not a power Linux or CentOS user.

Thanks for the reply.

I don’t have any custom repos.

I did consider a fresh install, but wanted to see if it was repairable without going through that.

I also thought you guys might like to know about it.