Stuck when installing Rockstor 4

Trying to install Rockstor 4 on my NAS but it’s not working. Installation freezes after “fb0 switching to amdgpudrmfb from efi vga”. As shown on the picture. Tried failsafe mode but with no luck.!

My NAS is built on Gigabyte B450 Tomahawk Max II, AMD Ryzen 5 3600, 16 GB ram, 4 x 4TB Toshiba HDD, Intel 600 M2 256GB and a Geforce 1070 GPU. Maybe wrong hardware but this is what I got.

The strange thing is that I can install TrueNas 12 and Openmediavault 6 but not Rockstor which I prefer to use.

If someone could point to what I could do I would be grateful.

IMG_20220222_134827

@carltorn, that’s rather annoying I can imagine.
The Leap 15.2/15.3 are using kernel version 5.3.18 (likely with some backporting as @phillxnet has indicated before).
From what I ready on various forums, something like a 5.10+ kernel level might work with the Ryzen. Incidentally, I believe TrueNas 12 and OMV 6 are running on a 5.10 kernel, which could indicate that the Leap based Rockstor is not working at this time, unless you re-assemble with a newer kernel version.
Since you’re mixing AMD with a NVIDIA card, have you tried to install/boot without the nvidia card installed/connected? Again, my knowledge is very shallow in this area, but might be worth a try.
Finally, I did a couple of threads (not on the Rockstor forum) where the system is hanging after this message, but was still accessible via SSH. I assume, that this is not the case here?

I guess, finally, you could see whether a “vanilla” OpenSUSE install works (LEAP first, and then maybe try with Tumbleweed to get the latest released improvements and kernel level).

3 Likes

Or … you build your own Rockstor iso:

with the kernel backports enabled in the kiwi file (around line 387ff. enabling the Kernel stable backport and the btrfs-progs backport via filesystems repo before executing the installer recipe).

which follows the referenced how-to on a “running system”, but will do it right for install:
https://rockstor.com/docs/howtos/stable_kernel_backport.html

This should then give you a very recent kernel, which very well might support the Ryzen quirks that I have read about.

2 Likes

@Hooverdan thank you very much for your reply. I guess it’s the kernel version that messes up with the installation. Unfortunaly I don’t know how to build my own ISO, never done that before. Maybe I will give it a try. Btw I tried without the graphics card but then for some reason the onboard graphics didn’t work. Issues with Radeon graphics I guess. My monitor didn’t wake up :frowning:

@carltorn Hello there. Long time no see.
Re:

I’d second this one from @Hooverdan.

That may be down to a bios setting (it may be disabled) or you may have to try another monitor plug. I’ve seen some boards with multiple outputs that will only feed one without special request otherwise.

Yes that could be it. I.e. no signal. Have a look to see in the bios if there are settings for the built in card. Or if there is more than one monitor port available once the nvidia is removed. Or if there is, likewise, a bios setting to state the default.

Can’t think of anything else and the DIY build with backported kernel is a idea but it’s a bit of a job. See the Readme here for doing the build and @Hooverdan howto reference if you have another system you can install to and apply the kernel and btrfs-progs (filesystems) backports on that before moving it back to you desired (currently problematic) system.

Hope that helps.

1 Like

@phillxnet Thank you very much. Been using Qnap NAS but was thinking of switching to Rockstor because I have some hardware laying around with beter performance. But now I have run in on a problem which I can’t solve.

As you asked I indeed tried onboard graphics card, different HDMI-cables, but that didn’t work. Checked in bios if the onboard graphics card was activated and it is. Don’t know why isn’t working in Rockstor. So with that in mind I have to find another solution.

@carltorn Hello again.
Re:

I think there is hope as yet. I have seen some default graphics cards refuse to sync/start some older monitors. It may just be that. Althougt in this case given it appears to be both the internal and external it seems less likely. As suggested by @Hooverdan previously, you could just bypass this ‘issue’ and create the install on another machine first then transplant the system disk back into this system.

Seems like there is road left here for Rockstor given we are essentialy just a modern openSUSE Leap 15.3 base. A rather longer approach to installing on a donor system just to get that bit done and transferring back to the intended system is to attempt the generic Leap15.3 server install and follow the instructions on the download page entitled:

“Built on openSUSE Rpm”: Install on Vanilla openSUSE/SuSE SLES

A little more clunky but entirely doable. Plus we need more folks testing that approach in case I’ve missed something there. And we have had some folks reporting that a generic Leap 15.3 server install works on their hardware and our installer fails.

Failing all that, or for whatever reason, the open media vault project is a long running and well maintained DIY NAS of note :).

If you end up trying a generic Leap 15.3 server install and then have troubles with my instructions as per the download page then let us know here as improvement is always possible and the main Rockstor devs are keen on keeping this as an important alternative install method so that folks are not hampered by any bugs or short-falls in our own installer. Just a thought.

Hope that helps.

Correct me if I am wrong or there was simply a typo, but I think MSI makes the B450 Tomahawk Max II and the AMD Ryzen 5 3600 does not have built in graphics. The motherboard does not have on-board graphics capability unless a “G” model CPU is used.

I think you can cut out any tests with on-board graphics to simplify things.

Also, if not done already, a BIOS upgrade may prove beneficial.

FWIW, I will try a Rockstor install on my 5950x setup in a day or two and see if I get the same results.

Good Luck!

:sunglasses:

2 Likes

@Tex1954 you are absolutely right. My CPU doesn’t have built in graphics. Why didn’t I think about that? :rofl:

1 Like

Howdy again. Tried 5950x setup and ONE (funny,different,weird?) thing happened.

The Ryzen 9 5950X on Gigabyte Aorus X570 mobo has 2x 1TB NVME drives and a 480GB blank SSD installed with a TpLink 10GB NIC and a cheapo Nvidia GT 610 video card to test with. Probably this is the last bench test for these parts as they are going into a new water cooled WS.

I’ve run into many problems over the last few months, mostly due to my own ignorance and “need for speed” complex. LOL!

My latest fool (me) proof method of installing Rockstor is as follows and now works every time on dedicated hardware.

I took a USB stick that has the latest (a week ago?) Rockstor install and did the following:

  1. With Ryzen 9 5950X setup OFF, installed the USB stick, attached a monitor & usb kybd then started up the system.

  2. Hit “Del” key to get into setup. Went to Advanced mode and reset all bios setting to “Optimal Defaults”, saved and exited.

  3. Hit “Del” key again to get into bios, went advanced “Boot” options and selected option 1 as “SanDisk” (Sandisk is the USB stick). ALL other options disabled. DO NOT SELECT “UEFI SanDisk” if offered first! Select only the USB stick by itself and disable all others.

  4. Saved and exited and let the USB stick boot up, selected Install Rockstor etc. and go through all the prompts.

Weird thing during install:
The screen that I normally see go from VGA to Higher Res stayed in VGA mode. Keep in mind I used the same card on two other Intel Mobo’s that worked fine. Usually just after starting install, the screen resolution changed to high res… but not on the Ryzen 9 setup!

  1. Pushed power button to shut down, removed USB stick, restarted system. System seemed to boot fine. However, this time it booted High Res!

  2. I login as “root” with my password and there is all the Rockstor stuff I am used to seeing.

rockryzen2

  1. Went to old WS, entered the port in Firefox and followed the login stuff for a new setup.

RockRyzen1

  1. Clicked on the blinking “Update” thingy and did all the updates.

From that point on, everything seemed normal, disks showed up, DASHBOARD works, network works, all copacetic.

Hope that helps someone somewhere…

:sunglasses:

UPDATE:

Further testing, I tried the same setup with a GTX 980 instead and encountered no problems.

I tried again with an AMD HD7970 card and the system install hangs:

rockryzen3

Same setup with AMD HD7970 runs fine in windows (tested last).

Tested with GTX 980 and HD7970 because they run PCIe x16 instead of x8 like the GT 610 does.

UPDATE2:
2/27/22

Further testing, I tried the install on a GA-78LMT-USB3 Mobo that has the 760G chipset with built-in HD3000 graphics using 1045T CPU. I got the same garbled display mess.

I then installed the GT610 video card and all went well. After the install and updates, I shut it down, removed USB drive and rebooted and all was well.

I then removed the GT610 and rebooted and the screen stopped displaying after the Fuse thing. BUT, the WebUI worked fine!

Go figure, the AMD 760G chipset doesn’t seem supported, yet this board runs LinuxMint and Windows just fine. Maybe I should try a generic openSUSE Leap install.

Final Update 2/27/22:

openSUSE 15.3-2 installs with KDE GUI and runs fine.

Time to start on my new workstation…

:sunglasses:

4 Likes