Syncthing or transmission not access to web interface

I have been experimenting with syncthing but what ever i do i cannot get access to the web ui via 8080 accessing the ip of the rockstor server. I can see the docker container is running. And i can ping its ip from the cli on rockstor. I can see the nat rules and other fw rules. If i start the syncthing container as an interactive session i can access the internet and locsl network but only after i switched on ipv4 fowarding. I then thought maybe syncthing was broken so i enabled transmission but same problem. Has anyone got this working?

I personally have been using Syncthing Rock-on for a few weeks now and it works great. I’d like to help you right away, but we are making the ui better in the current release cycle and it’s best if we wait to discuss this matter once the release is out(in a couple of days). We are also going to have documentation to help prevent confusion. I’ll update this post in a few days.

We are still working on the update, but I figured out the main reason for Syncthing UI access problem. The upstream docker image maintainer changed the port mapping.

I see a few other changes and they are actually good in the long run. Anyway, just a quick update. More after we close the update.

That is good to know i might have another look and change the port back and see how i go.

Do you think you could make a testing rock on that had ssh and apache or somthing for experimenting?

Not sure what you would like to test and experiment. Can you explain?

As far as Syncthing and Transmission goes, your best bet is to wait till the update and once the update is out, 1) update Rockstor, 2) uninstall the current Syncthing and Transmission Rockons 3) Click the update button to update the metadata 4) Install Syncthing and Transmission again. You should be able to use same Share mapping, so no harm there.

Oh i was thinking if you could provide a generic container for people to learn and play with docker. Like this ssh host

Or similar and then maybe i could use that as the base to build a container to run sickbeard or sabnzbd+ or whatever other apps users want to run.

You can already ssh to rockstor if you didn’t know (and that may not be your point at all).

However, the idea of a generic “drop your own docker here” I like. No idea how difficult that would be to implement.

And of course, the userbase needs to understand that it couldn’t be a supported feature. However, it may lead to a more rapid development of supported rockons as the userbase experiments and finds things that appear to work well and add value.

To just orchestrate above docker wouldn’t be that hard but it’s not super trivial either. While it’s great for geeks like us, the vision behind Rock-Ons is to make great apps out there that can leverage Rockstor as a platform accessible to everybody without demanding much expertise. So, in the short term, we will have a growing set of apps that we the community like. Once there is more traction, we’ll make the framework more and more generic to the point where it will be easy for users to add their own apps. This is longer term. Note that this is different from just giving a docker playground. It’s more like a Rock-On hub or app store.

@sirhcjw I see that sickbeard is on our list. It is going to get easier and easier to add more Rock-Ons soon. We’d love for you to contribute apps that you like. For now though, I suggest you play with docker separately from Rockstor. We plan to add documentation soon about how to add new Rock-Ons.

Here’s the update I’ve been waiting to post. So with 3.8-2 update, the Rock-on system is significantly improved. @sirhcjw please uninstall your inaccessible Syncthing and Transmission Rock-ons. Then click the update button to pull new metadata. Then install your Rock-ons again. Please read the excellent documentation contributed by @phillxnet

Can someone point me to a manual rock-on clean up procedure I have syncthing in a broken state even though I have blown away the shares for rock-on’s and syncthing config when I re-enable rock-on’s it thinks syncthing is still installed and sits there indefinitely trying to start it.

Can you provide a screenshot?

[root@backup ~]# ls -al /mnt2/rockons/
total 12
drwxr-xr-x 1 root root 138 Jul 8 19:34 .
drwxr-xr-x 1 root root 186 Jul 8 22:15 …
drwx------ 1 root root 0 Jul 8 19:34 btrfs
drwx------ 1 root root 0 Jul 8 19:34 containers
drwx------ 1 root root 0 Jul 8 19:34 graph
drwx------ 1 root root 32 Jul 8 19:34 init
-rw-r–r-- 1 root root 5120 Jul 8 19:34 linkgraph.db
-rw------- 1 root root 19 Jul 8 19:34 repositories-btrfs
drwx------ 1 root root 0 Jul 8 19:34 tmp
drwx------ 1 root root 0 Jul 8 19:34 trust
drwx------ 1 root root 0 Jul 8 19:34 volumes

[root@backup ~]# ls -al /mnt2/rockons/containers/
total 0
drwx------ 1 root root 0 Jul 8 19:34 .
drwxr-xr-x 1 root root 138 Jul 8 19:34 …
[root@backup ~]#

There must be something in the database.

I had a hdd problem which turned out to be a faulty cable and I think something got corrupted with syncthing.

I could not remove syncthing so I blew away all the rockon and syncthing shares and then recreated them to remove all the config.but the problem persists.I guess worst case I could do a fresh install and import the pool but that would be a last resort in my opinion.

Try running this script:

It will remove all your Rock-on meta data. Then click update button and Syncthing should show in “All” tab.

If you have manually altered the Rock-on root share, I suggest you start with a new one. Please read the documentation to help clarify things.

Let me know.

Thanks that fixed it.

I switched off rock-ons
changed the default rock-on share to home
deleted the share I was using for rock-ons
ran your script
recreated the rock-on share
changed the default rock-on share to the new share I had just created
switched on rock-ons and it was fixed.

Thanks again.

Cool. Be sure to share your Syncthing experience, tips and expertise with others on Syncthing Rock-on

Bad news now syncthing has crashed


Continuous File Synchronization

Current status: exitcode: 1 error:

So the log file for the syncthing docker container is 7.8GB

[root@backup 94c3198928ec48c7007b27e9c2e44164fc45e30fee66c0e7975b261fee48ad4d]# ls -lah
total 7.8G
drwx------ 1 root root 278 Jul 9 17:20 .
drwx------ 1 root root 128 Jul 9 13:46 …
-rw------- 1 root root 7.8G Jul 9 15:11 94c3198928ec48c7007b27e9c2e44164fc45e30fee66c0e7975b261fee48ad4d-json.log
-rw-r–r-- 1 root root 3.2K Jul 9 15:11 config.json
-rw-r–r-- 1 root root 930 Jul 9 15:11 hostconfig.json
-rw-r–r-- 1 root root 13 Jul 9 13:46 hostname
-rw-r–r-- 1 root root 174 Jul 9 13:46 hosts
-rw-r–r-- 1 root root 71 Jul 9 13:46 resolv.conf
-rw------- 1 root root 71 Jul 9 13:46 resolv.conf.hash

Not sure if that is causing me issues or not?

ok so I have worked out that the logging for the syncthing rock-on is extremely verbose.

It is generating about 160MB of logs every 1 minute.

So it crashed because I only had a 10gb share for it.

Is it possible to fix this as anyone who tries to use it will have it work for a while and then crash like mine did.

and now the other problem is even thow I have mapped a 200GB share to syncthing to hold the files I am trying to sync all I get is “: disk quota exceeded” for every file it tries to create.