UI no longer accessible after upgrade

I’ve been hesitant to upgrade since my previous troubles in addition to my family constantly accesses data on the NAS but finally had a few hours free.

Followed instructions that were emailed to me:

  1. login to the system as root user
  2. run “yum update rockstor-3.8.15” command to explicitly upgrade to 3.8.15
  3. reboot the system with “shutdown -r now” command.

but now can’t access the UI. I can access my pools, just not the UI.

Read a thread that sometimes the UI takes a bit to initiate and that you can run “systemctl status -l rockstor-pre” so I did and received among other things Active: active (exited)

In addition, I’m getting:
BTRFS error (device sdc): space cache generation (136379) does not match inode (13638…

right after I boot up

So no UI but I can access my data. :frowning:

I got so fed up with this kind of thing happening with Rockstor, after the 3rd time of the system going tits up, I just installed an Ubuntu server, setup RAID1, LVM, ext4, samba and now solid as a rock. Oh and Plex is now fully up to date as opposed to the old version in the plex rockon. I can reboot or update it without worrying everything will break, and having to recover my data.

1 Like

I had a similar issue upgrading a 3.8.16-1 appliance. Web Gui would not come up after upgrade to 3.8.16-7.

Since i run Rockstor in my lab on a proxmox vm with proxmox snapshots, i was able to revert to the latest working version.

3.8.16-1 working (my rollback)
yum update rockstor-3.8.16-6 -> working
yum update rockstor-3.8.16-7 -> not working

Hi all,
testing on this


@wolf.f Cheers for confirming this in the testing channel update. I have reproduced here and it is currently under investigation. The testing channel updates version of Rockstor does and will break and is not recommended for production use. Linking to an earlier report of the same.
As you diagnosed this affects 3.8.16-7 release.

Hi @William212 & @wolf.f,
actually this solved, waiting for Rockstor update

From another forum thread


Sorry my fellow humans. But we just released 3.8.16-8 which fixes the issue. Please see Dev log for 3.9.0 - #10

yum update

:frowning: and the UI is still unavailable


Getting this on the screen (omitting the numerals):

Rockstor is successfully installed.

You can access the web-ui…
naskrock login: […] BTRFS error (device add) space cache generation () does not match node <>

then several rows of

[…] BTRFS error (device ssd): space cache generation() does not match inode ()

followed by 4 lines of

[…] BTRFS error (device ssd): csum mismatch of free space cache


systemmd[1]: failed to start Crash recovery kernel arming.

Would a fresh install resolve this?




Nothing? Do I just remain without a UI? What of those errors?

@William212 Those errors indicate an issue with the btrfs file system so yes a re-install may well help here if the issue is on the system drive, please see the Reinstalling Rockstor section of the official docs. Note that you may want to disconnect all your data drives during the re-install to avoid the risk of accidentally choosing the wrong drive to re-install.

Hope that helps.