Unable to check update due to a system error: (Error running a command. cmd

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Samba service an update cannot start

Detailed step by step instructions to reproduce the problem

The server was power off for 2 months. Today we power it up and from here the problems…

Web-UI screenshot

printsc

Error Traceback provided on the Web-UI

        Traceback (most recent call last):

File “/opt/rockstor/src/rockstor/storageadmin/views/command.py”, line 225, in post
return Response(rockstor_pkg_update_check(subscription=subo))
File “/opt/rockstor/src/rockstor/system/pkg_mgmt.py”, line 293, in rockstor_pkg_update_check
raise e
CommandException: Error running a command. cmd = /usr/bin/yum changelog 2020-Apr-21 rockstor. rc = 1. stdout = [‘Loaded plugins: changelog, fastestmirror’, ‘Loading mirror speeds from cached hostfile’, ‘’]. stderr = [’’, ‘’, ’ One of the configured repositories failed (Unknown),’, " and yum doesn’t have enough cached data to continue. At this point the only", ’ safe thing yum can do is fail. There are a few ways to work “fix” this:’, ‘’, ’ 1. Contact the upstream for the repository and get them to fix the problem.’, ‘’, ’ 2. Reconfigure the baseurl/etc. for the repository, to point to a working’, ’ upstream. This is most often useful if you are using a newer’, ’ distribution release than is supported by the repository (and the’, ’ packages for the previous distribution release still work).’, ‘’, ’ 3. Run the command with the repository temporarily disabled’, ’ yum --disablerepo= …’, ‘’, " 4. Disable the repository permanently, so yum won’t use it by default. Yum", ’ will then just ignore the repository until you permanently enable it’, ’ again or use --enablerepo for temporary usage:’, ‘’, ’ yum-config-manager --disable ‘, ’ or’, ’ subscription-manager repos --disable=’, ‘’, ’ 5. Configure the failing repository to be skipped, if it is unavailable.’, ’ Note that yum will try to contact the repo. when it runs most commands,’, ’ so will have to try and fail each time (and thus. yum will be be much’, ’ slower). If it is a very temporary problem though, this is often a nice’, ’ compromise:’, ‘’, ’ yum-config-manager --save --setopt=.skip_if_unavailable=true’, ‘’, ‘Cannot retrieve metalink for repository: epel/x86_64. Please verify its path and try again’, ‘’]

[paste here]

@alin.stancu Welcome to the Rockstor community.
From:

and:

It looks like the epel repository is either not reachable or having issues. We have seen them ‘waver’ on occasions.

To double check try, as the root user:

yum update

As the output may be informative. You may just have to accept a newer certificate or the like.

And if you paste the output in the forum be careful not to paste your Appliance ID and activation code which may appear in that output against the Stable Channel repository. Note that from the Web-UI you are running 3.9.2-57 which was released on 25th April 2020 so only a month ago today. Maybe the error shown is from an automated update event, if you have them enabled, and it found the failing epel repo and reported it.

Hope that helps.