Unable to start owncloud

Hello. Im sorry if i should have posted this in the other “owncloud issue with start/install”-post, but i think i have a slightly different issue, since a complete reinstall did not solve my problem.

The owncloud rockon installs, and does not indicate that anything is wrong, but the browser page does not load owncloud, but a “connection failed” instead. Ive tried the following things, and none of it has solved my issue:

  • Started, stopped the rockon service
  • Reinstall with different (new) shares.
  • A complete reinstall where i formated my hdds and dd:ed a fresh copy of rockstor on my thumb drive (in 3.8-13)
  • Same as above, but with the newly released 3.8-14 instead.

Any suggestions?


Try to connect to your machine via ssh.
Place the “docker ps -a” command after you have startet the owncloud rockon via Web-GUI and show us the output of it.

Hello and thanks for trying to help me! This is the output of that command:

CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS                                PORTS                           NAMES
81d0f212e3f8        pschmitt/owncloud   "/usr/bin/run.sh"        23 hours ago        Restarting (1) 32 minutes ago   80/tcp,>443/tcp   owncloud
9c210f539cd6        postgres            "/docker-entrypoint.s"   23 hours ago        Up About an hour                5432/tcp                        owncloud-postgres

Thanks for the output.
Looks like your owncloud container is faulty.
You can try to run the “docker events“ command and then stop and start the rockon via Web-GUI. If you see something like

… Kill
On the ssh session there might be an issue which I had myself…
I solved it by reinstalling Rockstor. But you can try first to create new shares for owncloud and reinstall it.
You can backup your Owncloud data first by setting it up as samba share.
Maybe there is another solution, but I did it this Way. Sorry for having no good news for you…

I’m not very comfortable with docker containers and how docker hub functions, but this specific container has been showing build error for the past weeks https://hub.docker.com/r/pschmitt/owncloud/builds/. The corresponding logs on hub.docker are empty so I don’t know what this really means (especially given that the docker seems to have been untouched for months on Github.
Could removing the image force Rockstor to re-pull the image upon the rock-on reinstall?
Of course, I noticed that @suman is apparently considering using the official docker image now so maybe that’s what you’re using…

Open an ssh session and run “find /. -name run.sh | grep owncloud”

Note: this is from memory, I can’t recall if the | grep owncloud is required

In my system, this found about 15 run.sh scripts, all in long directory names containing random letters. ONE of these run.sh files is the file owncloud runs to start up, but all of them are identical. I don’t know how to tell which is which.

Owncloud is choking when it tries to create a link that already exists. To fix it, you just need to change the name of the link it is creating.

To fix it, open the run.sh file (or just open the one that owncloud runs if you can figure out which one it is) owncloud uses, search for “localtime” (without quotes) and change it to “localtime2”

Stop and restart the docker from the web GUI and I suspect it will start.

Note:I have an untested theory that if your system time was set to UTC and not a specific timezone, the docker would start without changing that link. Again, this is an untested theory and it is based on my thoughts today about observations when I dug into this weeks ago. I also have a theory that tiny monkeys live in your computer and are clobbering owncloud every time it tries to start up. I’m not sure which theory is more plausible.

I’m having the same issue, owncloud docker is not starting

already tried searching for the run.sh file with the timezone mentioned in it but it is nowhere to be found.
any other suggestions?