Unable to start Samba Service : samba_service.py", line 123

Hello all,
I have a new installation, still a 3.9.2 version but fully updated, where “SAMBA service” can not start!

Makes errors linke:

Houston, we’ve had a problem.
Failed to start samba due to a system error: Error running a command. cmd = /usr/bin/systemctl start smb. rc = 1. stdout = [’’]. stderr = [‘Job for smb.service failed. See “systemctl status smb.service” and “journalctl -xe” for details.’, ‘’]

        Traceback (most recent call last):

File “/opt/rockstor/src/rockstor/smart_manager/views/samba_service.py”, line 123, in post
systemctl(“smb”, command)
File “/opt/rockstor/src/rockstor/system/services.py”, line 77, in systemctl
return run_command([SYSTEMCTL_BIN, switch, service_name], log=True)
File “/opt/rockstor/src/rockstor/system/osi.py”, line 176, in run_command
raise CommandException(cmd, out, err, rc)
CommandException: Error running a command. cmd = /usr/bin/systemctl start smb. rc = 1. stdout = [’’]. stderr = [‘Job for smb.service failed. See “systemctl status smb.service” and “journalctl -xe” for details.’, ‘’]

Does some have any idea?
How can i re-instal SAMBA?

MiH

@haf Welcome to the Rockstor community and thanks for transferring this conversation to the forum from support email.

As per the error message:

i.e.:

systemctl status smb.service

and

journalctl -xe

Could you post the output of those 2 commands, run as root, on the Rockstor instance.
Also

yum info rockstor

to pin down the revision of 3.9.2 (you are likely on the last in that run though which was 3.9.2-57):


But we need that output to confirm the exact version installed.

@Flox Sorry to tag you on this as I know you are super busy but you’ve also successfully narrowed down a number of these samba start issues in the past. In a prior support email thread with @haf I’ve sighted the following threads here on the forum:

Forum posts to check out are for example:


As a start. Each thread in turn links to others that may help.

So with the output of those 3 commands we should be able to get you up and running as there are only really a couple of known issues and many folks are otherwise using the samba feature on both our older 3 and newer 4 varaints.

Hope that helps and thanks again for the report here.

1 Like