Unknown internal error doing a POST to /api/commands/update-check

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

After trying to load “https://ip/#version

Detailed step by step instructions to reproduce the problem

[write here]

Web-UI screenshot

Error Traceback provided on the Web-UI

Houston, we've had a problem.
Unknown internal error doing a POST to /api/commands/update-check

Hi @g6094199,
99% your issue related to recent well know problems over connection to Rockstor repository, so don’t worry about that


@g6094199 Are you still experiencing this issue as I’m rather hoping that the repo issue @Flyer referenced is now sorted.

Awaiting further confirmation over at the following forum thread:

Hi, I’m running on 3.9.0-3 and if I go to the system update webUI I get the same error as stated above…no way to change the update channel or to perform any update (beside the error the page stays white)? Any idea?

Also running yum update from the terminal gives the following message :confused:

[root@rockstor ~]# [root@rockstor ~]# yum update
Existing lock /var/run/yum.pid: another copy is running as pid 21608.
Another app is currently holding the yum lock; waiting for it to exit…
The other application is: yum
Memory : 34 M RSS (419 MB VSZ)
Started: Fri Jun 16 12:51:32 2017 - 02:34 ago
State : Sleeping, pid: 21608

I am hitting same issue on It’s first time clicking on “update” button on HP GEN8. Tried on latest firefox and chrome with same issue.

"Houston, we’ve had a problem.

Unknown internal error doing a POST to /api/rockons/update"


can you check if you face also the very same error via the terminal using yum update?

With this blockage it sounds we can’t get any updates at all (Rockstor testing channel nor other packages) :scream:

Now the hourly cron email service keeps posting…every hour!

Updateinfo file is not valid XML: <open file '/var/cache/yum/x86_64/$releasever/epel/gen/updateinfo.xml', mode 'rt' at 0x16296f0>

@phillxnet, @Flyer, @suman any additional input we can provide in order to get this strange behaviour solved?


I get the same error. Updateinfo file is not valid XML

Same here, although mine comes as email warnings every hour. My mailbox was close to exploding this morning :stuck_out_tongue:

Same here, but it seems to be a problem on the repository side. Should be fixed soon, however, according to this:

Postby avij » 2017/06/21 17:44:44

This is an EPEL problem, and EPEL is not managed by CentOS.

That said, there has indeed been a problem in EPEL today and fixed EPEL repository files are currently being synced to mirrors. It may take a while. yum clean all may help, and yum update may also work.


Hi @suman and @Flyer ,

with reference to your reply in the 3.9.1 development log thread, I post here my reply as it seems to fit better here.

I’ve used ps -A | grep yum and kill to close all ongoing yum processes.

Then I was running yum clean all and after that yum update
Now I get the following error, no change over time
> [root@rockstor ~]# yum update

Loaded plugins: changelog, fastestmirror
http://a8c08601-fdad2a03-a3ac-4680-9b9f-c2ad1f437264:51AMIU2vgQZfkX5KhnRvpA==@updates.rockstor.com:8999/rockstor-stable/repodata/repomd.xml: [Errno 12] Timeout on http://a8c08601-fdad2a03-a3ac-4680-9b9f-c2ad1f437264:51AMIU2vgQZfkX5KhnRvpA==@updates.rockstor.com:8999/rockstor-stable/repodata/repomd.xml: (28, 'Connection timed out after 30001 milliseconds')
Trying other mirror.

I’ve tried to reboot the server…getting first the same error as stated above

If I kill again all yum processes and hit yum update result in the error that no mirror works :disappointed_relieved:

Any idea?